SOLVED: conky on startup xfce debian

Forum rules
Before you post please read how to get help

SOLVED: conky on startup xfce debian

Postby aljoriz on Thu May 05, 2011 5:38 am

Facts:
1. I installed conky
2. Added a script that has transparency
3. I changed the default wallpaper (emavibe silver to something else)
4. I added conky to the application auto start under session and startup

When I rebooted I saw the default emavibe wallpaper with conky but was quickly replaced with the new wallpaper I had installed but it has no conky.
Last edited by aljoriz on Sat May 14, 2011 6:52 pm, edited 1 time in total.
aljoriz
Level 4
Level 4
 
Posts: 269
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Linux Mint is funded by ads and donations.
 

Re: Help: conky on startup xfce debian

Postby jeffreyC on Thu May 05, 2011 6:17 pm

In Xfce 4.8 own_window_type desktop does not give transparency
own_window_type override does give transparency

Xfce places the wallpaper on a layer above the root window
Get Dropbox and an extra 250 mb http://db.tt/wAizqw0
jeffreyC
Level 4
Level 4
 
Posts: 318
Joined: Mon Jun 07, 2010 9:34 pm

Re: Help: conky on startup xfce debian

Postby aljoriz on Thu May 05, 2011 6:33 pm

so how do I get around to changing the root windows, is that it?
aljoriz
Level 4
Level 4
 
Posts: 269
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: Help: conky on startup xfce debian

Postby jeffreyC on Thu May 05, 2011 7:13 pm

The root window is under the wallpaper, maybe if you used something like SLiM and made a theme with the same background ?
But that is a workaround not really a fix.
Get Dropbox and an extra 250 mb http://db.tt/wAizqw0
jeffreyC
Level 4
Level 4
 
Posts: 318
Joined: Mon Jun 07, 2010 9:34 pm

Re: Help: conky on startup xfce debian

Postby phredbull on Tue May 10, 2011 4:09 pm

In my experience with using Conky w/compositing, you need to have a delay in your Conky startup script to give the compositor time to get up and running; here's my Conky startup script:
Code: Select all
#!/bin/sh

# click to start, click to stop

if pidof conky | grep [0-9] > /dev/null
then
 exec killall conky
else
sleep 18
 exec conky -c ~/Scripts/conkyrc.time &
 exec conky -c ~/Scripts/conkyrc.weather &
 exec conky -c ~/Scripts/conkyrc.system &
 exec conky -c ~/Scripts/conkyrc.wireless &
 exec conky -c ~/Scripts/conkyrc.keys

 fi

Note the "sleep 18"; this makes Conky wait 18 seconds after login to launch, (which is not very long, a bit after the desktop and panel are up). You can play w/this number to suit your needs.
BTW, you can remove the sleep command and use this script for a Conky start/stop switch, either as a desktop/panel launcher, or assign a key command to it...

Edit: if you're using Nautilus, Nautilus may be drawing a desktop on top of everything; in that case, I'd disable the Nautilus desktop. I don't remember how off hand, but I'm sure Google will have plenty of how-tos.
If you're NOT using Nautilus, but are using DropBox, (I'm not), see this thread...
Apple iMac, Core2Duo 2.0gHz, 3gb, ATI Radeon Mobility X1600
-Mint Nadia Cinnamon
-Mac OSX 10.5.8
Compaq Evo N610c, P4M 2.8gHz, 7688mb, ATI Radeon m7500
-LMDE XFCE
-Mint Katya Gnome
-Windoze XP
Ext. HD
-Mint Isadora Fluxbox
USB stick
-#! Statler
User avatar
phredbull
Level 1
Level 1
 
Posts: 42
Joined: Wed Dec 01, 2010 8:55 pm
Location: Chicago, IL, USA

Re: Help: conky on startup xfce debian

Postby aljoriz on Tue May 10, 2011 6:38 pm

that's a great work around but still not a solution.
aljoriz
Level 4
Level 4
 
Posts: 269
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: Help: conky on startup xfce debian

Postby phredbull on Tue May 10, 2011 11:07 pm

AFAIK, Conky must start after the desktop is drawn, and if you use compositing, after that starts. A startup script like the one I posted seems to be the standard way to achieve this, so it's not a workaround, it's a way to make Conky auto-start correctly.
Apple iMac, Core2Duo 2.0gHz, 3gb, ATI Radeon Mobility X1600
-Mint Nadia Cinnamon
-Mac OSX 10.5.8
Compaq Evo N610c, P4M 2.8gHz, 7688mb, ATI Radeon m7500
-LMDE XFCE
-Mint Katya Gnome
-Windoze XP
Ext. HD
-Mint Isadora Fluxbox
USB stick
-#! Statler
User avatar
phredbull
Level 1
Level 1
 
Posts: 42
Joined: Wed Dec 01, 2010 8:55 pm
Location: Chicago, IL, USA

Re: Help: conky on startup xfce debian

Postby jeffreyC on Sat May 14, 2011 4:36 pm

Delaying the start of conky IS the standard method because it depends on other things to be running first.
This is not a workaround, it is the normal start up sequence, if you use Gnome or KDE you would need an even longer delay than with Xfce.
Get Dropbox and an extra 250 mb http://db.tt/wAizqw0
jeffreyC
Level 4
Level 4
 
Posts: 318
Joined: Mon Jun 07, 2010 9:34 pm

Re: Help: conky on startup xfce debian

Postby aljoriz on Sat May 14, 2011 6:34 pm

I see thank you for enlightening me. For the benefit of newbies do they use the script?
at the terminal:
sudo gedit .conky_start.sh
Code: Select all
#!/bin/sh

# click to start, click to stop

if pidof conky | grep [0-9] > /dev/null
then
exec killall conky
else
sleep 18
exec conky -c ~/Scripts/conkyrc.time &
exec conky -c ~/Scripts/conkyrc.weather &
exec conky -c ~/Scripts/conkyrc.system &
exec conky -c ~/Scripts/conkyrc.wireless &
exec conky -c ~/Scripts/conkyrc.keys

fi


Save at the terminal:
Code: Select all
chmod a+x .conky_start.sh


Now go to Menu>Settings>Session & Startup > Application autostart press add
Enter any name that would want for the conky.

I used conky, for the command? its the location of the script hence:
/home/(username)/.conky_start.sh
aljoriz
Level 4
Level 4
 
Posts: 269
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: SOLVED: conky on startup xfce debian

Postby phredbull on Mon May 16, 2011 6:27 pm

You can copy the startup script I posted above, but replace the lines
Code: Select all
exec conky -c ~/Scripts/conkyrc.time &
with the name and location of your Conky. I have multiple Conkys; if you only have 1 Conky, use only 1 exec line without the & symbol at the end. Save the file, (mine is called "Conky startup"), right click on the file and go to Properties>Permissions and click "Allow this file to run as a program".
Add "/home/username/path/to/Conky startup" to your startup items, and adjust the "sleep #" as needed.

Enjoy! 8)

edit: It sounds like what you posted above should work, just replace the info in the script with your own Conkys.
Apple iMac, Core2Duo 2.0gHz, 3gb, ATI Radeon Mobility X1600
-Mint Nadia Cinnamon
-Mac OSX 10.5.8
Compaq Evo N610c, P4M 2.8gHz, 7688mb, ATI Radeon m7500
-LMDE XFCE
-Mint Katya Gnome
-Windoze XP
Ext. HD
-Mint Isadora Fluxbox
USB stick
-#! Statler
User avatar
phredbull
Level 1
Level 1
 
Posts: 42
Joined: Wed Dec 01, 2010 8:55 pm
Location: Chicago, IL, USA

Re: SOLVED: conky on startup xfce debian

Postby Roken on Mon May 16, 2011 8:19 pm

You could, alternatively, have conky start with your system, and change the script as follows:

Code: Select all
    #!/bin/sh

    sleep 18
    killall -SIGUSR1 conky


This will force conky to reload after 18 seconds.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Linux Mint is funded by ads and donations.
 

Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 1 guest