Enable Compiz For the x64 Mint Running In Virtual Box

Forum rules
Before you post please read this

Enable Compiz For the x64 Mint Running In Virtual Box

Postby derek777 on Fri Dec 09, 2011 12:39 am

My host OS - Windows Server 2008 R2 SP1
My guest OS - Linux Mint 12 Lisa x64

My problem - I want to enable the linux eye-candy 3d effects such as cube and switcher.

What I have done:

- set 3D support with 128 Mb in Virtual Box
- checked "3D Acceleration"
- installed virtual box additions
- rebooted
- tried compiz configurator but still no luck


=> What else needs to be done?
=> Is compiz possible with x64 virtual maches?

Thank You very much,

Derek.
derek777
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 09, 2011 12:17 am

Linux Mint is funded by ads and donations.
 

Re: Enable Compiz For the x64 Mint Running In Virtual Box

Postby derek777 on Sat Dec 10, 2011 8:30 am

Same way I'm stuck with Linux Mint 12 x86, while I have seen people do it years ago!

http://www.youtube.com/watch?v=qhvWDnj8EbU

Clues would be good, I'm counting on your help GUYS.

My real hardware - Core2Qiad 8Gb ATI5870.
derek777
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 09, 2011 12:17 am

Re: Enable Compiz For the x64 Mint Running In Virtual Box

Postby zerozero on Sat Dec 10, 2011 8:40 am

yes, you saw that done years ago but with gnome2.x; with Mint12, unless you login in gnome-classic or MATE you won't be able to run compiz: gnome aka gnome-shell uses mutter and is incompatible with compiz.
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Enable Compiz For the x64 Mint Running In Virtual Box

Postby derek777 on Sat Dec 10, 2011 9:45 am

Hi zerozero, thank you very much for the clarification. This is my first experience with Linux after I read many reviews and watched lots of videos. The system looks awsome indeed and I'm anxious to try it out in virtualbox before I install another SATA for real Mint.

So, would you please tell me how do I login in gnome-classic or MATE, and which of these two should I prefer?
derek777
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 09, 2011 12:17 am

Re: Enable Compiz For the x64 Mint Running In Virtual Box

Postby derek777 on Sat Dec 10, 2011 10:12 am

Quick update, yes I see how to login in:

Gnome
Gnome Classic
Gnome Classic (No Effects)
MATE


Tried them all, still no luck with windows cube and other fancy effects. Trying to figure out why ...
derek777
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 09, 2011 12:17 am

Re: Enable Compiz For the x64 Mint Running In Virtual Box

Postby derek777 on Mon Dec 12, 2011 3:08 pm

derek777 wrote:Quick update, yes I see how to login in:

Gnome
Gnome Classic
Gnome Classic (No Effects)
MATE


Tried them all, still no luck with windows cube and other fancy effects. Trying to figure out why ...


:)

Image

:)

I got things finally sorted. In virtual box it works not only under "Gnome Classic" but in other shells too. However, it always takes me to "Reload Window Manager" from the fusion icon before I can see the effects, compiz doesn't start automatically in virtual box. Anyway for other linux noobs like me, this is what I did:


1. Install Linux

Image


2. Install Guest Additions (from your virtual machine's menu) and reboot

Image


3. Login in Gnome or Gnome Classic for better compatibility

Image


4. Start software manager and type in the search word "compiz". Install "Fusion Icon" and "Compiz Configurator known as "CCSM"

ImageImage

ImageImage


5. Launch the "Compiz Configurator" and configure various desktop and windows effects. Be default you have 2 workspaces, you may wanna go to CCSM -> General -> Desktop Size to increase to 4

ImageImage


6. Launch the "Fusion Icon", right-click it and choose "Reload Window Manager"

Image


7. Now you should see that Linux "Aero" with desktops and switchers (as configured in your Compiz Config Settings Manager)

ImageImage


:) :) :) :) :) :) :)

Image
derek777
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 09, 2011 12:17 am


Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 2 guests