Mint 12 - No Compiz with Intel N10 graphics

Forum rules
Before you post please read this

Mint 12 - No Compiz with Intel N10 graphics

Postby fpeelo on Tue Feb 07, 2012 3:01 pm

I got a new computer and put Linux Mint 12 on it. It mostly works fine, but I have no 3D effects on my display. Could anyone help me get them working?

I found a program in the Synaptic Package Manager, compiz-check. It tells me I have
Distribution: Linux Mint 12
http://www.linuxmint.com/rel_lisa.php
Desktop environment: Unknown
Graphics chip: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
/usr/bin/compiz-check: line 199: [: too many arguments
/usr/bin/compiz-check: line 201: [: too many arguments
Driver in use: vesa
Rendering method: AIGLX

and VESA does not support compiz. Google showed me this:
viewtopic.php?f=59&t=75893
which looks spookily familiar, but is from last June, forum rules say not to reply from posts 6 months old, so I start a new thread.

The old thread did not come to a conclusion. The poster seems to have lost interest and gone elsewhere. Several questions were asked in that thread; to save time, here are the answers as they apply to my machine.
  • Mint version is 12. Desktop environment ("Unknown" above) is MATE because Gnome 3 was just annoying.
  • xserver-xorg-video-intel is installed, version 2:2.15.901-1ubuntu2.1, which seems to be the latest.
  • Kernel is whatever Mint 12 installer put on; I have not compiled a custom kernel, nor do I want to.
  • One question on the older thread was whether 'compatibility mode' was used when installing. I don't know, so unless it is the default the answer is "probably no". Nor did I add anything to the kernel line in the bootloader. Wouldn't know how. So I don't think there is any nomodeset or xforcevesa in there, as suggested in the older thread.
  • My /etc/default/grub is listed below
  • lspci -k includes the following:
    00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
    Subsystem: Intel Corporation Device 574d
    Kernel driver in use: i915
    Kernel modules: i915
  • There is no file /etc/X11/xorg.conf on my machine.

My /etc/default/grub is
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


Last bumped by fpeelo on Tue Feb 07, 2012 3:01 pm.
fpeelo
Level 1
Level 1
 
Posts: 17
Joined: Wed Nov 16, 2011 7:44 pm

Linux Mint is funded by ads and donations.
 

Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 2 guests