Mint 12, Intel, Compiz

Forum rules
Before you post please read how to get help

Mint 12, Intel, Compiz

Postby slezica on Mon Feb 20, 2012 8:04 pm

I'm having trouble with Compiz in Mint 12.

First, I was using the vesa drivers, so Compiz failed to start. I switched to intel by removing the vesa packages, installing libgl1-mesa-dri and libgl1-mesa-dlx along with xserver-xorg-vide-intel, and now Compiz starts but is incredibly glitchy. Switching workspaces makes everything blink uncontrollably, for example. I don't know what to try next.

Some diagnostic info:

Code: Select all
inxi -Gx
Graphics:  Card: Intel Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           X.Org 1.10.4 drivers intel,fbdev Resolution 1366x768@76.0hz
           GLX Renderer Gallium 0.4 on llvmpipe (LLVM 0x209) GLX Version 2.1 Mesa 8.1-devel (git-6e738d3 oneiric-oibaf-ppa) Direct Rendering Yes


The compiz-check script I found scattered all over the web reports:

Code: Select all
./compiz-check

Gathering information about your system...

 Distribution:          Linux Mint
 Desktop environment:   GNOME
 Graphics chip:         Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
 Driver in use:         fbdev
 Rendering method:      AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [ OK ]
 Checking for non power of two support...          [ OK ]
 Checking for composite extension...               [ OK ]
 Checking for FBConfig...                          [ OK ]
 Checking for hardware/setup problems...           [ OK ]


To be fair, I did get a warning about me having a weird graphics card, and possible poor Compiz reliability. Can I fix this?
slezica
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 19, 2012 12:52 pm

Linux Mint is funded by ads and donations.
 

Re: Mint 12, Intel, Compiz

Postby slezica on Mon Feb 20, 2012 9:17 pm

After many different tries, adding "acpi_osi=" to the kernel command-line in GRUB fixed my problem. For future reference:

To give this a one-shot try
    1. Hold SHIFT during boot (this lands you in the GRUB menu if its skipped by default)
    2. Put the cursor over the Mint entry (usually the first) and press 'e' to edit it
    3. Add "acpi_osi" to the options in the line that begins with "linux" (usually after "quiet nosplash")

If this works, you'll want to avoid having to make this change manually every time you boot.

To set this permanently
    1. Edit the file /etc/default/grub (with sudo), and add "acpi_osi=" to GRUB_CMDLINE_LINUX_DEFAULT
    Code: Select all
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

    2. Run grub-update as root

Hope it helps someone
slezica
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 19, 2012 12:52 pm


Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 2 guests