Slow maximize speed with Compiz

Forum rules
Before you post please read this

Slow maximize speed with Compiz

Postby kaneeec on Tue Feb 21, 2012 3:20 pm

I perfomed a huge system upgrade today. And a problem occured - window maximization takes a few seconds which is terrible. I used to fix it with this patch but I have the system too new now and the patch says it cannot be installed.

I tried to force the installation but it ruined the xorg and I had to revert it back in recovery mode.

Do you have any ideas how to fix this? I can provide more information if you say so.

Info
Code: Select all
kernel: 2.6.32-21-generic #32-Ubuntu SMP
dist: Linux Mint Isadora
driver: fglrx 2:8.723.1-0ubuntu6
kaneeec
Level 1
Level 1
 
Posts: 7
Joined: Tue Nov 30, 2010 1:39 pm

Linux Mint is funded by ads and donations.
 

Re: Slow maximize speed with Compiz

Postby RAWRferal on Tue Feb 21, 2012 5:16 pm

Hi there. What are your system specs? Do you have a dedicated graphics card? If so, are your drivers up to date?
Image
Inspiron 910 | Atom N270 | 2GB DDR2 | 16GB SSD | Mint 12 'Lisa' Cinnamon
User avatar
RAWRferal
Level 2
Level 2
 
Posts: 76
Joined: Sat Feb 18, 2012 5:21 am
Location: London, UK

Re: Slow maximize speed with Compiz

Postby kaneeec on Tue Feb 21, 2012 5:59 pm

I have Radeon 3650HD and the fglrx driver was updated today so it should be the newest as possible.

Code: Select all
*-display
                description: VGA compatible controller
                product: Mobility Radeon HD 3650
                vendor: ATI Technologies Inc
                physical id: 0
                bus info: pci@0000:01:00.0
                version: 00
                width: 32 bits
                clock: 33MHz
                capabilities: pm pciexpress msi bus_master cap_list rom
                configuration: driver=fglrx_pci latency=0
                resources: irq:32 memory:d0000000-dfffffff(prefetchable) ioport:2000(size=256) memory:cfff0000-cfffffff memory:cff00000-cff1ffff(prefetchable)
kaneeec
Level 1
Level 1
 
Posts: 7
Joined: Tue Nov 30, 2010 1:39 pm

Re: Slow maximize speed with Compiz

Postby RAWRferal on Tue Feb 21, 2012 6:13 pm

Hmm, in which case I've had a little search. Have you tried this xserver build with no back fill? https://launchpad.net/~ubuntu-x-swat/+archive/xserver-no-backfill

Apparantly it's an issue conflicting with ATI catalyst drivers and many users running ubuntu report it fixes the issue.

Thread: http://ubuntuforums.org/showthread.php?p=8467405
Image
Inspiron 910 | Atom N270 | 2GB DDR2 | 16GB SSD | Mint 12 'Lisa' Cinnamon
User avatar
RAWRferal
Level 2
Level 2
 
Posts: 76
Joined: Sat Feb 18, 2012 5:21 am
Location: London, UK

Re: Slow maximize speed with Compiz

Postby RAWRferal on Tue Feb 21, 2012 6:15 pm

Also if you still have trouble, try installing the open source driver as opposed to the proprietry as some users are reporting a fix that way!
Image
Inspiron 910 | Atom N270 | 2GB DDR2 | 16GB SSD | Mint 12 'Lisa' Cinnamon
User avatar
RAWRferal
Level 2
Level 2
 
Posts: 76
Joined: Sat Feb 18, 2012 5:21 am
Location: London, UK

Re: Slow maximize speed with Compiz

Postby kaneeec on Tue Feb 21, 2012 6:29 pm

RAWRferal wrote:Hmm, in which case I've had a little search. Have you tried this xserver build with no back fill? https://launchpad.net/~ubuntu-x-swat/+archive/xserver-no-backfill

Apparantly it's an issue conflicting with ATI catalyst drivers and many users running ubuntu report it fixes the issue.

Thread: http://ubuntuforums.org/showthread.php?p=8467405

Yeah. That's the driver I mentioned in the first post (I've forgotten to add link). So it was working before the update.

Fglrx is a proprietary driver? If so, which is the open source?

I think I have only the flrgx installed... I have never installed any other and I don't know if something is installed by default
kaneeec
Level 1
Level 1
 
Posts: 7
Joined: Tue Nov 30, 2010 1:39 pm

Re: Slow maximize speed with Compiz

Postby RAWRferal on Tue Feb 21, 2012 6:47 pm

Fglrx is proprietary. If the open source drivers are available you should find them in system settings > additional drivers.
Image
Inspiron 910 | Atom N270 | 2GB DDR2 | 16GB SSD | Mint 12 'Lisa' Cinnamon
User avatar
RAWRferal
Level 2
Level 2
 
Posts: 76
Joined: Sat Feb 18, 2012 5:21 am
Location: London, UK

Re: Slow maximize speed with Compiz

Postby kaneeec on Tue Feb 21, 2012 7:03 pm

RAWRferal wrote:Fglrx is proprietary. If the open source drivers are available you should find them in system settings > additional drivers.

I haven't found this additional drivers option, only the one where I can disable fglrx. I was looking for this open source driver but I've been able to find only a very old stuff. Do you know which deb package I should install or where I can find the version for my card?
kaneeec
Level 1
Level 1
 
Posts: 7
Joined: Tue Nov 30, 2010 1:39 pm

Re: Slow maximize speed with Compiz

Postby RAWRferal on Tue Feb 21, 2012 7:09 pm

Sorry my bad, apparantly with ATI if you uninstall the proprietary drivers and reboot it will use the open source ones by default. They are built into the kernel.
Image
Inspiron 910 | Atom N270 | 2GB DDR2 | 16GB SSD | Mint 12 'Lisa' Cinnamon
User avatar
RAWRferal
Level 2
Level 2
 
Posts: 76
Joined: Sat Feb 18, 2012 5:21 am
Location: London, UK

Re: Slow maximize speed with Compiz

Postby kaneeec on Wed Feb 22, 2012 4:52 am

Interesting. It's really working now :) Thank you!
kaneeec
Level 1
Level 1
 
Posts: 7
Joined: Tue Nov 30, 2010 1:39 pm

Re: Slow maximize speed with Compiz

Postby RAWRferal on Wed Feb 22, 2012 6:42 am

Ah that's great news! We got there eventually lol. I'm glad you got everything sorted :D
Image
Inspiron 910 | Atom N270 | 2GB DDR2 | 16GB SSD | Mint 12 'Lisa' Cinnamon
User avatar
RAWRferal
Level 2
Level 2
 
Posts: 76
Joined: Sat Feb 18, 2012 5:21 am
Location: London, UK

Linux Mint is funded by ads and donations.
 

Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 3 guests