Where to configure keyboard shortcuts in Cinnamon?

Where to configure keyboard shortcuts in Cinnamon?

Postby fschaap on Sat May 19, 2012 4:44 am

Is it me or is there no config tool for setting keyboard shortcuts in the Cinnamon menu?

I'd like to change/set some key bindings, but I haven't gotten nowhere the past hour or so :-\ Running Cinnamon on Debian Edition.
Linux Mint Debian Edition with Cinnamon
fschaap
Level 1
Level 1
 
Posts: 45
Joined: Mon Aug 02, 2010 8:37 am
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby AlbertP on Sat May 19, 2012 6:26 am

Most shortcuts are still configured in gnome's System Settings > Keyboard.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6515
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby fschaap on Sat May 19, 2012 8:05 am

So it is. I am so used to Linux Mint 9 where you can type "shortcut" in the Preferences window and get the appropriate settings dialog :-)

Still, I can't seem to get Mod4+E (left window key + e) to open Nautilus. I've added a shortcut called Nautilus, with the command "nautilus" and key binding Mod4+E... and nothing happens when I hit that key combination!

What am I doing wrong?
Linux Mint Debian Edition with Cinnamon
fschaap
Level 1
Level 1
 
Posts: 45
Joined: Mon Aug 02, 2010 8:37 am
Location: The Netherlands

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby AlbertP on Sat May 19, 2012 4:27 pm

Are you sure manually typing Mod4 is the right way to configure a shortcut with left Windows key? I'd have the shortcut captured, the key may well turn out to be named Super_L instead of Mod4.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6515
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby fschaap on Mon May 21, 2012 4:15 am

Yep, I use the capture function.

When I used this on LM9 with the same keyboard, it also said I was using the Mod4+E key combo. So no surprise there.

The surprise is that the shortcut doesn't seem to work at all. Never had that problem with Linux Mint 9.
Linux Mint Debian Edition with Cinnamon
fschaap
Level 1
Level 1
 
Posts: 45
Joined: Mon Aug 02, 2010 8:37 am
Location: The Netherlands

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby gychang on Mon May 21, 2012 10:22 am

Same problem here in Mint12. Ctrl-Alt combo works but not window superkey combo.

gychang
--
cruising the desert
--
User avatar
gychang
Level 3
Level 3
 
Posts: 143
Joined: Tue Dec 09, 2008 12:24 pm

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby ZeckeSZ on Tue May 22, 2012 2:34 am

Open gconf-editor --> apps --> metacity --> global_keybindings --> run_command_1

Type <Super>x

Goto keybindings_commands --> command_1

Type <your_command>

Works here with Mint 12 / LMDE + Cinnamon

HTH
ZeckeSZ
Level 1
Level 1
 
Posts: 2
Joined: Tue May 22, 2012 1:37 am
Location: Germany

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby fschaap on Tue May 22, 2012 5:41 am

Okay, this is just plain crazy...

In Cinnamon, I use the Menu, go to Preferences > Keyboard > Shortcuts > Custom Shortcuts. I add a shortcut, give it a name and a command to run. Then I use the key capture function to grab the key combination. I hit the left Windows key and "e". This registers as "Mod4+E".

Next, when I use the left Windows key + E combination: nothing happens.

Now, when I use the right Windows key + E combination: tadaa, the command is run (and in my case Nautilus starts).

This is silly, right? I use the capture function to grab a key combination and it does the switcharoo on me! (And repeating myself... this works fine on LM9.)
Linux Mint Debian Edition with Cinnamon
fschaap
Level 1
Level 1
 
Posts: 45
Joined: Mon Aug 02, 2010 8:37 am
Location: The Netherlands

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby fschaap on Tue May 22, 2012 5:49 am

ZeckeSZ wrote:Open gconf-editor --> apps --> metacity --> global_keybindings --> run_command_1


Well, that works. When I use the gconf-editor and I set a keybinding for <Mod4>E and the command to run Nautilus, it works with both the left and the right Windows key + E.

Actually, I first need to remove the shortcut that I added through the keyboard preference, because as long as that was there, the left Windows key would just not work.

Is this something that needs to be reported upstream? If so, where? Anyone knowledgeable enough to point me to the right issue queue?
Linux Mint Debian Edition with Cinnamon
fschaap
Level 1
Level 1
 
Posts: 45
Joined: Mon Aug 02, 2010 8:37 am
Location: The Netherlands

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby gychang on Tue May 22, 2012 10:57 am

fschaap wrote:Okay, this is just plain crazy...

In Cinnamon, I use the Menu, go to Preferences > Keyboard > Shortcuts > Custom Shortcuts. I add a shortcut, give it a name and a command to run. Then I use the key capture function to grab the key combination. I hit the left Windows key and "e". This registers as "Mod4+E".

Next, when I use the left Windows key + E combination: nothing happens.

Now, when I use the right Windows key + E combination: tadaa, the command is run (and in my case Nautilus starts).

This is silly, right? I use the capture function to grab a key combination and it does the switcharoo on me! (And repeating myself... this works fine on LM9.)


on my LM13 RC, when I click on Windows key + w to start my chromium, (on either L or R Windows key) it registers as Super+W. and when I try to use the key combo, tiny command window opens on the bottom. Using either R or L windows key, this happens withour starting the chromium.

this must be a bug...

gychang
--
cruising the desert
--
User avatar
gychang
Level 3
Level 3
 
Posts: 143
Joined: Tue Dec 09, 2008 12:24 pm

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby gychang on Tue May 22, 2012 11:28 am

ZeckeSZ wrote:Open gconf-editor --> apps --> metacity --> global_keybindings --> run_command_1

Type <Super>x

Goto keybindings_commands --> command_1

Type <your_command>

Works here with Mint 12 / LMDE + Cinnamon

HTH


on my LM12 debian Cinnamon machine (I have both versions installed). I did follow the instructions and seems to work, thanks.

gychang
--
cruising the desert
--
User avatar
gychang
Level 3
Level 3
 
Posts: 143
Joined: Tue Dec 09, 2008 12:24 pm

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby Oscar799 on Tue May 22, 2012 12:53 pm

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8841
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby anark10n on Sun May 27, 2012 10:19 am

I'm trying to change the keyboard+mouse combination of alt-right click as it conflicts with the blender combo of the same type. how do i change this in cinnamon, but this option does not appear in the shortcu settings.
anark10n
Level 1
Level 1
 
Posts: 2
Joined: Sun May 27, 2012 9:53 am

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby smlgbll on Mon Jun 04, 2012 7:14 am

The way mentioned above using gconf-editor works nicely, thanks for that.

The funny/odd thing is, that the shortcut I used for opening the terminal, using <Super>x worked directly from the shortcut-editor in the keyboard preferences, but using <Super>c to start chromium just brought up that search or command window on the lower right.

But, as I have my shortcut now, I won't be bothered. Still...what gives?
smlgbll
Level 1
Level 1
 
Posts: 1
Joined: Mon Jun 04, 2012 6:59 am

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby mjdtjm on Tue Jul 24, 2012 9:40 am

fschaap wrote:So it is. I am so used to Linux Mint 9 where you can type "shortcut" in the Preferences window and get the appropriate settings dialog :-)

Still, I can't seem to get Mod4+E (left window key + e) to open Nautilus. I've added a shortcut called Nautilus, with the command "nautilus" and key binding Mod4+E... and nothing happens when I hit that key combination!

What am I doing wrong?


I have the same problem, but I figured out that if I keep the (left window + e) keys pressed for a while and then release them simultaneously it works!
It's a bit strange, because the normal behavior is pressing window key at first and then pressing e, then release e and after it window key.
mjdtjm
Level 1
Level 1
 
Posts: 7
Joined: Mon Mar 26, 2012 1:50 am

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby xircon on Tue Jul 24, 2012 5:19 pm

I wonder if the problem is that the super (win) key is tied to the Cinnamon menu (and Gnome 3 switch to overview mode) and it is interfering with the keybinding - just a thought.

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby cherep on Sun Sep 30, 2012 12:11 am

The same problem on LM13 Maya Cinnamon 1.6.1. On Cinnamon 1.4 everything worked fine.

Who knows if it is a well-known bag?

Where can I post it and help to make LM13 and Cinnamon better?

Thanks!
cherep
Level 1
Level 1
 
Posts: 6
Joined: Sat Sep 29, 2012 2:21 pm

Re: Where to configure keyboard shortcuts in Cinnamon?

Postby cherep on Sun Sep 30, 2012 3:27 pm

cherep
Level 1
Level 1
 
Posts: 6
Joined: Sat Sep 29, 2012 2:21 pm

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 2 guests