alt+f2 and delete button don't work in Cinnamon 1.4, LMDE

alt+f2 and delete button don't work in Cinnamon 1.4, LMDE

Postby frankob on Fri Oct 26, 2012 10:26 am

I have just installed LMDE 64 yesterday and noticed today that alt+f2 doesn't work. In the keyboard settings the binding was set normally all the time, but it still doesn't work. Alt+f1, neither, but I don't use that very much, anyway...

I have also just noticed that in Nautilus pressing delete on the keyboard doesn't move files to trash. Shift+delete works normally...

I've had Ubuntu installed on this machine before and have kept the home folder (on a different partition) while installing, if this info can help.

Any idea how to solve this?
frankob
Level 1
Level 1
 
Posts: 7
Joined: Fri Oct 26, 2012 7:18 am

Linux Mint is funded by ads and donations.
 

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby frankob on Mon Oct 29, 2012 8:19 pm

I have noticed that in Nautilus, ctrl+delete works instead of just delete... How do I change that?

Still no clue about the alt+f2 issue...
frankob
Level 1
Level 1
 
Posts: 7
Joined: Fri Oct 26, 2012 7:18 am

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby zerozero on Mon Oct 29, 2012 8:53 pm

frankob wrote:I've had Ubuntu installed on this machine before and have kept the home folder (on a different partition) while installing, if this info can help.

you have kept it and are using it?
please create a new user and test if these issues are present under that newly created account.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby frankob on Tue Oct 30, 2012 11:51 am

Yes, I am using that as my home partition and folder. I just tried what you suggested, and alt+f1 and alt+f2 really work there, while in Nautilus I still have to use ctrl+delete, instead of just delete to send files in trash. And, interestingly enough, my touchpad has issues of his own on that testing account... but this is off topic.

I am sure that in Ubuntu alt+f2 worked fine, and, as I already said, the bindings are set as they should all the time... I guess somewhere in my user settings something is telling to Unity or Compiz to handle this, but Unity is not running (Cinnamon is), which causes the issue. I have searched around dconf and gconf and couldn't find anything related, or at least nothing that I could recognize as related... as I am obviously missing something.
frankob
Level 1
Level 1
 
Posts: 7
Joined: Fri Oct 26, 2012 7:18 am

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby zerozero on Tue Oct 30, 2012 11:59 am

Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby frankob on Tue Oct 30, 2012 2:39 pm

Yes, but for the third time, I have this already set in the keyboard settings.

It was already set all the time there, but I tried to reset it, anyway... no dice!
frankob
Level 1
Level 1
 
Posts: 7
Joined: Fri Oct 26, 2012 7:18 am

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby zerozero on Wed Oct 31, 2012 7:09 am

so we go back to the first idea: (re)using an pre-existing home is a bad idea, you have ubuntu/unity config files messing up lmde/cinnamon
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby frankob on Wed Oct 31, 2012 10:22 am

yeh, obviously... I was thinking about deleting all the Unity and Compiz configuration stuff, which I don't necessarily need. But then I found out I couldn't configure Cinnamon the way I needed, for example, no easy way to make the "taskbar" show windows from all workspaces. So I dumped it and installed Xfce instead, which is easier to customize.
So in the end I wasn't deleting any configs, just removed some Gnome/Cinnamon-related packages and installed all I found that was LMDE Xfce related. And alt+f2 works just fine here. :-)
frankob
Level 1
Level 1
 
Posts: 7
Joined: Fri Oct 26, 2012 7:18 am

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby zerozero on Wed Oct 31, 2012 10:46 am

i'm glad you found in xfce a worthy alternative :D

frankob wrote:no easy way to make the "taskbar" show windows from all workspaces
i dunno if this is applicable to 1.4 (didn't used it that much) but in 1.6.x this problem is solved
Image
howto upgrade to 1.6
and this applet http://cinnamon-spices.linuxmint.com/applets/view/98 does the same with some extra features

anyhow, glad xfce is doing great :wink:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm

Re: alt+f2 and delete button don't work in Cinnamon 1.4, LMD

Postby frankob on Wed Oct 31, 2012 1:24 pm

hmm... It is possible I have overlooked that kind of applet, as I was looking for something integrated in some kind of taskbar itself, and didn't even think of an applet with a separate list. But I am happy with Xfce for now. :-) Thank you for the info, anyway. I could be giving Cinnamon another chance in the future, who knows. :-)
frankob
Level 1
Level 1
 
Posts: 7
Joined: Fri Oct 26, 2012 7:18 am

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 1 guest