Failed to execute login command with SLiM and Cinnamon

Failed to execute login command with SLiM and Cinnamon

Postby edoiny on Mon Nov 05, 2012 10:37 pm

Hello all,

well my problelm is the next, after install SLiM as login display manager and configure it, after log in with username and password the next message appear:

"Failed to execute login command"

I can log in with other display managers lightdm, gdm3, mdm without problems but with SLiM have a lot of problems.

My /etc/slim.conf is the next:

Code: Select all
# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
#
default_path        /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
default_xserver     /usr/bin/X11/X
xserver_arguments   -nolisten tcp

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue.net; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/X11/xauth

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
# hidecursor          false

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
login_cmd           exec /bin/sh - ~/.xinitrc %session
# login_cmd           exec /bin/bash -login /etc/X11/Xsession %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd   some command
# sessionstop_cmd   some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon   yes

# Available sessions (first one is the default).
# The current chosen session name is replaced in the login_cmd
# above, so your login command can handle different sessions.
# see the xinitrc.sample file shipped with slim sources
[b]sessions          gnome-session -session=cinnamon[/b]

# Executed when pressing F11 (requires imagemagick)
screenshot_cmd      scrot /root/slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to %host

# Session message. Prepended to the session name when pressing F1
# session_msg         Session:

# shutdown / reboot messages
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
#default_user        simone

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
#focus_password      no

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
#auto_login          no


# current theme, use comma separated list to specify a set to
# randomly choose from
current_theme       default

# Lock file
lockfile            /var/run/slim.lock

# Log file
logfile             /var/log/slim.log


in blod letters have a posible reason for this error, maybe the session name as been declared wrong in the file.

the ~/.xinitrc file is the next:

Code: Select all
# ~/.xinitrc
# This file is sourced when running startx and
#    other programs which call xinit
# As in all Bash/sh scripts lines starting with
#    '#' are comments

# Set background to your favorite pic
xsetbg -fullscreen /morphix/background.png &

# Start a XTerm
# /usr/bin/X11/xterm &

# Start the systems window manager.
# See WindowManagers for other choices.
exec /etc/alternatives/x-window-manager

# To run Gnome instead of system default, place a
# '#' before the previous line and uncomment the
# next line.
# exec gnome-session
[b]exec gnome-session -session=cinnamon[/b]


maybe the session parameters as wrong but I grant chmo +x permission to the file and not have luck.

Any idea?

thx
edoiny
Level 1
Level 1
 
Posts: 3
Joined: Mon Nov 05, 2012 10:28 pm

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 3 guests