Install latest Cinnamon (1.7.3) in LMDE

Install latest Cinnamon (1.7.3) in LMDE

Postby sdim on Fri Apr 05, 2013 2:40 pm

Hi, everyone.

I'm running the latest LMDE (March 2013 edition).
I would like to ask if I can update to the latest Cinnamon 1.7.3.

I've tried
Code: Select all
sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-nightly

and the rest of the stuff, but it didn't work, probably because it's for Ubuntu based Mint.

Is there a way that this can be done?

Many thanks.
MB:MSI 770 C-45 / HD1:500 GB-->Windows / HD2:320 GB-->Mint 17 Cinnamon
CPU:AMD X4 640 3.00 GHz / RAM:4.0 GB / VGA: NVidia GeForce GT630
User avatar
sdim
Level 3
Level 3
 
Posts: 147
Joined: Fri Mar 21, 2008 6:19 pm

Linux Mint is funded by ads and donations.
 

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby catweazel on Fri Apr 05, 2013 3:27 pm

If you can't wait until it hits the Mint debian repo, you can download the source and compile it.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby sdim on Fri Apr 05, 2013 3:29 pm

Thanks for the answer, my friend.
I don't think I'll do that.
MB:MSI 770 C-45 / HD1:500 GB-->Windows / HD2:320 GB-->Mint 17 Cinnamon
CPU:AMD X4 640 3.00 GHz / RAM:4.0 GB / VGA: NVidia GeForce GT630
User avatar
sdim
Level 3
Level 3
 
Posts: 147
Joined: Fri Mar 21, 2008 6:19 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby eanfrid on Fri Apr 05, 2013 3:33 pm

Regarding LMDE, you can take Cinnamon 1.73 from Debian unstable official repos ;) I did this for my Debian desktop machines.

http://www.debian.org/mirror/list
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1625
Joined: Mon Apr 30, 2012 2:49 am
Location: there is no place like ~

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby mockturtl on Fri Apr 05, 2013 3:35 pm

Ubuntu is not binary-compatible with Debian. PPA's will break your system. Don't use them.

1.7.3 is in sid, but Cinnamon won't be part of wheezy.

http://packages.debian.org/search?keywords=cinnamon

After wheezy is released (not long now!), I think LMDE will provide a migration path from the current cinnamon package (linuxmint.com repo) to debian's. (Just speculation, no official word.)

If you're willing to accept some risk, you can perform this step yourself, and add the sid repo. Otherwise it's best to wait.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby sdim on Fri Apr 05, 2013 4:59 pm

Many thanks for the answers, guys.
MB:MSI 770 C-45 / HD1:500 GB-->Windows / HD2:320 GB-->Mint 17 Cinnamon
CPU:AMD X4 640 3.00 GHz / RAM:4.0 GB / VGA: NVidia GeForce GT630
User avatar
sdim
Level 3
Level 3
 
Posts: 147
Joined: Fri Mar 21, 2008 6:19 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Fri Apr 12, 2013 12:42 pm

i would love to jump in here .

i have the sid repos in my sources list even the experimental ( but i guess that is really not neccessary ) BUT
when i refresh the packages there is no cinnamon 1.7.3 in the list, i tried many many different things but its not there ...
i then went and downloaded the packed version from the http repos and tried to install but it stops at libmuffin0
wich i then also tried to download from http but surprise as it IS listed and there is a explanation about the package for the sid repos
every mirror link across the world gave me a 404 ... :/
so my question is .... what happened ? :D

src list :

Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import backport romeo
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
# deb http://debian.linuxmint.com/latest/multimedia testing main non-free
deb http://download.virtualbox.org/virtualbox/debian wheezy contrib
# deb-src http://download.virtualbox.org/virtualbox/debian wheezy contrib
deb http://liquorix.net/debian sid main
# deb-src http://liquorix.net/debian sid main
deb http://www.deb-multimedia.org sid main non-free
# deb-src http://www.deb-multimedia.org sid main non-free
# deb http://ftp.debian.org/debian unstable main contrib non-free
# deb-src http://ftp.debian.org/debian unstable main contrib non-free
# deb http://ftp.debian.org/debian/ experimental main contrib non-free
# deb-src http://ftp.debian.org/debian/ experimental main contrib non-free


i turned the neccesary repos on when i made the updates :) .

tia

chris
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby Monsta on Fri Apr 12, 2013 1:15 pm

urbiental wrote:wich i then also tried to download from http but surprise as it IS listed and there is a explanation about the package for the sid repos
every mirror link across the world gave me a 404 ... :/
so my question is .... what happened ? :D

Yeah, for some reason every download link from the package page leads to 1.7.1 while the directory listing clearly shows there's already 1.7.2 instead.

Side note: looking at your set of repos, I really hope you know what you're doing and have set the repo preferences right :)
Monsta
Level 8
Level 8
 
Posts: 2349
Joined: Fri Aug 19, 2011 3:46 am

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Fri Apr 12, 2013 6:07 pm

well this still doesnt explains WHY cinnamon does not appear in the packages to be updated when i use the sid repos . its in there as the http repos site says but when i use the update manager , nothing ?
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby zerozero on Fri Apr 12, 2013 6:31 pm

because you have the preferences setted for mint packages higher.
look at etc/apt/preferences.
but i agree with Monsta
Monsta wrote:I really hope you know what you're doing
or have a recent backup
zerozero
Level 16
Level 16
 
Posts: 6470
Joined: Tue Jul 07, 2009 2:29 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Fri Apr 12, 2013 7:22 pm

thank you , i just want to install cinnamon 1.7.3 . so after getting the packages list from the repos i usually turn them all off and just mark those i want, like a more recent darktable or the like . or doing single package install over synaptic . but i just couldnt understand why cinnamon didnt showed up . the prioritys make sense , i came across them before in another thread but thought they will come later in my "studies" :)
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby Monsta on Sat Apr 13, 2013 5:58 am

urbiental wrote:the prioritys make sense , i came across them before in another thread but thought they will come later in my "studies" :)

That depends on your pace in learning Debian :)

Okay, let's see. Enable these repos for a moment and run these commands:
Code: Select all
apt-cache policy cinnamon
Code: Select all
apt-cache policy muffin
Code: Select all
apt-cache policy libmuffin0
and post their output here.
Monsta
Level 8
Level 8
 
Posts: 2349
Joined: Fri Aug 19, 2011 3:46 am

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Sat Apr 13, 2013 10:54 am

ta tae ta reaaaa ..

Code: Select all
xxxxxxxxx ~ $ apt-cache policy cinnamon
cinnamon:
  Installed: 1.6.7+lmde
  Candidate: 1.6.7+lmde
  Version table:
 *** 1.6.7+lmde 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
        100 /var/lib/dpkg/status
xxxxxxxxx $ apt-cache policy muffin
muffin:
  Installed: (none)
  Candidate: 1.1.2+lmde
  Version table:
     1.1.2+lmde 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
xxxxxxxxxx ~ $ apt-cache policy libmuffin0
libmuffin0:
  Installed: 1.1.2+lmde
  Candidate: 1.1.2+lmde
  Version table:
 *** 1.1.2+lmde 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
        100 /var/lib/dpkg/status
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby Monsta on Sat Apr 13, 2013 11:48 am

Well, Sid isn't there. Did you run apt-get update after editing the repo list?
Monsta
Level 8
Level 8
 
Posts: 2349
Joined: Fri Aug 19, 2011 3:46 am

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Sat Apr 13, 2013 12:27 pm

sorry :) ...

Code: Select all
xxxxxxxx ~ $ apt-cache policy cinnamon
cinnamon:
  Installed: 1.6.7+lmde
  Candidate: 1.6.7+lmde
  Version table:
     1.7.3-1 0
        500 http://ftp.debian.org/debian/ unstable/main amd64 Packages
 *** 1.6.7+lmde 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
        100 /var/lib/dpkg/status
xxxxxxxxx ~ $ apt-cache policy muffin
muffin:
  Installed: (none)
  Candidate: 1.1.2+lmde
  Version table:
     1.7.2-1 0
        500 http://ftp.debian.org/debian/ unstable/main amd64 Packages
     1.1.2+lmde 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
xxxxxxxxx ~ $ apt-cache policy libmuffin0
libmuffin0:
  Installed: 1.1.2+lmde
  Candidate: 1.1.2+lmde
  Version table:
     1.7.2-1 0
        500 http://ftp.debian.org/debian/ unstable/main amd64 Packages
 *** 1.1.2+lmde 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
        100 /var/lib/dpkg/status
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby Monsta on Sat Apr 13, 2013 1:02 pm

Now you can see that the Mint repo has higher priority (700) than Sid (500). That's because LMDE, unlike pure Debian, makes use of /etc/apt/preferences file where the repo priorities are set. If you look there, you can see the Mint repo's priority. As for Sid, it just has its default priority, that's 500.

All that stuff prevents you from getting newer Cinnamon and libmuffin. You can use
Code: Select all
sudo apt-get -t unstable cinnamon libmuffin0
to get them. The "-t unstable" option tells apt to use that repo.

I also suggest reading more about preferences:
The last link shows how you can keep unstable and experimental in your repos list (no need to comment them anymore) and keep their packages from being automatically installed during dist-upgrade (or mintUpdate use).


Final note:

Code: Select all
# deb http://debian.linuxmint.com/latest/multimedia testing main non-free
deb http://www.deb-multimedia.org sid main non-free

You should've had a very good reason to disable the "native" LMDE repo and enable Sid's repo instead. I suggest reverting that before you get any unwanted upgrades and breakages. :)
Monsta
Level 8
Level 8
 
Posts: 2349
Joined: Fri Aug 19, 2011 3:46 am

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby eanfrid on Sat Apr 13, 2013 1:09 pm

Be careful, deb-multimedia.org repos are not official Debian repos and will never be. Cf: http://lists.alioth.debian.org/pipermai ... 25882.html (debian-multimedia.org was renamed to deb-multimedia.org weeks later, but reasons to be careful still remain).
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1625
Joined: Mon Apr 30, 2012 2:49 am
Location: there is no place like ~

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Sat Apr 13, 2013 1:30 pm

thank you for the detailed answer !

i used this preferences and list and will build on that for the deb-multimedia and other repos that might come .
just switched it for now as u suggested .

regards

chris
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby Monsta on Sat Apr 13, 2013 2:17 pm

urbiental wrote:i used this preferences and list

These preferences are too high, I think, especially 600 for Testing. Actually, I don't know if you can pin Testing in LMDE at all. IIRC, the release name ("release a=testing") is the same in LMDE's Latest repos.
Anyway, you still may end up with unwanted package upgrades. I strongly recommend reading that heap of documentation before experimenting: better safe than sorry, as they say. :)
Monsta
Level 8
Level 8
 
Posts: 2349
Joined: Fri Aug 19, 2011 3:46 am

Re: Install latest Cinnamon (1.7.3) in LMDE

Postby urbiental on Sat Apr 13, 2013 4:12 pm

well , thats somehow against my nature . thats why i write out of the classic gnome desktop now :D ....

actually everything worked as it should .. it only installed 4 new packages and upgraded 4 but after the login screen he couldnt start cinnamon as he told me with the suggestion to log into another session ... well :)
i took classic and when i checked with synaptic, one package was broken wich is " gnome-controle-center " . when i further investigated cinnamon-common wasnt installed as the muffin pack too . so i did that but now after the login screen it boots in and i can see the desktop but then hardbrakes into a screen with a crying screen telling me that nothing is possible and sends me back to the x login screen .

wich log is helpfull now ? .
urbiental
Level 1
Level 1
 
Posts: 10
Joined: Wed Apr 10, 2013 2:51 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 2 guests