Removable devices - mounting OK, but not prompt/app/folder

Removable devices - mounting OK, but not prompt/app/folder

Postby amassakoul on Wed Jun 19, 2013 5:46 pm

I have LMDE with all the latest updates (at 6). The removable device prompt is causing me problems.
Inserting an audio CD or USB stick automounts the media, and opening a window with the panel applet allows an application to be launched. That works fine - I can listen to audio CD's.
But I can't get autoplay using a configured application, or a prompt ('what do you want to do'), to work. Setting 'open folder' is ignored too.

When I configure the response to an audio CD, USB stick etc., using either the gnome config tool or cinnamon, I can see the resulting dconf values and the .local/share/applications/mimeapps.list values of x-context/xx. So the configuration is being updated - but it seems to be ignored.
'Ignore autorun and prompting' is *not* set, so I assume that I should be seeing a prompt/autoplay/a folder opening.
This is a problem for all the users on the machine.

A Gnome session works fine - I get a nice notification for running an application or ejecting the medium.

I've tried nemo --quit and starting nemo in a terminal, but there's nothing strange in the output.
Can anyone tell me how I can track down what's happening? Anyone else had this problem? How can I verify the configuration and required components? I can't remember for certain if the feature ever worked but I think it may have broken around update 4. Thanks!
Level 1
Level 1
Posts: 3
Joined: Fri Nov 12, 2010 10:12 am

Linux Mint is funded by ads and donations.

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 2 guests