No Wallpapers in LMDE

No Wallpapers in LMDE

Postby mdavies5 on Mon Jun 24, 2013 10:40 am

Just installed LMDE with Cinnamon 1.8.8. When first installed there was no problem with backgrounds. All the files from /usr/shared/backgrounds were available to choose from. Later there were no files to choose from in the Settings Manager/Backgrounds. I added one using the + button and found that the file I added was copied into home/.cinnamon/backgrounds. Why the change? How can I reset it to use the usr/shared folder?
The only change that may have caused it was changing the theme and changing the logon default session to "Cinnamon". I have reset this to the default "Run xclient script" and reset the theme to default.
Last edited by xenopeek on Mon Jun 24, 2013 10:50 am, edited 1 time in total.
Reason: Moved to LMDE forum
mdavies5
Level 2
Level 2
 
Posts: 78
Joined: Sat Aug 11, 2012 1:02 am

Linux Mint is funded by ads and donations.
 

Re: No Wallpapers in LMDE

Postby mdavies5 on Mon Jun 24, 2013 11:45 pm

I think I have found the problem. The folder /usr/share/cinnamon-background-properties was missing. Almost certainly this was deleted when I changed the default session to "Cinnamon". When I changed back to "Run X-Client script" as the default session this folder was not re-created. I copied a similar folder from my Mint 15 installation and everything works fine. In fact the Background files from usr/share/etc and home/.cinnamon/.. are both displayed. I found this by checking the file cs_backgrounds.py which searches both locations.
mdavies5
Level 2
Level 2
 
Posts: 78
Joined: Sat Aug 11, 2012 1:02 am

Re: No Wallpapers in LMDE

Postby darethehair on Wed Jun 26, 2013 10:49 am

Hmmm...I'm not so sure about this. I also lack the "/usr/share/cinnamon-background-properties" folder, bit it does not appear either on my 201303 LMDE fresh off the ISO, nor after upgrading to Cinnamon 1.8.8.

I am also experiencing some problems with wallpapers on both my established desktop and a freshly installed laptop, but both problems are different i.e. in the former case, my right-click-on-desktop option for 'Change Desktop Background' suddenly doesn't work, whereas in the latter case there were absolutely no wallpapers to chose from by default.
There is nothing more dangerous than a bored cat.
User avatar
darethehair
Level 3
Level 3
 
Posts: 158
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada

Re: No Wallpapers in LMDE

Postby mdavies5 on Thu Jun 27, 2013 2:36 am

Can you get the "Change Wallpaper Option" from the Gnome or Cinnamon Control Centre. If so click the + sign and add a wallpaper; either from your own pics or from /usr/backgrounds. You can add several at once. These should be automatically copied into your /.cinnamon/backgrounds folder.
Alternatively create a folder /usr/share/cinnamon-background-properties and add to it the linuxmint-olivia.xml file (copy attached). Make sure you also have /usr/share/backgrounds/linuxmint-olivia with several jpg's in it.
mdavies5
Level 2
Level 2
 
Posts: 78
Joined: Sat Aug 11, 2012 1:02 am

Re: No Wallpapers in LMDE

Postby mdavies5 on Thu Jun 27, 2013 2:43 am

Sorry, forgot the promised file in my last post but system will not let me upload it?
mdavies5
Level 2
Level 2
 
Posts: 78
Joined: Sat Aug 11, 2012 1:02 am

Re: No Wallpapers in LMDE

Postby mdavies5 on Thu Jun 27, 2013 2:43 am

Sorry, forgot the promised file in my last post but system will not let me upload it?
mdavies5
Level 2
Level 2
 
Posts: 78
Joined: Sat Aug 11, 2012 1:02 am


Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 3 guests