Breakages: MATE + Debian !!!TESTING!!!

Breakages: MATE + Debian !!!TESTING!!!

Postby äxl on Fri May 11, 2012 9:01 pm

DISCLAIMER: Although it seems I'm the only one - this thread is about tracking MATE from mate-desktop.org (wheezy) for which you will need some packages from debian.org's Wheezy/Testing

Wickedly stolen and altered from zerozero's "LMDE tracking testing"
For the ones looking for help, remember a few things:
1. MATE's code is based on Debian Testing/Wheezy so it's not by definition a stable, rock-solid Desktop Environment, "things are likely to break more often but fixes can also come quicker".

2. Generally it's not a good idea, just because something broke or a pkg was removed during an upgrade to pull new pkgs from Testing/Wheezy

3. Please use synaptic or the terminal. (MintUpdate is not designed for LMDE yet!!!)

The terminal it's the fastest and easiest way, just open it and do
Code: Select all
apt update && apt dist-upgrade

now watch the output, sometimes, something is broken (it's testing remember :D ), if you see something odd, apt wanting to remove half of your installation (can happen), don't panic 8) answer n and wait for a better day to update, it will come soon


For this to work you will have to edit you sources.list and preferences (Apt-Pinning) - My preferences look like this:
Code: Select all
Package: *
Pin: origin *.linuxmint.com
Pin-Priority: 700

Package: *
Pin: origin packages.mate-desktop.org
Pin-Priority: 600

Package: *
Pin: origin *.debian.org
Pin-Priority: 99

This will result in official packages being preferred, packages from MATE-desktop.org only upgraded if newer and Debian packages only exclusively installed. You will see an example in my next post.
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Linux Mint is funded by ads and donations.
 

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby äxl on Fri May 11, 2012 9:02 pm

Continuing from here: viewtopic.php?f=206&t=86481&p=578069#p578069
It has worsened:
Code: Select all
sudo apt-get -s -t wheezy install atril-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  atril eog fontconfig-config glib-networking glib-networking-common glib-networking-services gnome-themes-standard libatril libfontconfig1 libgail-3-0
  libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libglib2.0-0 libglib2.0-bin libgnutls26 libgtk-3-0 libgtk-3-bin libgtk-3-common libjavascriptcoregtk-3.0-0
  libkpathsea6 libpango1.0-0 libsoup2.4-1 libvte-2.90-9 libvte-2.90-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
Suggested packages:
  mate-file-manager ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp
The following NEW packages will be installed:
  libkpathsea6
The following packages will be upgraded:
  atril atril-common eog fontconfig-config glib-networking glib-networking-common glib-networking-services gnome-themes-standard libatril libfontconfig1
  libgail-3-0 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libglib2.0-0 libglib2.0-bin libgnutls26 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libjavascriptcoregtk-3.0-0 libpango1.0-0 libsoup2.4-1 libvte-2.90-9 libvte-2.90-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
26 upgraded, 1 newly installed, 0 to remove and 728 not upgraded.

Without Wheezy it's:
Code: Select all
sudo apt-get -s install atril-common
The following packages will be REMOVED:
  atril mate-core mate-desktop-environment
The following packages will be upgraded:
  atril-common
1 upgraded, 0 newly installed, 3 to remove and 1 not upgraded.
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby äxl on Fri May 18, 2012 3:15 pm

Just posting to say that I've made the aforementioned Wheezy upgrade now with no errors or warnings. Well, let's see what the next start brings. :D

- - - - - -
EDIT: Everything's fine. There are just some applications that don't stick with the theme, colouring. I.e. GDM Login, Transmission, Disk Utility (palimpsest) show white font on grey background (with mint-x-metal) although this should be a problem with Gnome than anything else.
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby äxl on Sat Jun 30, 2012 4:30 am

The "problem" in my last post is a pure Mint-X problem. It's just the "beautiest". Maybe I could try to migrate ...?

Had to do a "-t wheezy install atril-common" again. Here are the installed and upgraded packages:
2012-06-28 16:08:25 install libpoppler19 <none> 0.18.4-2
2012-06-28 16:08:26 install libpoppler-glib8 <none> 0.18.4-2
2012-06-28 16:08:26 upgrade atril 1.2.0-3+wheezy 1.2.0-4+wheezy
2012-06-28 16:08:27 upgrade atril-common 1.2.0-3+wheezy 1.2.0-4+wheezy
2012-06-28 16:08:28 upgrade libatril 1.2.0-3+wheezy 1.2.0-4+wheezy

Since then I can't log in to Gnome 3 and Cinnamon - says "Failed to load session '{}'" for gnome and cinnamon. Not that I need it. Heh.
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby titetanium on Mon Jul 02, 2012 8:45 pm

I have more of a Debian system with Mint components, you could call it Debian Mintified. Is that even possible? My sources.list is almost the same as Axl's above but I track Debian wheezy/testing primarily, then Mint, then Mate (the repo).

Running LXDE with a mix of MATE and GNOME 3 packages. What a mess to sort out! The gtk3 toolkit is giving me a royal headache as it won't match with my gtk2/qt apps which already blend together nicely. Come to find out that the shift from gtk-3.2 to gtk-3.4 was the culprit. And to make matters worse, I reinstalled the whole thing a few days ago, and now can't get gtk-3.2 anymore so therefore I can't get the gtk 3 themes to match. So I ripped out gnome-control-center and gnome-system-tools in favor of mate-control-center and mate-system-tools which gave me better functionality with LXDE. MATE and GNOME 3 do not mix!

EDIT: On a side note, I installed GNOME SHELL so I could use the gnome-tweak-tool. What a joke, it didn't even work right, and I couldn't even log in gnome shell either. No skin off my back, I don't mind losing gnome shell anyway.
titetanium
Level 2
Level 2
 
Posts: 71
Joined: Mon Jun 18, 2012 4:26 pm

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby äxl on Wed Jul 18, 2012 5:00 pm

Don't know if this is your problem as well, titetanium, but it fixed mine: viewtopic.php?f=220&t=101647#p597990

But I've got another problem with Caja crashing with BadDrawable or BadPixmap ... But I'll make a new thread for that when I've eliminated the solutions I've found so far ...
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby titetanium on Sat Jul 21, 2012 2:11 pm

Thanks Axl for the thread. I patched the affected mint gtk3 theme and it all blends together now..... :D

However, I've moved away from using the Mint theme in favor of the Ambiance Graphite theme I found on gnome-look.org. It looks awesome when matched with the serif italics fonts. :mrgreen:
titetanium
Level 2
Level 2
 
Posts: 71
Joined: Mon Jun 18, 2012 4:26 pm

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby äxl on Wed Aug 01, 2012 5:48 pm

You're welcome, titetanium. But I'll stick with the Mint theme. I like green. :D
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
A new apt-get -s dist-upgrade got me following:
Code: Select all
88 upgraded, 4 newly installed, 21 to remove and 5 not upgraded.
85 upgrades from mate-desktop.org and the removals resulted from the 'keep backs'.

I had to run aptitude this time to find out the problems:
Code: Select all
111 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 190 MB of archives. After unpacking 21.1 MB will be used.
The following packages have unmet dependencies:
  libatril: Depends: libdjvulibre21 (>= 3.5.25.3) but 3.5.25.2-1 is installed.
  mate-system-monitor: Depends: libglibmm-2.4-1c2a (>= 2.31.22) but 2.30.0-2 is installed.
  libmatevfs: Depends: libacl1 (>= 2.2.51-8) but 2.2.51-5 is installed.
              Depends: libattr1 (>= 1:2.4.46-8) but 1:2.4.46-5 is installed.
  marco: Depends: libx11-6 (>= 2:1.4.99.1) but 2:1.4.4-4 is installed.

So 179 MB later:
Code: Select all
sudo apt-get install atril-common caja-common caja-gksu caja-open-terminal dropbox engrampa engrampa-common engrampa-dbg eom eom-common eom-dbg firefox firefox-l10n-en-gb libcaja-extension libmarco libmate libmate-common libmate-dbg libmatecanvas libmatecanvas-dbg libmatecomponent libmatecomponent-dbg libmatecomponentui libmatecomponentui-dbg libmateconf libmatecorba libmatedesktop libmatekbd libmatekbd-dbg libmatekeyring libmatekeyring-dbg libmatemenu libmatenotify libmatenotify-dbg libmatepanelapplet libmatepolkit libmateweather libmateweather-common libmateweather-dbg marco-common mate-applets-common mate-backgrounds mate-calc mate-conf mate-conf-common mate-conf-dbg mate-conf-editor mate-control-center mate-corba mate-desktop mate-desktop-common mate-desktop-dbg mate-dialogs mate-icon-theme mate-indicator-applet mate-keyring mate-keyring-dbg mate-media mate-media-common mate-media-gstreamer mate-menus mate-mime-data mate-netspeed mate-notification-daemon mate-panel mate-panel-common mate-panel-dbg mate-polkit mate-power-manager mate-power-manager-common mate-power-manager-dbg mate-settings-daemon mate-settings-daemon-common mate-settings-daemon-gstreamer mate-system-tools mate-terminal mate-terminal-common mate-text-editor mate-themes mate-utils mint-common mintnanny mozo python-corba python-mate-desktop python-mate-menu thunderbird thunderbird-l10n-en-gb libdjvulibre21=3.5.25.3-1 libglibmm-2.4-1c2a=2.32.0-1 libacl1=2.2.51-8 libattr1=1:2.4.46-8 libx11-6=2:1.5.0-1 libdjvulibre-text=3.5.25.3-1
...my system is still running ...

I only got:
Code: Select all
Warning: program compiled against libxml 208 using older 207

Should I get libxml2 from Debian.org and reinstall?
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby zerozero on Wed Aug 01, 2012 6:04 pm

äxl,
where are you getting that error?
because i don't think that it is related to libxml2, you get a using older 207 and libxml2 is http://packages.qa.debian.org/libx/libxml2.html 2.8.0
http://packages.debian.org/wheezy/libxml-encoding-perl << this one matches the versions shown in your error output.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby äxl on Thu Aug 02, 2012 5:12 pm

I guessed so too, zerozero. But everything seems okay.
Got this again in about 50 consecutive lines in today's dist-upgrade (without Debian wheezy) after:
Code: Select all
Preparing to replace python-mate 1.2.0-3+wheezy (using .../python-mate_1.4.0-1+wheezy_amd64.deb) ...
Unpacking replacement python-mate ...
Processing triggers for mate-conf ...


titetanium, how does your GDM look? It's still grey on grey for me. Or do you use MDM?
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby titetanium on Thu Aug 02, 2012 10:54 pm

Axl,

I never installed gdm, I do have mdm installed and it looks the same as it always has since I tweaked it. Perhaps a screenshot:

mdm_screenie.png
Vertical Login from gnome-look.org
mdm_screenie.png (6.63 KiB) Viewed 1879 times
titetanium
Level 2
Level 2
 
Posts: 71
Joined: Mon Jun 18, 2012 4:26 pm

Re: Breakages: MATE + Debian !!!TESTING!!!

Postby äxl on Sat Aug 04, 2012 4:50 am

Oh, alright. I come from ISO 201109 so I still have GDM.

Regarding the libxml warning - I also get this now when running programs:
Code: Select all
~ $ mateconftool-2 --get /desktop/linuxmint/terminal/show_fortunes
Warning: program compiled against libxml 208 using older 207
true
~ $

I'll upgrade libxml-encoding-perl with next dist-upgrade.
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Linux Mint is funded by ads and donations.
 

Return to MATE

Who is online

Users browsing this forum: Google Feedfetcher and 2 guests