Compiz setup (SOLVED)

Compiz setup (SOLVED)

Postby Fornhamfred on Tue Oct 16, 2012 1:48 pm

I have followed the how to http://community.linuxmint.com/tutorial/view/506 but when rebooting compiz is not starting. I know that you can add compiz --replace to the startup applications but according to the how-to this should not be necessary. Also I am unable to change the no of desktops in compiz - is this particular to Mate as I found an old bug report about Ubuntu Maverick?

Also I have checked which desktop manager is running and it is Marco.
Last edited by Fornhamfred on Tue Oct 30, 2012 6:10 am, edited 1 time in total.
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Linux Mint is funded by ads and donations.
 

Re: Compiz setup

Postby bigbakedbean on Tue Oct 16, 2012 4:17 pm

To set Compiz as the default window manager in MATE, you'll want to use mateconftool-2 instead of gconftool-2. Give this a try:

Code: Select all
mateconftool-2 --set /desktop/mate/session/required_components/windowmanager --type string compiz


Regarding the number of workspaces, I'm pretty sure Compiz will honor whatever value Marco is using. You can set this the normal way (right-click the workspace switcher panel applet, then click "Properties") or via this command:

Code: Select all
mateconftool-2 --set /apps/marco/general/num_workspaces --type int 4


Be sure to change 4 to the number of workspaces you desire.
bigbakedbean
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 21, 2012 8:23 am

Re: Compiz setup

Postby Fornhamfred on Wed Oct 17, 2012 1:46 pm

Thanks unfortunately neither of these lines has any effect. Before installing Compiz I had four desktops now I only have two. I have two machines one with Intel graphics and the other nvidia and both have the same problem.

Edit: The problem of the desktops has been resolved as I posted on the mate forum as well.

You need to change num of workspaces in marco (workspace applet) to 1 before switching to compiz. Then, in CCSM > General Options > "Desktop Size" tab, make sure you have Horizontal Virtual Size = 4, Vertical Virtual Size = 1, and Number of desktops = 1.
That's how you get 4 workspaces horizontally, exactly like in MATE, but in Compiz.

In fact I only had to alter the setting in CCSM.
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK


Return to MATE

Who is online

Users browsing this forum: No registered users and 3 guests