MATE Menu wont load apps

MATE Menu wont load apps

Postby enito on Mon Jul 08, 2013 10:48 pm

Hi,

some strange happened apparently in last updates..i cant load any app from menu of mate. If the same app i try to run from console, works.. Any tip? or where i can see some log for trace the situation..

thx
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Linux Mint is funded by ads and donations.
 

Re: MATE Menu wont load apps

Postby rokytnji on Mon Jul 08, 2013 11:44 pm

Poke and hope in

Code: Select all
harry@biker ~ $ cd /var
harry@biker /var $ ls
backups  crash  local  log   metrics  run    tmp
cache    lib    lock   mail  opt      spool
harry@biker /var $ cd log
harry@biker /var/log $ ls
alternatives.log       dmesg.0             pm-powersave.log.2.gz
alternatives.log.1     dmesg.1.gz          pm-powersave.log.3.gz
alternatives.log.2.gz  dmesg.2.gz          pm-powersave.log.4.gz
alternatives.log.3.gz  dmesg.3.gz          pm-suspend.log
alternatives.log.4.gz  dmesg.4.gz          pm-suspend.log.1
apport.log             dpkg.log            pm-suspend.log.2.gz
apport.log.1           dpkg.log.1          pm-suspend.log.3.gz
apport.log.2.gz        dpkg.log.2.gz       pm-suspend.log.4.gz
apport.log.3.gz        dpkg.log.3.gz       pycentral.log
apport.log.4.gz        dpkg.log.4.gz       samba
apport.log.5.gz        faillog             speech-dispatcher
apport.log.6.gz        fontconfig.log      syslog
apport.log.7.gz        fsck                syslog.1
apt                    hp                  syslog.2.gz
aptitude               installer           syslog.3.gz
aptitude.1.gz          kern.log            syslog.4.gz
auth.log               kern.log.1          syslog.5.gz
auth.log.1             kern.log.2.gz       syslog.6.gz
auth.log.2.gz          kern.log.3.gz       syslog.7.gz
auth.log.3.gz          kern.log.4.gz       udev
auth.log.4.gz          lastlog             ufw.log
boot                   mail.err            unattended-upgrades
boot.log               mail.log            upstart
bootstrap.log          mdm                 wtmp
btmp                   mintsystem.log      wtmp.1
btmp.1                 mintUpdate.history  Xorg.0.log
ConsoleKit             news                Xorg.0.log.old
cups                   pm-powersave.log
dmesg                  pm-powersave.log.1


You can right click on menu button also I guess
Image
Linux user 475019.
User avatar
rokytnji
Level 3
Level 3
 
Posts: 198
Joined: Mon Nov 03, 2008 9:56 pm
Location: Pecos, TX

Re: MATE Menu wont load apps

Postby enito on Tue Jul 09, 2013 9:22 am

Thx for reply, but my problem was in menu for access to all aps of mint. I point one for example, gimp, k3b, etc and nothing happen. I made the same thing via console terminal, and works..

greets
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: MATE Menu wont load apps

Postby rokytnji on Tue Jul 09, 2013 2:07 pm

Well, you could create a new user and log in with that user name and see if the problem persists in that user.
Linux user 475019.
User avatar
rokytnji
Level 3
Level 3
 
Posts: 198
Joined: Mon Nov 03, 2008 9:56 pm
Location: Pecos, TX

Re: MATE Menu wont load apps

Postby enito on Tue Jul 09, 2013 2:46 pm

rokytnji wrote:Well, you could create a new user and log in with that user name and see if the problem persists in that user.

good point...

i try when i back to home, thx
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: MATE Menu wont load apps

Postby enito on Tue Jul 09, 2013 7:37 pm

Same thing with new user :(

strange behaviour cant catch some logs or somethig for found the problem..thx
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: MATE Menu wont load apps

Postby rokytnji on Tue Jul 09, 2013 8:37 pm

Hmmm. I installed Fluxbox window manager a few days ago. One thing I noticed was caja (mates file manager) could take over the behavior (right click menus) in theFluxbox desktop.
viewtopic.php?p=737375#p737375

In other words. I have tried to break things but I have not been able to accomplish what broke for you with my tweaks.

Yeah, I know. Without knowing what to look for in /var which holds all logs. It can be a pain staking process.

http://www.cyberciti.biz/faq/ubuntu-lin ... og-viewer/
Linux user 475019.
User avatar
rokytnji
Level 3
Level 3
 
Posts: 198
Joined: Mon Nov 03, 2008 9:56 pm
Location: Pecos, TX

Re: MATE Menu wont load apps

Postby aneto on Fri Jul 19, 2013 3:47 pm

enito, your not alone on this issue.

This happened to me when I got to work this morning, I have even tried logging into root account to check the menu and it's the same issue.

I have been posting on irc to see if I can snag some help but its crickets in there =(

Code: Select all
$uname -a
3.9-1-amd64 #1 SMP Debian 3.9.8-1 x86_64 GNU/Linux
$cat /etc/linuxmint/info
RELEASE=1
CODENAME=debian
EDITION="MATE 64-bit"
DESCRIPTION="LMDE MATE Edition"
DESKTOP=MATE
TOOLKIT=GTK
NEW_FEATURES_URL=http://www.linuxmint.com/rel_debian_whatsnew.php
RELEASE_NOTES_URL=http://www.linuxmint.com/rel_debian.php
USER_GUIDE_URL=http://www.linuxmint.com/documentation.php
GRUB_TITLE=LMDE MATE 64-bit


I have noticed synaptic is not working either, even from the terminal. I question if this mint specific, I think its gnome. Is there a way to jump to a different window manager without breaking mint? Or are you locked into mate when you choose that build?

Anyways thanks,
aneto
Level 1
Level 1
 
Posts: 5
Joined: Fri Jul 19, 2013 3:41 pm

Re: MATE Menu wont load apps

Postby enito on Fri Jul 19, 2013 3:50 pm

aneto wrote:enito, your not alone on this issue.

This happened to me when I got to work this morning, I have even tried logging into root account to check the menu and it's the same issue.

I have been posting on irc to see if I can snag some help but its crickets in there =(

Code: Select all
$uname -a
3.9-1-amd64 #1 SMP Debian 3.9.8-1 x86_64 GNU/Linux
$cat /etc/linuxmint/info
RELEASE=1
CODENAME=debian
EDITION="MATE 64-bit"
DESCRIPTION="LMDE MATE Edition"
DESKTOP=MATE
TOOLKIT=GTK
NEW_FEATURES_URL=http://www.linuxmint.com/rel_debian_whatsnew.php
RELEASE_NOTES_URL=http://www.linuxmint.com/rel_debian.php
USER_GUIDE_URL=http://www.linuxmint.com/documentation.php
GRUB_TITLE=LMDE MATE 64-bit


I have noticed synaptic is not working either, even from the terminal. I question if this mint specific, I think its gnome. Is there a way to jump to a different window manager without breaking mint? Or are you locked into mate when you choose that build?

Anyways thanks,


Nice too read this, another one with same trouble :(

here my specs

franky ~ # uname -a
Linux franky 3.9-1-amd64 #1 SMP Debian 3.9.8-1 x86_64 GNU/Linux

cat /etc/linuxmint/info
RELEASE=1
CODENAME=debian
EDITION="Cinnamon 64-bit"
DESCRIPTION="LMDE Cinnamon Edition"
DESKTOP=Gnome
TOOLKIT=GTK
NEW_FEATURES_URL=http://www.linuxmint.com/rel_debian_whatsnew.php
RELEASE_NOTES_URL=http://www.linuxmint.com/rel_debian.php
USER_GUIDE_URL=http://www.linuxmint.com/documentation.php
GRUB_TITLE=LMDE Cinnamon 64-bit
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: MATE Menu wont load apps

Postby aneto on Fri Jul 19, 2013 7:11 pm

What kind of output do you get when you try to run mintmenu from your terminal?

Code: Select all
aneto@aneto:[Desktop]$ mintmenu
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected
Opacity is: 98
Setting opacity to: 0.98
__init__ took 87.941 ms
Binding to Hot Key: <Control>Super_L

** (mintMenu.py:23247): WARNING **: Binding '<Control>Super_L' failed!

/
o
p
t
/
g
o
o
g
l
e
/
c
h
r
o
m
e
/
g
o
o
g
l
e
-
c
h
r
o
m
e
 
%
U
[Errno 13] Permission denied

(mintMenu.py:23247): MateComponent-WARNING **: Never got frame, control died - abnormal exit condition


The more I play with it the more, I think I may have done something retarded... but I haven't changed anything out of the ordinary.
aneto
Level 1
Level 1
 
Posts: 5
Joined: Fri Jul 19, 2013 3:41 pm

Re: MATE Menu wont load apps

Postby aneto on Fri Jul 19, 2013 8:34 pm

viewtopic.php?f=55&t=99793

Gives a good suggestion for a temp fix, you can remove matemenu and use the default gnome menu, or just press alt-f1 to get the menu, going to keep playing with it and see whats up... also tried downgrading to version to 5.3.7 from 5.3.8 no joy =(
aneto
Level 1
Level 1
 
Posts: 5
Joined: Fri Jul 19, 2013 3:41 pm

Re: MATE Menu wont load apps

Postby rokytnji on Fri Jul 19, 2013 8:51 pm

Off chance idea and it won't hurt to try.

I run AntiX with debian unstable repos and a dist-upgrade pulled in some gtk-3 stuff which played hell on synaptic,rox-terminal, plus some other stuff.

I changed out the theme from Zukwito to something else (I don't remember right now because I am not on my AntiX box) .

So basically, my idea is. Why not change your theme and see if it sorts things out. It worked for me after gtk-3 did some freaky stuff
to things not opening to segfaults, etc......

You can always go back to your old theme if it changes nothing.
Linux user 475019.
User avatar
rokytnji
Level 3
Level 3
 
Posts: 198
Joined: Mon Nov 03, 2008 9:56 pm
Location: Pecos, TX

Re: MATE Menu wont load apps

Postby aneto on Fri Jul 19, 2013 9:00 pm

Your right rokytnji,

Changing my appearance preference let me open synaptic, and roxterm. However mintmenu is still not working correctly so I switched to gnomes default menu.

I think I did the same thing with gtk because what you described to me is exactly what I'm going through.
aneto
Level 1
Level 1
 
Posts: 5
Joined: Fri Jul 19, 2013 3:41 pm

Re: MATE Menu wont load apps

Postby enito on Fri Jul 19, 2013 10:01 pm

aneto wrote:What kind of output do you get when you try to run mintmenu from your terminal?


The more I play with it the more, I think I may have done something retarded... but I haven't changed anything out of the ordinary.


Here i get this errors:

mintmenu
*********** Keybind Driver Load Failure **************
Error Report : No module named deskbar.core.keybinder
Opacity is: 98
Setting opacity to: 0.98
__init__ took 120.454 ms
[2013-07-19 21:59:09,280 pyinotify ERROR] add_watch: cannot watch /home/punto/.config/autostart/engrampa.desktop WD=-1, Errno=No such file or directory (ENOENT)
[2013-07-19 21:59:09,285 pyinotify ERROR] add_watch: cannot watch /home/punto/.config/autostart/file-roller.desktop WD=-1, Errno=No such file or directory (ENOENT)
[2013-07-19 21:59:09,287 pyinotify ERROR] add_watch: cannot watch /home/punto/.config/autostart/mate-calc.desktop WD=-1, Errno=No such file or directory (ENOENT

And lot of this add_watch errors..
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: MATE Menu wont load apps

Postby enito on Wed Jul 24, 2013 11:47 am

Can give your sources and preference for compare?

Here mine:

deb http://packages.linuxmint.com/ debian main incoming upstream import backport romeo
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
deb http://www.deb-multimedia.org sid main non-free
deb http://www.duinsoft.nl/pkg debs all

Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 700

Package: *
Pin: origin jas.gemnetworks.com
Pin-Priority: 800
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: MATE Menu wont load apps

Postby enito on Mon Jul 29, 2013 6:53 pm

Any there? not a reply? still cant load apps from menu :/

greets
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: MATE Menu wont load apps

Postby rokytnji on Tue Jul 30, 2013 6:51 pm

Sorry I can't help. The only thing I run with Debian testing and Sid repos is Fluxbox and Icewm. Not Mate.

Hence my previous post about GTK 3 breaking things in those Window Managers such as Rox Terminal and Synaptic Package Manager.

It makes me wonder if you have to wait

http://edos.debian.net/weather/

I figure you guys are suffering between a debain testing/unstable conflict with Mate Desktop and one or the other needs to fix it via another update/upgrade.
Linux user 475019.
User avatar
rokytnji
Level 3
Level 3
 
Posts: 198
Joined: Mon Nov 03, 2008 9:56 pm
Location: Pecos, TX

Re: MATE Menu wont load apps

Postby viking777 on Wed Jul 31, 2013 7:53 am

Topic moved by moderator as it appears to be about LMDE not Main Edition.

$uname -a
3.9-1-amd64 #1 SMP Debian 3.9.8-1 x86_64 GNU/Linux
$cat /etc/linuxmint/info
RELEASE=1
CODENAME=debian
EDITION="MATE 64-bit"
DESCRIPTION="LMDE MATE Edition"
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: MATE Menu wont load apps

Postby aneto on Wed Jul 31, 2013 12:47 pm

Sorry I haven't been as active in this thread I ended up dropping matemenu and using the gnome menu for the mean time... Considering just dropping mint and going back to Debian unsalted

Here is my /etc/apt/sources.list
Code: Select all
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

I have one extra source list in /etc/apt/source.list.d/ and its the google chrome repo
aneto
Level 1
Level 1
 
Posts: 5
Joined: Fri Jul 19, 2013 3:41 pm

Re: MATE Menu wont load apps

Postby rokytnji on Wed Jul 31, 2013 2:42 pm

Just to show what is capable in Mint if you use the inxi command in it to list all of your sources.list. inxi -help will give you a help list of commands to gather system info so you can supply more info in your posts.

Video

Code: Select all
harry@biker:~
$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/antix.list
           deb http://www.daveserver.info/antiX/debs testing main
           Active apt sources in file: /etc/apt/sources.list.d/debian.list
           deb http://ftp.us.debian.org/debian/ wheezy main contrib non-free
           deb http://security.debian.org/ wheezy/updates main contrib non-free
           Active apt sources in file: /etc/apt/sources.list.d/various.list
           deb http://www.duinsoft.nl/pkg debs all


I am mostly staying with stable on my netbooks like this one.

Code: Select all
harry@biker:~
$ inxi -Fxz
System:    Host: biker Kernel: 3.7.10-antix.3-486-smp i686 (32 bit, gcc: 4.7.3)
           Desktop: IceWM 1.3.7 Distro: antiX-13_386-full Luddite 01 June 2013
Machine:   System: manda product: Intel powered classmate PC version: Gen 1.5L
           Mobo: N/A model: N/A Bios: American Megatrends version: CM94515A.86A.0024.2008.0715.1716 date: 07/15/2008
CPU:       Single core Intel Core CPU N270 (-HT-) cache: 512 KB flags: (nx pae sse sse2 sse3 ssse3) bmips: 3191.84
           Clock Speeds: 1: 1600.00 MHz 2: 800.00 MHz
Graphics:  Card: Intel Mobile 945GSE Express Integrated Graphics Controller bus-ID: 00:02.0
           X.Org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x600@53.3hz
           GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 GLX Version: 1.4 Mesa 8.0.5 Direct Rendering: Yes
Audio:     Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.7.10-antix.3-486-smp
Network:   Card: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: ec00 bus-ID: 01:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 63.3GB (22.2% used) 1: id: /dev/sda model: KingSpec_KSD size: 63.3GB
Partition: ID: / size: 59G used: 14G (24%) fs: ext2
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 102 Uptime: 58 min Memory: 250.1/2015.1MB Runlevel: 5 Gcc sys: 4.7.2
           Client: Shell (bash 4.2.37) inxi: 1.9.12


There is no need to install inxi in Mint. It already comes with it included. :wink:
Linux user 475019.
User avatar
rokytnji
Level 3
Level 3
 
Posts: 198
Joined: Mon Nov 03, 2008 9:56 pm
Location: Pecos, TX

Linux Mint is funded by ads and donations.
 
Next

Return to MATE

Who is online

Users browsing this forum: No registered users and 3 guests