[SOLVED] Nemo, background cycling on startup

[SOLVED] Nemo, background cycling on startup

Postby malias on Tue Nov 05, 2013 5:13 pm

Whenever I log in to my Xfce environment, Nemo opens and my background image cycles through three or four images before stopping. I've checked the Application Autostart list under Session and Startup and Nemo wasn't listed so I'm not sure why it's starting.
As for my background image, I have Xfce set up to read my backgrounds from an image list. However, the images are not set on a timed cycle so the background should only change on login. Any idea about what is going on?

Both of these are minor annoyances, but I'd really like to figure what's causing them.
Last edited by malias on Tue Nov 05, 2013 8:20 pm, edited 1 time in total.
malias
Level 1
Level 1
 
Posts: 6
Joined: Thu Oct 03, 2013 1:36 am

Linux Mint is funded by ads and donations.
 

Re: Nemo, background cycling on startup

Postby karlchen on Tue Nov 05, 2013 7:02 pm

Hello, malias.

A note on your assumption
I've checked the Application Autostart list under Session and Startup and Nemo wasn't listed so I'm not sure why it's starting.

  • All startup applications can be found in the folder /etc/xdg/autostart. Each .desktop file is one potential startup application.
  • Each startup application may be active, i.e. it will be launched automatically, or it may be inactive.
  • Each startup application may be visible inside the Startup Application list or it may be hidden. This property is controlled by the parameter NoDisplay=False (visible) or NoDisplay=True (hidden).
  • Here is a commandline to make all autostart entries visible inside the Startup Application list:
    Code: Select all
    sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop
  • When you launch Startup Applications you will notice that the list of displayed items is much longer than before.
  • The little check mark left of each entry [X] decides whether an autostart item will be launched automatically (check mark ticked) or not (check mark unticked). So you can disable/enable autostart entries by unticking/ticking their check marks. - Leave items alone in case you do not know what they do.
  • I bet Nemo will be in the list of active autostart entries, else your desktop would be empty. Only before running the commandline given above it had been hidden.

A note on your statement
I have Xfce set up to read my backgrounds from an image list.
Sorry. I have never configured such a list on my xfce system. So I cannot advise on thise issue at the moment.

Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2529
Joined: Sat Dec 31, 2011 7:21 am

Re: Nemo, background cycling on startup

Postby malias on Tue Nov 05, 2013 8:09 pm

Thanks for the reply. So, I ran the sed command you posted and Nemo now shows in the Application list, but it shows up disabled and it's still starting on login.

For my background image, I set it to a single image and watched what happened. It looked like the wallpaper was swapping between my background and a specific wallpaper. After determining this, I checked the other desktop environments I have installed, set each background to a unique wallpaper, and logged backed into xfce. I discovered that when xfce starts it's swapping between the background image set in xfce and the one set in gnome/cinnamon. Now, why would it be clashing with xfce?

Edit

Nevermind, I think I got it figured out. A while back a shut down xfce with some applications open, including Nemo. And, when you start xfce, it starts all the applications that were running when it shut down, so that's why it was happening. I simply killed Nemo, restarted, and problem solved. I still don't know why that would have been affecting my desktop background image, but whatever.
malias
Level 1
Level 1
 
Posts: 6
Joined: Thu Oct 03, 2013 1:36 am

Re: [SOLVED] Nemo, background cycling on startup

Postby karlchen on Wed Nov 06, 2013 6:27 pm

Hello, malias.

Ha, might have occurred to me earlier:
xfce uses Thunar by default. Thunar will want to handle the desktop, which is correct. So Thunar somehow is responsible for displaying the wallpaper.
Depending on how you launched Nemo, Nemo will have felt like handling the desktop as well, which means Nemo started to interfere with your wallpapers , too.
(By the way, "nemo --no-desktop" will launch Nemo and tell it not to try and handle your desktop. - Just looked it up by running "man nemo".)

Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2529
Joined: Sat Dec 31, 2011 7:21 am

Re: [SOLVED] Nemo, background cycling on startup

Postby Domingo Medina on Fri Dec 20, 2013 7:19 pm

Code: Select all
nano /etc/xdg/autostart/

edit /etc/xdg/autostart/and either:

remove the NoDisplay=true lines;
or make those same lines comments by adding # in front of them;
or replace true by false in those same lines.

The third solution can be easily done in three steps:

Summon the terminal with Ctrl + Alt + T.
Type the two following commands:

Code: Select all
cd /etc/xdg/autostart/ sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop


After changing anything you want, you can go back to the previous state by typing this into the terminal:
Code: Select all
sudo sed --in-place 's/NoDisplay=false/NoDisplay=true/g' *.desktop


source: http://namhuy.net/388/how-do-i-addremove-the-hidden-startup-applications.html
Domingo Medina
Level 1
Level 1
 
Posts: 7
Joined: Sat Nov 30, 2013 1:05 pm

Re: [SOLVED] Nemo, background cycling on startup

Postby karlchen on Sun Dec 22, 2013 10:38 am

Hello, Domingo Medina.

This thread had already been marked as [Solved].
The correct solution had been post here.
The correct commandline reads
Code: Select all
sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop


Why the heck did you have copy and paste the crap that this guy posted in his blog here as a solution?
Wrong:
Code: Select all
nano /etc/xdg/autostart/

Code: Select all
cd /etc/xdg/autostart/ sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Correct:
Code: Select all
sudo nano /etc/xdg/autostart/*.desktop

Code: Select all
sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop


Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2529
Joined: Sat Dec 31, 2011 7:21 am


Return to Xfce

Who is online

Users browsing this forum: No registered users and 2 guests