Stop Nautilus from Auto Running at Start Up? [SOLVED]

Stop Nautilus from Auto Running at Start Up? [SOLVED]

Postby odo5435 on Sat May 26, 2012 6:15 am

(EDIT = On reflection, this problem would seem to be better suited to the 'Software and Applications' heading in LMDE - it can sometimes be confusing where to post. If a moderator agrees, it'd be appreciated if you would move this thread to that forum.)


After doing a fresh install of LMDE Xfce UP4 on my ASUS eee I changed the File Manager to Nautilus using Settings -> Preferred Applications (for no reason other than to see what it looked like). Ever since then a Nautilus window opens automatically every time we log in to a session. I am certain I made no changes to request this function, it just seems to have happened automatically. It persists even after I changed the preferred manager back to Thunar.

The settings below do not seem to mention Nautilus at all.
15.png
15.png (85.3 KiB) Viewed 2425 times


I think I've searched everywhere else and I can't seem to find anywhere in the GUI that mentions Start Up applications and I'm afraid my CLI skills are abysmal. Can anyone direct me to where I can change the settings to remove the automatic running of this unwanted window. I'd prefer not to have to remove Nautilus completely if possible.
Last edited by odo5435 on Sun May 27, 2012 3:45 am, edited 3 times in total.
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon
User avatar
odo5435
Level 4
Level 4
 
Posts: 376
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Linux Mint is funded by ads and donations.
 

Re: How Do I Stop Nautilus from Auto Running at Start Up?

Postby crborga on Sat May 26, 2012 7:44 am

Have you already unchecked run Gnome Services in the Xfce session settings?
Image
crborga
Level 2
Level 2
 
Posts: 99
Joined: Wed Oct 27, 2010 10:09 am
Location: South Carolina, USA

Re: How Do I Stop Nautilus from Auto Running at Start Up?

Postby odo5435 on Sat May 26, 2012 7:58 am

crborga wrote:Have you already unchecked run Gnome Services in the Xfce session settings?


Is this where you mean? If so, I'm pretty certain that it was never checked. I didn't want to run Gnome, I wanted Xfce.
19.png
19.png (39.71 KiB) Viewed 2413 times
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon
User avatar
odo5435
Level 4
Level 4
 
Posts: 376
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Re: How Do I Stop Nautilus from Auto Running at Start Up?

Postby crborga on Sat May 26, 2012 12:45 pm

odo5435 wrote:
crborga wrote:Have you already unchecked run Gnome Services in the Xfce session settings?


Is this where you mean? If so, I'm pretty certain that it was never checked. I didn't want to run Gnome, I wanted Xfce.
19.png

I see it is unchecked so what I would do make a simple script
Code: Select all
sleep 5
killall -9 nautilus
killall -9 caja

and add it to your startup
Image
crborga
Level 2
Level 2
 
Posts: 99
Joined: Wed Oct 27, 2010 10:09 am
Location: South Carolina, USA

Re: How Do I Stop Nautilus from Auto Running at Start Up?

Postby odo5435 on Sat May 26, 2012 8:49 pm

Thanks for your reply crborga.
crborga wrote:so what I would do make a simple script

I understand most of what your script does but am curious. Why is the 'killall caja' command necessary? I've skimmed this too-techie-for-me webpage from which I interpret CaJa to be as harmless a piece of bloat as as most other stuff required to run modern systems. Will its removal cause problems with other programs trying to load at startup?
crborga wrote:and add it to your startup

Ahh, as Shakespeare would say, 'there's the rub'. Where is the startup file located so I can add the script? I'm fairly confident of being able to copy and paste your script into the file, but I'm afraid I'm going to need to be pointed in the right direction.

I'm not a total newb, but have a bad habit of my eyes glazinig over and nodding off to sleep whenever things too technical are being discussed.
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon
User avatar
odo5435
Level 4
Level 4
 
Posts: 376
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Re: How Do I Stop Nautilus from Auto Running at Start Up?

Postby crborga on Sat May 26, 2012 11:26 pm

From terminal do nano killnautilus.sh paste this
Code: Select all
sleep 5
killall -9 nautilus
killillall -9 caja
exit

chmod +x killnautilus.sh
Then go into the Session and Startup (which you had in the screenshots) and click Add. Now just give it a description and command would be (assuming you have it in your home directory)
Code: Select all
/home/yourusername/killnautilus.sh

save it and relog


Hope this helps
Image
crborga
Level 2
Level 2
 
Posts: 99
Joined: Wed Oct 27, 2010 10:09 am
Location: South Carolina, USA

Re: How Do I Stop Nautilus from Auto Running at Start Up?

Postby jjaythomas on Sat May 26, 2012 11:56 pm

Might be...
Got into session (when saved seem like auto-start app)

try...
1.check with task manager if any processes running nautilus (or caja)
2.if are kill process in task manager
3.in main menu>setting>session and start up under session tab re-save session (make sure not listed in list)
4. log-out (make sure 'save session box not checked)
5. log-back in

If still happening I'm out of ammo (try above script maybe) :cry:

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: How Do I Stop Nautilus from Auto Running at Start Up?

Postby odo5435 on Sun May 27, 2012 3:44 am

Thank you crborga and jjaythomas for your replies. I decided to try jjay's solution first. I'd have been happy to try your method crb, but after so many years of enforced Windows usage I'm a GUI type of person these days even though I started my Personal Computing experience (many years ago) in a Unix environment. Also, I would have needed further clarification on the CaJa issue. No offence intended, but I'm reluctant to copy and paste any script, regardless of source, without understanding what they do. The kill-caja process may have happened in the background using jjay's GUI method but, hey, what I don't see doesn't hurt me (I hope).

As for the results, I followed jjay's instructons to the letter and they worked perfectly, well except that I left the System Monitor window open when I logged out and had to repeat the process to stop that from auto starting. :oops:

Which also gave me insight into how the situation arose. I must have had the Nautilus window open when I logged out and its been remembering it ever since (although I was sure I'd unchecked the Save Session box the first time I encountered it). But then, why didn't it show in the Session Start Up details??? No matter, problem solved and marked as such.
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon
User avatar
odo5435
Level 4
Level 4
 
Posts: 376
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Re: Stop Nautilus from Auto Running at Start Up? [SOLVED]

Postby crborga on Sun May 27, 2012 7:57 am

Caja is the official file manager for the MATE desktop. It allows to browse directories, preview files and launch applications associated with them. It is also responsible for handling the icons on the MATE desktop. It works on local and remote filesystems.

http://mate-desktop.org/applications/

Script just issues the kill command to both just in case you had Mate. His method is probably better anyway as mine was kind of a dirty hack but it would have accomplished the same basically.
Image
crborga
Level 2
Level 2
 
Posts: 99
Joined: Wed Oct 27, 2010 10:09 am
Location: South Carolina, USA

Re: Stop Nautilus from Auto Running at Start Up? [SOLVED]

Postby jjaythomas on Sun May 27, 2012 1:04 pm

Very Happy worked for you :D
Both answers are basically same, mine just prefers a GUI to CLI solution.

Had happen to someone else on forum already and that was problem.

P.S. not all session start-up show in the GUI (I not sure why :roll: ) if I add HPLIP-toolkit (qt app I know) it does but alarm-applet and cairodock (both GTK I think) don't, even if their???

J.Jay

P.S. you may want to check forum posts and change draw_dekstop setting, if planning to keep nautilus. May avoid later problems related to nautilus in XFCE. :wink:

J.Jay

Edit that a good method of 'shaving' some service type stuff (if you know for sure) from running in background. :idea:
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 3 guests