Certain Applications crash Gnome Shell after installing UP8

Certain Applications crash Gnome Shell after installing UP8

Postby CruelChris on Sat Mar 29, 2014 3:28 pm

I have installed Mint Debian's Update Pack 8 today. Since then, launching certain applications such as Docky, Gedit or Gnote causes Gnome Shell to crash. It displays the infamous "Oh no! Something is wrong..." screen and forces me to log out. This happens on both Gnome and Gnome Classic. Gnome Flashback works. Cinnamon also worked, although in the meantime I have tried removing it (apt-get remove cinnamon-session), but that had no effect on Gnome Shell either.

I'm using the 64-bit version on a Thinkpad X220.

Any help is very much appreciated!
CruelChris
Level 1
Level 1
 
Posts: 8
Joined: Tue Jul 24, 2012 2:16 pm

Linux Mint is funded by ads and donations.
 

Re: Certain Applications crash Gnome Shell after installing

Postby Monsta on Sat Mar 29, 2014 3:48 pm

Post the output of:
Code: Select all
cat ~/.xsession-errors
(don't forget to use the "code" tag)
Monsta
Level 9
Level 9
 
Posts: 2514
Joined: Fri Aug 19, 2011 3:46 am

Re: Certain Applications crash Gnome Shell after installing

Postby CruelChris on Sat Mar 29, 2014 5:02 pm

Thanks for the quick response! Below is the file. I had to shorten it though, because it was over 7 MB. Most of the messages were displayed frequently, so I had to delete a lot of them. (If you need the full 7mb file, let me know...)

Code: Select all
/etc/gdm3/Xsession: Beginning session setup...
localuser:christian being added to access control list
Skript für ibus unter run_im gestartet.
Skript für auto unter run_im gestartet.
Skript für default unter run_im gestartet.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Skript für ibus unter run_im gestartet.
Skript für auto unter run_im gestartet.
Skript für default unter run_im gestartet.
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
GNOME_KEYRING_CONTROL=/home/christian/.cache/keyring-OkCrWU
GNOME_KEYRING_CONTROL=/home/christian/.cache/keyring-OkCrWU
SSH_AUTH_SOCK=/home/christian/.cache/keyring-OkCrWU/ssh
GNOME_KEYRING_CONTROL=/home/christian/.cache/keyring-OkCrWU
SSH_AUTH_SOCK=/home/christian/.cache/keyring-OkCrWU/ssh
GPG_AGENT_INFO=/home/christian/.cache/keyring-OkCrWU/gpg:0:1
GNOME_KEYRING_CONTROL=/home/christian/.cache/keyring-OkCrWU
SSH_AUTH_SOCK=/home/christian/.cache/keyring-OkCrWU/ssh
GPG_AGENT_INFO=/home/christian/.cache/keyring-OkCrWU/gpg:0:1
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected

** (gnome-settings-daemon:4678): WARNING **: /usr/lib/gnome-settings-daemon-3.0/libupdates.so: undefined symbol: pk_control_set_root_async

** (gnome-settings-daemon:4678): WARNING **: Cannot load plugin 'Aktualisierungen' since file '/usr/lib/gnome-settings-daemon-3.0/libupdates.so' cannot be read.

** (gnome-settings-daemon:4678): WARNING **: Error activating plugin 'Aktualisierungen'
x-session-manager[4512]: WARNING: Failed to start app: Unable to start application: Kindprozess »/usr/lib/tracker/tracker-miner-fs« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
x-session-manager[4512]: WARNING: Failed to start app: Unable to start application: Kindprozess »cinnamon-screensaver« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
x-session-manager[4512]: WARNING: Failed to start app: Unable to start application: Kindprozess »/usr/lib/tracker/tracker-store« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
** Message: applet now removed from the notification area
x-session-manager[4512]: WARNING: Failed to start app: Unable to start application: Kindprozess »synaptikscfg« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
Starting Dropbox.../usr/lib/python2.7/dist-packages/blueman/plugins/applet/AppIndicator.py:44: Warning: /tmp/buildd/glib2.0-2.36.4/./gobject/gsignal.c:2475: signal `child-added' is invalid for instance `0x2bfc1c0' of type `GtkMenu'
[Info  11:23:52.675] [ThemeService] Setting theme: Matte
[Warn  11:23:52.743] [DesktopItemService] Could not find remap file '/home/christian/.local/share/docky/remaps.ini'!
    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/home/christian/.local/share/gnome-shell/extensions/weather-extension@xeked.com/extension.js' line 597 exception 0 number 157
    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/home/christian/.local/share/gnome-shell/extensions/weather-extension@xeked.com/extension.js' line 1012 exception 0 number 157

(gnome-shell:4694): Clutter-CRITICAL **: clutter_actor_insert_child_at_index: assertion `child->priv->parent == NULL' failed
    JS ERROR: !!!   WARNING: 'assignment to undeclared variable signalId'
    JS ERROR: !!!   WARNING: file '/usr/share/gnome-shell/extensions/native-window-placement@gnome-shell-extensions.gcampax.github.com/extension.js' line 124 exception 0 number 156
      JS LOG: GNOME Shell started at Sat Mar 29 2014 11:23:53 GMT+0100 (CET)
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
[Info  11:23:53.329] [DockServices] Dock services initialized.
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected

** (nemo:4713): WARNING **: Can not determine workarea, guessing at layout
Agent registration failed: GDBus.Error:org.bluez.Error.AlreadyExists: Already Exists
** Message: applet now embedded in the notification area
failed to create drawable
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Got a request to focus 0x2000006 (Arbeitsfl?) with a timestamp of 0.  This shouldn't happen!

(dropbox:4805): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed

(cryptkeeper:4768): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
[Info  11:23:54.844] [PluginManager] Loaded "CPU Monitor".
[Info  11:23:54.847] [PluginManager] Loaded "Docky.Widgets,1.0".
[Info  11:23:54.847] [PluginManager] Loaded "Clock".
[Info  11:23:54.848] [PluginManager] Loaded "Trash".
Fensterverwalter-Warnung:Log level 8: _shell_embedded_window_unrealize: assertion `SHELL_IS_EMBEDDED_WINDOW (window)' failed
[Info  11:23:55.307] [HelperService] Helper added: /usr/share/dockmanager/scripts/hamster_control.py
Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Got a request to focus 0x2000006 (Arbeitsfl?) with a timestamp of 0.  This shouldn't happen!
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Terminated
Fensterverwalter-Warnung:Log level 8: _shell_embedded_window_unrealize: assertion `SHELL_IS_EMBEDDED_WINDOW (window)' failed
glibtop: Non-standard uts for running kernel:
release 3.12-9.dmz.2-liquorix-amd64=3.12.0 gives version code 199680

    JS ERROR: !!!   Exception in callback for signal: destroy
    JS ERROR: !!!     message = '"menuData is undefined"'
    JS ERROR: !!!     fileName = '"/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js"'
    JS ERROR: !!!     lineNumber = '371'
    JS ERROR: !!!     stack = '"([object Object])@/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js:371
([object Object])@/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js:39
([object Object])@/usr/share/gnome-shell/js/ui/popupMenu.js:2237
wrapper([object Object])@/usr/share/gjs-1.0/lang.js:213
_emit("destroy")@/usr/share/gjs-1.0/signals.js:124
()@/usr/share/gnome-shell/js/ui/popupMenu.js:1163
wrapper()@/usr/share/gjs-1.0/lang.js:213
_parent()@/usr/share/gjs-1.0/lang.js:175
()@/usr/share/gnome-shell/js/ui/popupMenu.js:1809
wrapper()@/usr/share/gjs-1.0/lang.js:213
([object Object])@/usr/share/gnome-shell/js/ui/panelMenu.js:135
wrapper([object Object])@/usr/share/gjs-1.0/lang.js:213
()@/usr/share/gnome-shell/js/ui/panel.js:598
wrapper()@/usr/share/gjs-1.0/lang.js:213
()@/usr/share/gnome-shell/js/ui/panel.js:573
wrapper()@/usr/share/gjs-1.0/lang.js:213
([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gnome-shell/js/ui/panel.js:494
wrapper([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gjs-1.0/lang.js:213
"'
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Got a request to focus 0x3a00003 (luckyBacku) with a timestamp of 0.  This shouldn't happen!
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
[17360:17384:0329/113129:ERROR:object_proxy.cc(627)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[17360:17384:0329/113129:ERROR:object_proxy.cc(627)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[17360:17360:0329/113129:ERROR:object_proxy.cc(532)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Got a request to focus 0x3a00003 (luckyBacku) with a timestamp of 0.  This shouldn't happen!
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.

(gnome-shell:4694): St-CRITICAL **: _st_paint_shadow_with_opacity: assertion `shadow_spec != NULL' failed
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
[19210:19234:0329/113340:ERROR:object_proxy.cc(627)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[19210:19234:0329/113340:ERROR:object_proxy.cc(627)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[19210:19210:0329/113340:ERROR:object_proxy.cc(532)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Got a request to focus 0x3a00003 (luckyBacku) with a timestamp of 0.  This shouldn't happen!
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
[26646:26670:0329/114302:ERROR:object_proxy.cc(627)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[26646:26670:0329/114302:ERROR:object_proxy.cc(627)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
[26646:26646:0329/114303:ERROR:object_proxy.cc(532)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Got a request to focus 0x3a00003 (luckyBacku) with a timestamp of 0.  This shouldn't happen!
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
glibtop: Non-standard uts for running kernel:
release 3.12-9.dmz.2-liquorix-amd64=3.12.0 gives version code 199680

Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected

** (gnome-system-monitor:31307): WARNING **: SELinux was found but is not enabled.

Fensterverwalter-Warnung:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Log level 8: meta_window_lower: assertion `!window->override_redirect' failed
Fensterverwalter-Warnung:Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x2000004 (Systemübe)
Fensterverwalter-Warnung:meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
"'
    JS ERROR: !!!   Exception in callback for signal: destroy
    JS ERROR: !!!     message = '"menuData is undefined"'
    JS ERROR: !!!     fileName = '"/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js"'
    JS ERROR: !!!     lineNumber = '371'
    JS ERROR: !!!     stack = '"([object Object])@/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js:371
([object Object])@/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js:39
([object Object])@/usr/share/gnome-shell/js/ui/popupMenu.js:2237
wrapper([object Object])@/usr/share/gjs-1.0/lang.js:213
_emit("destroy")@/usr/share/gjs-1.0/signals.js:124
()@/usr/share/gnome-shell/js/ui/popupMenu.js:1163
wrapper()@/usr/share/gjs-1.0/lang.js:213
_parent()@/usr/share/gjs-1.0/lang.js:175
()@/usr/share/gnome-shell/js/ui/popupMenu.js:1809
wrapper()@/usr/share/gjs-1.0/lang.js:213
([object Object])@/usr/share/gnome-shell/js/ui/panelMenu.js:135
wrapper([object Object])@/usr/share/gjs-1.0/lang.js:213
()@/usr/share/gnome-shell/js/ui/panel.js:598
wrapper()@/usr/share/gjs-1.0/lang.js:213
()@/usr/share/gnome-shell/js/ui/panel.js:573
wrapper()@/usr/share/gjs-1.0/lang.js:213
([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gnome-shell/js/ui/panel.js:494
wrapper([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gjs-1.0/lang.js:213
""

non-double matrix elementFontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78:
saw unknown, expected numberFontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70:
non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/25-wqy-zenhei.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element

Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix elementnon-double matrix element

Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected numbersaw unknown, expected number

(gnome-settings-daemon:4678): libupower-glib-WARNING **: unhandled property 'Temperature'
Fensterverwalter-Warnung:CurrentTime used to choose focus window; focus window may not be correct.
Fensterverwalter-Warnung:Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!

(gnome-settings-daemon:4678): libupower-glib-WARNING **: unhandled property 'Temperature'

    JS ERROR: !!!   Exception in callback for signal: destroy
    JS ERROR: !!!     message = '"menuData is undefined"'
    JS ERROR: !!!     fileName = '"/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js"'
    JS ERROR: !!!     lineNumber = '371'
    JS ERROR: !!!     stack = '"([object Object])@/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js:371
([object Object])@/home/christian/.local/share/gnome-shell/extensions/panelSettings@eddiefullmetal.gr/extension.js:39
([object Object])@/usr/share/gnome-shell/js/ui/popupMenu.js:2237
wrapper([object Object])@/usr/share/gjs-1.0/lang.js:213
_emit("destroy")@/usr/share/gjs-1.0/signals.js:124
()@/usr/share/gnome-shell/js/ui/popupMenu.js:1163
wrapper()@/usr/share/gjs-1.0/lang.js:213
_parent()@/usr/share/gjs-1.0/lang.js:175
()@/usr/share/gnome-shell/js/ui/popupMenu.js:1809
wrapper()@/usr/share/gjs-1.0/lang.js:213
([object Object])@/usr/share/gnome-shell/js/ui/panelMenu.js:135
wrapper([object Object])@/usr/share/gjs-1.0/lang.js:213
()@/usr/share/gnome-shell/js/ui/panel.js:598
wrapper()@/usr/share/gjs-1.0/lang.js:213
()@/usr/share/gnome-shell/js/ui/panel.js:573
wrapper()@/usr/share/gjs-1.0/lang.js:213
([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gnome-shell/js/ui/panel.js:494
wrapper([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gjs-1.0/lang.js:213
"'

(gnome-settings-daemon:4678): libupower-glib-WARNING **: unhandled property 'Temperature'

(gnome(gnome-settings-daemon:4678): libupower-glib-WARNING **: unhandled property 'Temperature'
ERROR:dbus.connection:Unable to set arguments ('Dropbox', dbus.UInt32(0L), '', u'2014-03-29 14.14.24.jpg hinzugef\xfcgt', u'\u201e2014-03-29 14.14.24.jpg\u201c wurde Ihrer Dropbox hinzugef\xfcgt.', [], {'y': 1102, 'x': 1520, 'icon_data': (dbus.Int32(128), dbus.Int32(128), dbus.Int32(512), dbus.Boolean(True), dbus.Int32(8), dbus.Int32(4), dbus.ByteArray('\xff\xff\xff\x00\xff\xff\xff\x00\xff
[...]
\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00\xff\xff\xff\x00'))}, -1) according to signature None: <type 'exceptions.ValueError'>: Unable to guess signature from an empty list

(gnome-settings-daemon:4678): libupower-glib-WARNING **: unhandled property 'Temperature'
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py", line 220, in Run
Fensterverwalter-Warnung:Log level 8: gtk_tree_path_get_depth: assertion `path != NULL' failed
    ret = getattr(inst, function)(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/blueman/plugins/applet/TransferService.py", line 61, in on_manager_state_changed
Fensterverwalter-Warnung:Log level 8: gtk_tree_path_get_depth: assertion `path != NULL' failed
    self.Transfer.DisconnectAll()
  File "/usr/lib/python2.7/dist-packages/blueman/ods/OdsManager.py", line 82, in DisconnectAll
    on_destroyed(None)
TypeError: on_destroyed() takes exactly 2 arguments (1 given)
Fensterverwalter-Warnung:Log level 8: _shell_embedded_window_unrealize: assertion `SHELL_IS_EMBEDDED_WINDOW (window)' failed
x-session-manager[4512]: Gdk-WARNING: x-session-manager: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.


(gnome-screensaver:4804): Gdk-WARNING **: gnome-screensaver: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.

(nm-applet:4706): Gdk-WARNING **: nm-applet: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.

cryptkeeper: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.
blueman-applet: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.

(gnote:4816): Gdk-WARNING **: gnote: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.


(gdu-notification-daemon:4777): Gdk-WARNING **: gdu-notification-daemon: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.


(evolution-alarm-notify:4903): Gdk-WARNING **: evolution-alarm-notify: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.

synapse: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.
dropbox: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.

(gnome-shell-calendar-server:4991): Gdk-WARNING **: gnome-shell-calendar-server: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.

Fensterverwalter-Warnung:Log level 16: gnome-shell: Fatal IO error 0 (Erfolg) on X server :0.


(gnome-settings-daemon:4678): Gdk-WARNING **: gnome-settings-daemon: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.

nfo] Unable to create AppInfo
Loading configuration plugins
blueman-applet version 1.23 starting
Stale PID, overwriting
Using gconf config backend
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Methode »randr« wird benutzt.
Xsession: X session started for christian at Sa 29. Mär 17:52:12 CET 2014
localuser:christian being added to access control list
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
x-session-manager[7279]: WARNING: Error while executing session-migration: Kindprozess »session-migration« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-048xw4
SSH_AUTH_SOCK=/run/user/1000/keyring-048xw4/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-048xw4/gpg:0:1
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-048xw4
SSH_AUTH_SOCK=/run/user/1000/keyring-048xw4/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-048xw4/gpg:0:1
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-048xw4
SSH_AUTH_SOCK=/run/user/1000/keyring-048xw4/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-048xw4/gpg:0:1
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-048xw4
SSH_AUTH_SOCK=/run/user/1000/keyring-048xw4/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-048xw4/gpg:0:1
Fehlgeschlagen: Modulinitialisierung fehlgeschlagen

(cinnamon-settings-daemon:7343): color-plugin-WARNING **: failed to create device: failed to obtain org.freedesktop.color-manager.create-device auth

(cinnamon-settings-daemon:7343): color-plugin-WARNING **: failed to create device: failed to obtain org.freedesktop.color-manager.create-device auth

(cinnamon-settings-daemon:7343): color-plugin-WARNING **: failed to obtain org.freedesktop.color-manager.create-profile auth

(cinnamon-settings-daemon:7343): color-plugin-WARNING **: failed to reset xrandr-LVDS1 gamma tables: gamma size is zero
access control disabled, clients can connect from any host
x-session-manager[7279]: WARNING: Failed to start app: Unable to start application: Kindprozess »/usr/lib/tracker/tracker-miner-fs« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
x-session-manager[7279]: WARNING: Failed to start app: Unable to start application: Kindprozess »/usr/lib/tracker/tracker-store« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
x-session-manager[7279]: WARNING: Failed to start app: Unable to start application: Kindprozess »synaptikscfg« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
To link this computer to a dropbox account, visit the following url:

** (polkit-gnome-authentication-agent-1:7396): WARNING **: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Cannot register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Initializing nemo-dropbox 2.0.1
Loading configuration plugins
blueman-applet version 1.23 starting
There is an instance already running
      JS LOG: About to start Cinnamon
** Message: applet now removed from the notification area

** (nemo:7409): WARNING **: Can not get _NET_WORKAREA

** (nemo:7409): WARNING **: Can not determine workarea, guessing at layout
      JS LOG: Cinnamon started at Sat Mar 29 2014 17:52:14 GMT+0100 (CET)

(cryptkeeper:7397): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
      JS LOG: network applet: Found connection for active
x-session-manager[7279]: CRITICAL: csm_manager_set_phase: assertion `CSM_IS_MANAGER (manager)' failed
x-session-manager[7279]: Gtk-CRITICAL: gtk_main_quit: assertion `main_loops != NULL' failed
[1396111933,000,xklavier.c:xkl_engine_start_listen/]    The backend does not require manual layout management - but it is provided by the application
Xsession: X session started for christian at Sa 29. Mär 19:51:40 CET 2014
localuser:christian being added to access control list
Skript für ibus unter run_im gestartet.
Skript für auto unter run_im gestartet.
Skript für default unter run_im gestartet.

(process:8556): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.

(process:8556): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Skript für ibus unter run_im gestartet.
Skript für auto unter run_im gestartet.
Skript für default unter run_im gestartet.
x-session-manager[8588]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.

x-session-manager[8588]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Lurcg1
GPG_AGENT_INFO=/run/user/1000/keyring-Lurcg1/gpg:0:1
GNOME_KEYRING_PID=8658
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
x-session-manager[8588]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used

(process:8670): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
x-session-manager[8588]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
x-session-manager[8588]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.

(process:8670): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
x-session-manager[8588]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Lurcg1
GPG_AGENT_INFO=/run/user/1000/keyring-Lurcg1/gpg:0:1
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Lurcg1
GPG_AGENT_INFO=/run/user/1000/keyring-Lurcg1/gpg:0:1
SSH_AUTH_SOCK=/run/user/1000/keyring-Lurcg1/ssh
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Lurcg1
GPG_AGENT_INFO=/run/user/1000/keyring-Lurcg1/gpg:0:1

(gnome-shell:8726): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.

(gnome-shell:8726): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
x-session-manager[8588]: Gdk-WARNING: x-session-manager: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :1.


(gnome-shell:8726): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Keine Berechtigung.  dconf will not work properly.
blueman-applet: Fatal IO error 4 (Unterbrechung während des Betriebssystemaufrufs) on X server :1.
Loading configuration plugins
blueman-applet version 1.23 starting
Stale PID, overwriting
Using gconf config backend
Using gconf config backend
CruelChris
Level 1
Level 1
 
Posts: 8
Joined: Tue Jul 24, 2012 2:16 pm

Re: Certain Applications crash Gnome Shell after installing

Postby Monsta on Sat Mar 29, 2014 5:06 pm

Oh yeah, eddiefullmetal strikes again. That extension (Panel Settings) is not compatible with Gnome 3.8. Remove it.

Your log also shows you have problems with /run/user permissions. Remove libpam-systemd and systemd packages to fix it.
Monsta
Level 9
Level 9
 
Posts: 2514
Joined: Fri Aug 19, 2011 3:46 am

Re: Certain Applications crash Gnome Shell after installing

Postby CruelChris on Sat Mar 29, 2014 6:37 pm

Thanks very much so far! I removed all extensions, unfortunately the problem persists.

When I attempt to remove libpam-systemd and systemd packages, apt-get would remove various gnome-related packages as well, so that does not seem to be an option.
CruelChris
Level 1
Level 1
 
Posts: 8
Joined: Tue Jul 24, 2012 2:16 pm

Re: Certain Applications crash Gnome Shell after installing

Postby Monsta on Sun Mar 30, 2014 2:18 am

CruelChris wrote:Thanks very much so far! I removed all extensions, unfortunately the problem persists.

I think it's better to not just remove them from the panel, but to clean up the directory they are in, see an example here.

CruelChris wrote:When I attempt to remove libpam-systemd and systemd packages, apt-get would remove various gnome-related packages as well, so that does not seem to be an option.

Interesting. Gnome depends on systemd already? Can you post the output of what apt-get says?
Monsta
Level 9
Level 9
 
Posts: 2514
Joined: Fri Aug 19, 2011 3:46 am

Re: Certain Applications crash Gnome Shell after installing

Postby CruelChris on Sun Mar 30, 2014 4:19 am

Monsta wrote:
CruelChris wrote:Thanks very much so far! I removed all extensions, unfortunately the problem persists.

I think it's better to not just remove them from the panel, but to clean up the directory they are in, see an example here.

I think that's what I did. I apt-get removed gnome-shell-extensions so \usr\share\gnome-shell\extensions is empty, then removed files from ~\.local\share\gnome-shell\extensions.

Monsta wrote:
CruelChris wrote:When I attempt to remove libpam-systemd and systemd packages, apt-get would remove various gnome-related packages as well, so that does not seem to be an option.

Interesting. Gnome depends on systemd already? Can you post the output of what apt-get says?

Here it is. I did an
Code: Select all
$ sudo apt-get -s remove libpam-systemd systemd

and as output got:
Code: Select all
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  evolution-webcal gir1.2-clutter-gst-1.0 gir1.2-folks-0.6 gir1.2-gee-1.0
  gir1.2-gst-plugins-base-0.10 gir1.2-gtop-2.0 gtk3-engines-unico lesstif2
  libavcodec53:i386 libavutil51:i386 libbctsp-java libboost-date-time1.49.0
  libboost-date-time1.53.0 libboost-filesystem1.49.0 libboost-python1.49.0
  libboost-regex1.49.0 libboost-serialization1.49.0 libboost-signals1.49.0
  libboost-system1.49.0 libboost-system1.53.0 libboost-thread1.49.0
  libclass-isa-perl libclutter-gst-1.0-0 libcluttergesture-0.0.2-0
  libcppunit-1.13-0 libcsync-plugin-owncloud libcsync-plugin-sftp
  libcsync-plugin-smb libcsync0 libdirac-encoder0:i386 libepc-1.0-3
  libepc-ui-1.0-3 libexosip2-7 libfakekey0 libgnome-desktop-3-2 libibus-1.0-0
  libkms1 liblavfile-2.0-0 liblavjpeg-2.0-0 liblavplay-2.0-0 liblinphone4
  libllvm3.2 libllvm3.2:i386 libmatroska5 libmediastreamer1
  libmjpegutils-2.0-0 libmockito-java libmozjs5d libmpeg2encpp-2.0-0
  libmplex2-2.0-0 libmx-1.0-2 libobjenesis-java liborcus-0.4-0 libortp8
  libosip2-7 libprotobuf-lite7 librhythmbox-core7 libtelepathy-logger2
  libtorrent-rasterbar6 libudev0:i386 libx264-123 libx264-124:i386 libx264-135
  mintstick muffin-common nemo-data python-aptdaemon.gtk3widgets python-ibus
  python-pyatspi2 texlive-doc-ar texlive-doc-bg texlive-doc-cs+sk
  texlive-doc-de texlive-doc-en texlive-doc-es texlive-doc-fi texlive-doc-fr
  texlive-doc-it texlive-doc-ja texlive-doc-ko texlive-doc-mn texlive-doc-nl
  texlive-doc-pl texlive-doc-pt texlive-doc-rs texlive-doc-ru texlive-doc-si
  texlive-doc-th texlive-doc-tr texlive-doc-uk texlive-doc-vi texlive-doc-zh
  texlive-lang-armenian texlive-lang-croatian texlive-lang-danish
  texlive-lang-dutch texlive-lang-finnish texlive-lang-hebrew
  texlive-lang-hungarian texlive-lang-latin texlive-lang-latvian
  texlive-lang-lithuanian texlive-lang-mongolian texlive-lang-norwegian
  texlive-lang-swedish texlive-lang-tibetan texlive-lang-vietnamese
  ttf-marvosym xulrunner-5.0
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  gdm3 gnome-control-center gnome-core gnome-packagekit
  gnome-packagekit-session gnome-power-manager gnome-session
  gnome-session-fallback gnome-session-flashback gnome-settings-daemon
  gnome-shell gnome-shell-timer indicator-session libpam-systemd systemd
0 aktualisiert, 0 neu installiert, 15 zu entfernen und 0 nicht aktualisiert.
Remv gnome-core [1:3.8+4]
Remv gnome-shell-timer [0.0.20130422-1]
Remv gnome-shell [3.8.4-5] [gdm3:amd64 gnome-session:amd64 ]
Remv gdm3 [3.8.4-6] [gnome-session:amd64 ]
Remv gnome-control-center [1:3.8.3-4] [gnome-session:amd64 ]
Remv gnome-packagekit [3.8.2-4] [gnome-session:amd64 ]
Remv gnome-packagekit-session [3.8.2-4] [gnome-session:amd64 ]
Remv gnome-power-manager [3.8.2-1] [gnome-session:amd64 ]
Remv gnome-session [3.8.4-3]
Remv gnome-session-fallback [3.8.0-1]
Remv gnome-session-flashback [3.8.0-1]
Remv indicator-session [0.3.96-1+b1]
Remv gnome-settings-daemon [3.8.5-2]
Remv libpam-systemd [204-5linuxmint1]
Remv systemd [204-5linuxmint1]
CruelChris
Level 1
Level 1
 
Posts: 8
Joined: Tue Jul 24, 2012 2:16 pm

Re: Certain Applications crash Gnome Shell after installing

Postby CruelChris on Sun Mar 30, 2014 6:04 am

Ok, so I just went through Synaptic, searching for gnome-shell related entries, when I found the package gnome-shell-timer. I didn't realize before I had this installed (because the /gnome-shell/extensions folders were empty), so I removed it and since then, no more crashes.
CruelChris
Level 1
Level 1
 
Posts: 8
Joined: Tue Jul 24, 2012 2:16 pm

Re: Certain Applications crash Gnome Shell after installing

Postby TarasMK on Tue Apr 01, 2014 2:29 pm

Hi All,

I'm facing the same problem. Unfortunately removing extensions (as packages and from home dir) didn't solve my problem.
Shell starts fine, but gnome-tweak-tool and some others crash it.

Any ideas how I can trace the cause of the problem?

Here is my .xsession-errors (it has more messages then needed, as I removed already extensions dir):
Code: Select all
/etc/gdm3/Xsession: Beginning session setup...
/etc/gdm3/Xsession: 17: [: unexpected operator
localuser:taras being added to access control list
GNOME_KEYRING_CONTROL=/home/taras/.cache/keyring-3bBpuv
GPG_AGENT_INFO=/home/taras/.cache/keyring-3bBpuv/gpg:0:1
GNOME_KEYRING_CONTROL=/home/taras/.cache/keyring-3bBpuv
GPG_AGENT_INFO=/home/taras/.cache/keyring-3bBpuv/gpg:0:1
GNOME_KEYRING_CONTROL=/home/taras/.cache/keyring-3bBpuv
GPG_AGENT_INFO=/home/taras/.cache/keyring-3bBpuv/gpg:0:1
SSH_AUTH_SOCK=/home/taras/.cache/keyring-3bBpuv/ssh
GNOME_KEYRING_CONTROL=/home/taras/.cache/keyring-3bBpuv
GPG_AGENT_INFO=/home/taras/.cache/keyring-3bBpuv/gpg:0:1
SSH_AUTH_SOCK=/home/taras/.cache/keyring-3bBpuv/ssh
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected

** (gnome-settings-daemon:4366): WARNING **: /usr/lib/gnome-settings-daemon-3.0/libupdates.so: undefined symbol: pk_control_set_root_async

** (gnome-settings-daemon:4366): WARNING **: Cannot load plugin 'Оновлення' since file '/usr/lib/gnome-settings-daemon-3.0/libupdates.so' cannot be read.

** (gnome-settings-daemon:4366): WARNING **: Error activating plugin 'Оновлення'

(gnome-shell:4390): Clutter-WARNING **: Whoever translated default:LTR did so wrongly.
access control disabled, clients can connect from any host
x-session-manager[4283]: WARNING: Failed to start app: Unable to start application: Помилка виконання дочірнього процесу "cinnamon-screensaver" (No such file or directory)
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Initializing nautilus-image-converter extension
Initializing nautilus-gdu extension
Initializing nautilus-dropbox 1.4.0
Initializing nautilus-open-terminal extension
Starting Dropbox...Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected

** (nm-applet:4410): WARNING **: Could not create object for /org/freedesktop/NetworkManager/Settings/11: uid 1000 has no permission to perform this operation

** (nm-applet:4410): WARNING **: handle_property_changed: failed to update property 'available-connections' of object type NMDeviceBt.
** Message: applet now removed from the notification area
ping: unknown host google.com
Попередження віконного менеджера:Log level 16: Could not create object for /org/freedesktop/NetworkManager/Settings/11: uid 1000 has no permission to perform this operation
Попередження віконного менеджера:Log level 16: handle_property_changed: failed to update property 'available-connections' of object type NMDeviceBt.
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
      JS LOG: System monitor applet init from /home/taras/.local/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com
      JS LOG: System monitor applet enabling
glibtop: Non-standard uts for running kernel:
release 3.10-2-amd64=3.10.0 gives version code 199168

      JS LOG: System monitor applet enabling done
Dropbox isn't running!
Done!
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.
    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/home/taras/.local/share/gnome-shell/extensions/weather-extension@xeked.com/extension.js' line 597 exception 0 number 157
    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/home/taras/.local/share/gnome-shell/extensions/weather-extension@xeked.com/extension.js' line 1012 exception 0 number 157

(gnome-shell:4390): Clutter-CRITICAL **: clutter_actor_insert_child_at_index: assertion `child->priv->parent == NULL' failed
      JS LOG: [impatience] enabled
      JS LOG: [impatience] setting new speed: 0.75
      JS LOG: GNOME Shell started at Tue Feb 04 2014 20:47:33 GMT+0200 (EET)
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
failed to create drawable
** Message: applet now embedded in the notification area

(dropbox:4450): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed

(clipit:4398): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
Agent unregistration failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownObject: Method "UnregisterAgent" with signature "o" on interface "org.bluez.Adapter" doesn't exist
 'g-io-error-quark'
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.

(process:4997): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Попередження віконного менеджера:CurrentTime used to choose focus window; focus window may not be correct.
Попередження віконного менеджера:Got a request to focus 0x2400006 (Стіль) with a timestamp of 0.  This shouldn't happen!

(process:5066): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Попередження віконного менеджера:CurrentTime used to choose focus window; focus window may not be correct.
Попередження віконного менеджера:Got a request to focus 0x2400006 (Стіль) with a timestamp of 0.  This shouldn't happen!

(process:5073): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Попередження віконного менеджера:CurrentTime used to choose focus window; focus window may not be correct.
Попередження віконного менеджера:Got a request to focus 0x2400006 (Стіль) with a timestamp of 0.  This shouldn't happen!
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.
Попередження віконного менеджера:Log level 8: meta_window_actor_mapped: assertion `!priv->mapped' failed
Попередження віконного менеджера:CurrentTime used to choose focus window; focus window may not be correct.
Попередження віконного менеджера:Got a request to focus 0x2400006 (Стіль) with a timestamp of 0.  This shouldn't happen!
Попередження віконного менеджера:CurrentTime used to choose focus window; focus window may not be correct.
Попередження віконного менеджера:Got a request to focus 0x2400006 (Стіль) with a timestamp of 0.  This shouldn't happen!
Попередження віконного менеджера:Log level 8: meta_window_actor_mapped: assertion `!priv->mapped' failed
Попередження віконного менеджера:Log level 8: meta_window_actor_mapped: assertion `!priv->mapped' failed
Попередження віконного менеджера:Log level 8: meta_window_actor_mapped: assertion `!priv->mapped' failed
    JS ERROR: !!!   Exception was: TypeError: this._myWindowClass.listAllWindows is not a function
    JS ERROR: !!!     message = '"this._myWindowClass.listAllWindows is not a function"'
    JS ERROR: !!!     fileName = '"/home/taras/.local/share/gnome-shell/extensions/panel-docklet@quina.at/extension.js"'
    JS ERROR: !!!     lineNumber = '4215'
    JS ERROR: !!!     stack = '"()@/home/taras/.local/share/gnome-shell/extensions/panel-docklet@quina.at/extension.js:4215
"'
Попередження віконного менеджера:Log level 16: STACK_OP_RAISE_ABOVE: sibling window 0xc00123 not in stack
    JS ERROR: !!!   Exception was: TypeError: this._myWindowClass.listAllWindows is not a function
    JS ERROR: !!!     message = '"this._myWindowClass.listAllWindows is not a function"'
    JS ERROR: !!!     fileName = '"/home/taras/.local/share/gnome-shell/extensions/panel-docklet@quina.at/extension.js"'
    JS ERROR: !!!     lineNumber = '4215'
    JS ERROR: !!!     stack = '"()@/home/taras/.local/share/gnome-shell/extensions/panel-docklet@quina.at/extension.js:4215
"'
Попередження віконного менеджера:Log level 16: STACK_OP_RAISE_ABOVE: sibling window 0xc0012b not in stack
      JS LOG: SM: No battery found
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.
Попередження віконного менеджера:Log level 8: meta_window_raise: assertion `!window->override_redirect' failed
Попередження віконного менеджера:Log level 8: meta_window_focus: assertion `!window->override_redirect' failed
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.
    JS ERROR: !!!   Exception was: TypeError: this._myWindowClass.listAllWindows is not a function
    JS ERROR: !!!     message = '"this._myWindowClass.listAllWindows is not a function"'
    JS ERROR: !!!     fileName = '"/home/taras/.local/share/gnome-shell/extensions/panel-docklet@quina.at/extension.js"'
    JS ERROR: !!!     lineNumber = '4215'
    JS ERROR: !!!     stack = '"()@/home/taras/.local/share/gnome-shell/extensions/panel-docklet@quina.at/extension.js:4215
"'
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Попередження віконного менеджера:CurrentTime used to choose focus window; focus window may not be correct.
Попередження віконного менеджера:Got a request to focus 0x2400006 (Стіль) with a timestamp of 0.  This shouldn't happen!

(firefox:4997): Gtk-CRITICAL **: IA__gtk_clipboard_get_for_display: assertion `!display->closed' failed

(firefox:4997): Gtk-CRITICAL **: IA__gtk_clipboard_get_for_display: assertion `!display->closed' failed
[1391539636,000,xklavier.c:xkl_engine_start_listen/]    The backend does not require manual layout management - but it is provided by the application
[1391539639,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
[1391539639,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
[1391539639,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
[1391539639,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
[1391539639,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
[1391539639,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
[1391543317,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 1 is not ready
[1391543317,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 1 is not ready
[1391543578,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
[1391543578,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
[1391545343,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 1 is not ready
[1391545343,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 1 is not ready
[1391546077,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]    Page for group 0 is not ready
=== Applying Configuration Configuration ===
  Clone: false
  Output: Ноутбук attached to LVDS1
     status: on
     width: 1366
     height: 768
     rate: 60
     primary: true
     position: 0 0
  Output: (null) attached to VGA1
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1
  Output: (null) attached to HDMI1
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1
  Output: (null) attached to DP1
     status: off
     width: -1
     height: -1
     rate: -1
     primary: false
     position: -1 -1
      JS LOG: SM: No battery found

(process:8289): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Попередження віконного менеджера:Log level 8: meta_window_actor_mapped: assertion `!priv->mapped' failed
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Попередження віконного менеджера:CurrentTime used to choose focus window; focus window may not be correct.
Попередження віконного менеджера:Got a request to focus 0x2400006 (Стіль) with a timestamp of 0.  This shouldn't happen!
      JS LOG: SM: Power proxy error: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SettingsDaemon was not provided by any .service files
Clipboard is null, recovering ...

(gnome-shell:4390): GLib-GIO-WARNING **: Dropping signal ActiveSessionChanged of type (s) since the type from the expected interface is (o)
firefox: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Terminated
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
gnome-shell-calendar-server[4475]: Lost (or failed to acquire) the name org.gnome.Shell.CalendarServer - exiting
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
TarasMK
Level 1
Level 1
 
Posts: 19
Joined: Fri Nov 12, 2010 3:40 pm

Re: Certain Applications crash Gnome Shell after installing

Postby Monsta on Wed Apr 02, 2014 2:27 am

TarasMK wrote:
Code: Select all
    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/home/taras/.local/share/gnome-shell/extensions/weather-extension@xeked.com/extension.js' line 597 exception 0 number 157
    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/home/taras/.local/share/gnome-shell/extensions/weather-extension@xeked.com/extension.js' line 1012 exception 0 number 157
Code: Select all
    JS ERROR: !!!   Exception was: TypeError: this._myWindowClass.listAllWindows is not a function
    JS ERROR: !!!     message = '"this._myWindowClass.listAllWindows is not a function"'
    JS ERROR: !!!     fileName = '"/home/taras/.local/share/gnome-shell/extensions/panel-docklet@quina.at/extension.js"'
    JS ERROR: !!!     lineNumber = '4215'
    JS ERROR: !!!     stack = '"()@/home/taras/.local/share/gnome-shell/extensions/panel-docklet@quina.at/extension.js:4215

See? It's obvious. One extension (weather-extension) shows a warning and another (panel-docklet) throws an exception. Panel-docklet is probably incompatible with Gnome Shell 3.8 and should be removed. If it doesn't help, get rid of weather-extension too.
Monsta
Level 9
Level 9
 
Posts: 2514
Joined: Fri Aug 19, 2011 3:46 am

Re: Certain Applications crash Gnome Shell after installing

Postby TarasMK on Wed Apr 02, 2014 12:21 pm

Monsta wrote:See? It's obvious. One extension (weather-extension) shows a warning and another (panel-docklet) throws an exception. Panel-docklet is probably incompatible with Gnome Shell 3.8 and should be removed. If it doesn't help, get rid of weather-extension too.


I think those were messages from earlier sessions. Because I removed all extensions completely and it didn't help.

But at last I have it working now. It was suggested to try different themes. Yes, I tried to change gtk+ and window themes to default earlier, but without any success. And today I tried to change icon theme. And it works! So for now I can say that Mint-X icons do not work for me with gnome shell. Never thought it can cause such crashes....
TarasMK
Level 1
Level 1
 
Posts: 19
Joined: Fri Nov 12, 2010 3:40 pm

Re: Certain Applications crash Gnome Shell after installing

Postby jack.herbert on Mon Jun 23, 2014 5:20 am

I had exactly the same problem on a fresh LMDE install, just adding nvidia-driver and gnome.
Gnome-shell would crash when starting gedit, glxgears, goggles, some parts of tweak tool and when going full screen on videos in firefox (but not in chromium)

Changing the icon theme away from Mint-X resolved everything immediately.

After two days of messing around with my graphic drivers and having to reinstall the whole system a few times, it's hard to believe how simple the solution was.
Thanks a million for posting this TarasMK!
The light at the end of the tunnel is just the light of an oncoming train.
Robert Lowell
User avatar
jack.herbert
Level 1
Level 1
 
Posts: 40
Joined: Sun Jun 28, 2009 5:25 pm

Re: Certain Applications crash Gnome Shell after installing

Postby Gazbook on Fri Aug 29, 2014 8:07 am

Changing the icon theme away from Mint-X resolved everything immediately.


I hunted down my login details for the forum just to say, after moving to Mint for the first time in years (and trying out Debian Edition for the first time), this solved everything for me. Thank you!!! :D
Gazbook
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 13, 2011 6:18 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 0 guests