Team Fortress 2 on XCFE working very badly

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read this

Team Fortress 2 on XCFE working very badly

Postby Molerskatraka123 on Wed Jan 15, 2014 7:30 am

When I start Team Fortress 2 (game) on Steam (gaming platform) with Linux Mint 16 Petra (XCFE edition) it is very glitchy in the menu by showing parts of the loading screen. And when I go to a server it is even worse: alot of effects don't show propertly or don't show at all, there are anomalies containing random letters, numbers and colors everywhere and randomly cuting of parts of the HUD and the floors are flashing white color. Any help with this? My laptop is MS-1722 (that is not the actual marketing name) and it is very old, but it dual-boots Windows 7 and Mint well, and Team Fortress 2 runs well on Windows 7. As the title says I think the problem is in XCFE as the developers of the game say that they recommend and will give support only to users of Ubuntu 12.04 LTC Unity, so I got Unity from packet menager but I don't know how to start it.
Molerskatraka123
Level 1
Level 1
 
Posts: 1
Joined: Wed Jan 15, 2014 7:08 am

Linux Mint is funded by ads and donations.
 

Re: Team Fortress 2 on XCFE working very badly

Postby Previous1 on Thu Jan 16, 2014 2:29 am

Unity would probably make it worse. Do you have the AMD proprietary drivers installed? (fglrx) Open a terminal, enter and copy the output

Code: Select all
inxi -Gx
Image
Tutorials | cynicaltux
Arch Linux i3wm, 64bit
User avatar
Previous1
Level 4
Level 4
 
Posts: 367
Joined: Sun Dec 01, 2013 11:48 am


Return to Gaming on Linux Mint

Who is online

Users browsing this forum: No registered users and 1 guest