Mint 16 KDE and Skyrim

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read this

Mint 16 KDE and Skyrim

Postby FB9 on Mon Jan 20, 2014 12:53 pm

I've the Steam version of Skyrim mostly running fine on Mint 16 with KDE. I'm using the default kernel and the nVidia 319.32 driver.

I'm running it through PlayOnLinux with Wine 1.7.8. I've tried higher versions. My one issue is that sometimes the mouse stops so I can not turn completely.

I know what's up, the mouse is ceasing to be "grabbed" sometimes in game. Opening the console briefly fixes it when this occurs. Yes, I'm playing it fullscreen. I've set everything I should to stop this from occuring. Yep, Wine is configured as it should be.

I've tried mouse warp override default, enabled, and forced. Normally, forced fixes the problem. The only way I've found to cure it currently is to edit the fMouseHeadingSensitivity setting in SkyrimPrefs.ini's to a high value like 1.0000. That makes the game unplayable because it's far too fast. I've tried mouse acceleration off and on; didn't make a difference. I've tried disabling desktop effects before gaming; didn't make a difference. Would I be better off with a different DE than KDE?

So in summary, sometimes my mouse is leaving the game and returning to my desktop even in fullscreen mode. All the old fixes and settings that should cure it do not. I'm wondering if there isn't some obscure setting in KDE I'm missing that could prevent this.

I love Mint 16 with KDE. This is the only thing that's currently annoying me.
FB9
Level 1
Level 1
 
Posts: 2
Joined: Mon Jan 20, 2014 12:39 pm

Linux Mint is funded by ads and donations.
 

Re: Mint 16 KDE and Skyrim

Postby FB9 on Wed Jan 22, 2014 12:49 am

The mouse stays captured or grabbed and turning is fine in Skyrim on Ubuntu 13.10. Same hardware, same nVidia driver. I installed and set it up the same way too. I'm suspecting some setting in KDE was causing the mouse to drift off to the desktop at times. Another thing, using CPU freq helps the game feel much smoother. I select performance before I start the game. If you want to install that app, sudo apt-get install indicator-cpufreq

Setting my CPU to performance with that app before playing makes cities with Ultra settings feel much smoother and the game in general. It's not as smooth as on Win 7 but it's completely playable and solid. There is certainly not a night and day difference between the two; it's fairly insignificant.
FB9
Level 1
Level 1
 
Posts: 2
Joined: Mon Jan 20, 2014 12:39 pm

Re: Mint 16 KDE and Skyrim

Postby Booman on Tue Feb 11, 2014 4:01 pm

Yes I have seen this too with may games in full screen. If the resolution of the game is set lower than the Linux desktop resolution, then it will appear fullscreen, but is actually still in a window and the mouse can roll outside the game area.
So annoying!

But I have an idea.
I found with Wine you can set a "virtual desktop" and sets the resolution for whatever you want. I normally use 1024x768
Then when you set the resolution in-game, just match the resolution of your Linux desktop.
Skyrim will appear full-screen and the mouse will stay in the "virtual desktop" area
There is also a setting for "automatically capture mouse in full-screen windows" too. check that one as well.
But make sure to turn off the "mouse override" in PlayOnLinux. They will conflict.

I use virtual desktop for all of my games.
Sometimes the game is slow in high resolutions, so I will lower my Linux desktop resolution to 1440x900 then in game do the same.
This way it always appears as fullscreen.
Booman
Mint 17 64-bit
Wine 1.7.18
PlayOnLinux 4.2.2
PlayOnLinux GuidesTested Games List
Booman
Level 3
Level 3
 
Posts: 186
Joined: Fri Feb 22, 2013 1:54 pm


Return to Gaming on Linux Mint

Who is online

Users browsing this forum: No registered users and 2 guests