[SOLVED] synaptic not working (again)

Questions about applications and software
Forum rules
Before you post please read how to get help

[SOLVED] synaptic not working (again)

Postby AbeFreeman on Wed Aug 31, 2011 10:05 pm

In mint 9, I was getting this "WARNING you are about to install software that can't be authenticated! Doing this could allow a malicious individual to damage or take control of your system." with every package I tried to install using synaptic. Thankfully, vincent told me that the problem was a line:
APT::Get::AllowUnauthenticated 1;
in the /etc/apt/apt.conf file, and he told me how to fix it. Now, using mint 10, I'm getting this same error message with every package I try to install. BUT there isn't any /etc/apt/apt.conf file in mint 10. So what do I do???? Incidentally, at first synaptic worked properly in mint 10, but now it doesn't. I have no idea what happened to change this.

(the problem I had in mint 9 was solved in this forum)
viewtopic.php?f=33&t=55462


Thanks to anyone who has a solution.
Last edited by AbeFreeman on Tue Sep 06, 2011 2:47 am, edited 1 time in total.
User avatar
AbeFreeman
Level 3
Level 3
 
Posts: 146
Joined: Wed Aug 04, 2010 12:36 am

Linux Mint is funded by ads and donations.
 

Re: synaptic not working (again)

Postby xenopeek on Thu Sep 01, 2011 4:37 am

So as not to start confusions, I'm a different Vincent :D

Did you clean install Linux Mint 10, or did you upgrade from 9 to 10? I would suggest you do a clean install if you didn't already do this, as this error is not normal.

If you did do a clean install, did you add PPAs or edit the sources.list? What repositories have you added?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15433
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: synaptic not working (again)

Postby AbeFreeman on Thu Sep 01, 2011 9:53 am

Clean install, but then I restored data, settings, etc. from old computer (using mint backup tool). I didn't have this problem at that time. I did add a PPA, (details at this post:)
viewtopic.php?f=46&t=72841

and it messed everything up. But after I got things running again, I did a ppa-purge. Also dist-upgrade. I'm certain, though, that I installed some programs since then, and didn't have this error message come up. I did install 2 programs from .deb files: the latest versions of skype (to see if sound problems were fixed), and the latest Anki (again, to fix some problems in the repository version).

If mint 10 has the equivalent of the APT::Get::AllowUnauthenticated (must be set to 0 or everything is treated as unauthenticated) variable, I'm guessing that it somehow got set to 1 and I need to reset it, but where to find it???
User avatar
AbeFreeman
Level 3
Level 3
 
Posts: 146
Joined: Wed Aug 04, 2010 12:36 am

Re: synaptic not working (again)

Postby DrHu on Thu Sep 01, 2011 11:27 am

https://help.ubuntu.com/community/Autom ... ityUpdates
--looks like you might need a different place for the rules file
    /etc/apt/apt.conf.d
This is for Ubuntu 10, but even if Mint 10x didn't provide an apt.conf file, you could create one, and it is likely to be accepted as apt's configuration file or to make sure search your hard drive for that file name
Code: Select all
locate apt.conf
locate apt.c

--and if it is there, you will find it
http://manpages.ubuntu.com/manpages/luc ... onf.5.html
http://en.wikipedia.org/wiki/Advanced_Packaging_Tool
User avatar
DrHu
Level 17
Level 17
 
Posts: 7087
Joined: Wed Jun 17, 2009 8:20 pm

Re: synaptic not working (again)

Postby AbeFreeman on Tue Sep 06, 2011 2:47 am

Waded through those links and figured out that there is no longer an apt.conf file, but an apt.conf.d folder that contains fragments. Just added the APT::Get::AllowUnauthenticated 0; line to one of the files in that folder, and now synaptic seems to be working fine. Don't know what messed it up in the first place, since it's been fine the whole time (close to a year?) that I've been using Mint10. Thanks for the help.
User avatar
AbeFreeman
Level 3
Level 3
 
Posts: 146
Joined: Wed Aug 04, 2010 12:36 am


Return to Software & Applications

Who is online

Users browsing this forum: Bing [Bot] and 10 guests