Error every time using MintUpdate

Questions about applications and software
Forum rules
Before you post please read this

Error every time using MintUpdate

Postby windyweather on Sat Feb 18, 2012 12:30 am

Mint 12 x64, running in VirtualBox on W7 system.
mintUpdate gives this every time.
Code: Select all
W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 584BD6410AAFAD78

Nothing looks amiss in my software sources. I am using cinnamon which is working fine.

Is this a known error, or do I have a bogus source?

- ww
Image
User avatar
windyweather
Level 2
Level 2
 
Posts: 55
Joined: Wed Nov 09, 2011 8:34 pm
Location: Coos Bay, OR

Linux Mint is funded by ads and donations.
 

Re: Error every time using MintUpdate

Postby remoulder on Sat Feb 18, 2012 8:40 am

Repositories on Launchpad are un-official in that almost anyone can create one, and are therefore untrusted. You need to add the gpg signng key from that repos home page if you trust it and don't want to see the error.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Here is a solution....

Postby windyweather on Sun Feb 19, 2012 2:05 pm

It would help to have a pointer to some sort of instructions about how to do this. Here's what I finally did that worked:
Code: Select all
darrell@a90-vmmint12 ~ $ sudo add-apt-key 584BD6410AAFAD78
gpg: directory `/home/darrell/.gnupg' created
gpg: new configuration file `/home/darrell/.gnupg/gpg.conf' created
gpg: WARNING: options in `/home/darrell/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/home/darrell/.gnupg/secring.gpg' created
gpg: keyring `/home/darrell/.gnupg/pubring.gpg' created
gpg: requesting key 0AAFAD78 from hkp server subkeys.pgp.net
gpg: /home/darrell/.gnupg/trustdb.gpg: trustdb created
gpg: key 0AAFAD78: public key "Launchpad merlwiz79" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
darrell@a90-vmmint12 ~ $

So, when you get the error, the easiest way to solve the problem is to Copy the key from the error box window and enter the command:
Code: Select all
sudo add-apt-key <paste key here>

One problem is that the entire URL of the source is not repored in the error box. The error says ppa.launchpad.net but the entire URL is actually http://ppa.launchpad.net/merlwiz79/cinnamon-ppa/ubuntu. I know this because this is the only enabled source that contains launchpad.

So BUG: report the entire URL in this error so you can tell which URL the reported key refers to.

- ww
Image
User avatar
windyweather
Level 2
Level 2
 
Posts: 55
Joined: Wed Nov 09, 2011 8:34 pm
Location: Coos Bay, OR

Re: Error every time using MintUpdate

Postby urdumania.com on Mon Feb 27, 2012 9:21 am

A new version of Linux Mint is released every 6 months. It usually comes with new features and improvements but there's nothing wrong with sticking with the release you already have. In fact, you could skip many releases and stick with the version that works for you.
urdumania.com
Level 1
Level 1
 
Posts: 1
Joined: Mon Feb 27, 2012 9:20 am


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 23 guests