No keyboard after supend

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

No keyboard after supend

Postby blacknail on Fri Nov 05, 2010 3:39 pm

Hi all,

I'm using MInt 9 64 bits and, as I have configured, after 10 minutes or so of the laptop being idle it automatically suspends the operating system. When I press one key it comes back but the screen is locked, and then I can't seem to use the keyboard to login again... so I have to make a hard reboot, which of course is not nice at all... I searched the forums and found some possible solutions to have the keyboard back, like pressing CTRL + ALT + TAB or ALT + PRT SC + REISUB but it doesn't seem to work, anyone had the same problem and got it solved? I don't know if it has to do with the fact of the operating system being the 64 nbit version, but since you'll never know, I thought it was better to post the issue in this section.

By the way, my laptop is a Vaio VGN-CS11Z. If someone could help it would be much appreciated! I'm tired of doing hard reboots, if I can't found a solution I'll disable suspendig I guess.

Thanks in advance,
João Fernandes
blacknail
Level 1
Level 1
 
Posts: 37
Joined: Mon Jun 09, 2008 11:00 am

Linux Mint is funded by ads and donations.
 

Re: No keyboard after supend

Postby dawgdoc on Fri Nov 05, 2010 9:44 pm

Before disabling suspend, go to > Menu > Preferences > Screensaver and deselect Lock screen when screensaver is active. This has worked for a number of people.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2724
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: No keyboard after supend

Postby blacknail on Sat Nov 06, 2010 9:57 am

Thanks dawgdoc, I'll try that!

Then I'll post here to say if it worked out or not :]
blacknail
Level 1
Level 1
 
Posts: 37
Joined: Mon Jun 09, 2008 11:00 am

Re: No keyboard after supend

Postby blacknail on Sat Nov 06, 2010 8:01 pm

Ok, my problem is a bit different from what I thought. Indeed I deselected "Lock screen when screensaver is active" & disabled suspending and now it doesn't lock the screen but the keyboard problem remains, with the only difference being the fact of being able to make a manual reboot with the mouse... in simple plain words, I think the problem comes from the option "put computer to sleep when inactive" (which has always been enabled). Do you know any solutions regarding that, dawgdoc? Meanwhile I'll resume my search...

Thanks again,
João
blacknail
Level 1
Level 1
 
Posts: 37
Joined: Mon Jun 09, 2008 11:00 am

Re: No keyboard after supend

Postby dawgdoc on Sun Nov 07, 2010 11:05 pm

Did you create a swap partition?
Is it at least as large as the amount of ram you have?
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2724
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps


Return to Newbie Questions

Who is online

Users browsing this forum: dXTC, RobertoAl and 37 guests