Howto: setting up Beryl on Linux Mint

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Postby vamsee on Sun Feb 25, 2007 4:48 am

maximus659 wrote:
I had the same exact problem on my setup using NVIDIA 7600 card. Here is how I fixed it:

append the following to your /etc/X11/xorg.conf in the “Deviceâ€￾ section:

Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "backingstore" "True"
Option "TripleBuffer" "True"

It worked perfectly for me. Hope that helps


Hi maximus659,

Thanks for posting this tip. Your tip helped along with some other things (like removing flgrx that I installed based on some other instructions). I summarized what worked for me in the following post.

http://ubuntuforums.org/showthread.php? ... ost2208819
vamsee
Level 1
Level 1
 
Posts: 4
Joined: Sun Feb 25, 2007 3:46 am

Linux Mint is funded by ads and donations.
 

Re: Beryl not installing on Bianca

Postby mfab on Sun Feb 25, 2007 1:16 pm

lvshankar wrote:I tried everything as posted by Alephcat. The only change I made was to try sudo wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add - instead of what was given initially, because I got a general error.
But after restart :
$ sudo aptitude install beryl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Building tag database... Done
Couldn't find any package whose name or description matched "beryl"
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.

why?????? :shock:

~LVS


it seems there is no package "beryl" available, you should install "beryl-manager" and all its recommended packages ! or use "aptitude install beryl-manager" which will install the recommendations automatically.

anyone some infos on my upper post concerning the modules (vbe or dbe)?

greets mfab
mfab
Level 1
Level 1
 
Posts: 22
Joined: Mon Feb 12, 2007 4:50 pm

Postby maximus659 on Sun Feb 25, 2007 2:18 pm

vamsee wrote:
maximus659 wrote:
I had the same exact problem on my setup using NVIDIA 7600 card. Here is how I fixed it:

append the following to your /etc/X11/xorg.conf in the “Deviceâ€￾ section:

Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "backingstore" "True"
Option "TripleBuffer" "True"

It worked perfectly for me. Hope that helps


Hi maximus659,

Thanks for posting this tip. Your tip helped along with some other things (like removing flgrx that I installed based on some other instructions). I summarized what worked for me in the following post.

http://ubuntuforums.org/showthread.php? ... ost2208819



I did not know that you're using an ATI 7500 card. You might want to try using the following setup:

http://forum.beryl-project.org/viewtopi ... 0&start=20

Look at the post from Nile. Good luck
maximus659
Level 1
Level 1
 
Posts: 8
Joined: Mon Feb 05, 2007 4:52 pm

Postby lvshankar on Mon Feb 26, 2007 11:28 am

@mstab

I tried installing beryl again and it showed up. Cool.

But I don't get any 3D effects yet...yes beryl-manager is running, have done the settings in it. The only feature I seem to have gotten is an Alt+Tab style switching betweeon workspaces. :(

Also, any themes won't apply..selecting them has no effect!

thanks in advance..


~LVS

My box:
Asus A8V-MX mobo, 512 MB RAM, AMD Athlon 3000+ 64-bit processor
User avatar
lvshankar
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 01, 2007 5:24 am
Location: Chennai, India

No title bars in Beryl

Postby GoldNugget on Mon Mar 05, 2007 11:35 pm

I had a similar problem as the one described above. After scouring the forums and trying several things, I found this entry and it did the trick:
http://ubuntuforums.org/showthread.php?t=369703 (bottom of the page):

"I had the exact same problems.
a) There were no maximize and minimize buttons/titlebars.
b) Clicking on a new theme in Emerald Manager did nothing.
I asked on the forums and someone posted this response and it WORKED!!!

Quote:
If you have a nvidia card and if you are using the non-opensource drivers, run this command.
Code:

Code:

sudo nvidia-xconfig --add-argb-glx-visuals

Then hit <CTRL><ALT><Backspace> and log back in again. That should fix your problem.
Hope this fixes your problem. If not, there are some other suggestions in the thread: http://ubuntuforums.org/showthread.php?t=367850 "
GoldNugget
Level 1
Level 1
 
Posts: 14
Joined: Mon Jan 01, 2007 6:51 pm

Postby Zone on Wed Mar 07, 2007 2:54 am

Hello,
I followed all the instructions, and tips. It installed perfectly, and everything went as explained. :)
I have the 3d option selected in the Beryl Manager.
Now I do have the wobbly window affects, work-space flipping and many others, but I don't have the cube effect, is there something else I need to do or install?

UPDATE: It was working all along, I wasn't doing the command for it correctly. :) This works perfectly, and beautifuly!!!
User avatar
Zone
Level 2
Level 2
 
Posts: 76
Joined: Tue Feb 13, 2007 1:10 pm
Location: Wisconsin, USA

Howto: setting up Beryl on Linux Mint

Postby cedenburn on Mon Mar 12, 2007 7:59 pm

Went thru all of the suggestions and this what I get when I start Beryl-Manager

garbage.

but I can ctrl+alt+backspace and recover

Laptop = Presario R3210
Video = Nvidia = GForce4 420 Go 32meg
Driver = 1.0.8776
User avatar
cedenburn
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 22, 2006 9:42 pm

Postby carlos on Mon Mar 12, 2007 10:29 pm

Hey cedenburn I have a geforce 440 GO on my laptop this is a quote from another post of what I did, try it and hopefully it can help:

carlos wrote:Well it looks it didn't work for me. I have Bianca installed on a dell inspirion laptop that has a nvidia "geforce4 440 GO" video card. It requires the legacy driver.

I used Alberto Milone's guide to manually install the driver. Just make sure to go to "point 7 of the PROBLEMS SECTION" and follow the additional instructions there.

http://www.albertomilone.com/latest_nvidia_udsf_edgy.html

Also I installed beryl but had to make sure that options were specified before beryl was even started. Goto the beryl icon right click and on the menu under advanced > beryl options > Rendering Platform > Force nvidia. Otherwise the screen was completely garbled.

So far it been running well, but it is a tad slower when compared to my desktop. I think with a bit of tweaking I can solve this problem.
____________ ________ ______ ____ ___ __ __ _
http://www.designdrifter.com
The Purpose of Life is for DNA to reproduce.
User avatar
carlos
Level 5
Level 5
 
Posts: 526
Joined: Thu Dec 14, 2006 4:30 pm
Location: USA

Beryl AIGLX and ATI Script

Postby lavs23 on Tue Mar 13, 2007 12:07 pm

I've used this script to get my Radeon 9600 Pro work with Beryl and AIGLX. The only problem is to run games like Counter Strike or any full screen game I have to switch to metacity, this might be a issue that hasn't been fixed though. Other then that it works great.

http://koti.mbnet.fi/waappu/edgy_ati_aiglx_beryl.html
lavs23
Level 1
Level 1
 
Posts: 30
Joined: Tue Mar 13, 2007 12:00 pm

Postby Alephcat on Thu Mar 15, 2007 5:01 am

the issue with games (and anything that trys to display full screen) is an issue with Beryl, not sure if/when it is going to be fixed but at least they allow you to switch back to a non-3D one easily now.
"To absent friends, lost loves, old gods, and the season of mists; and may each and every one of us always give the devil his due."
User avatar
Alephcat
Level 3
Level 3
 
Posts: 132
Joined: Wed Dec 06, 2006 6:13 am
Location: Chester

Reply to Nighto

Postby and on Thu Mar 22, 2007 3:19 pm

Your concern after Beryl install :no menu bar: The default settings after install indeed give this result. Try setting (Force Nvidia) or (AIGLX) and use (Copy).This fixes also the :Blank screen) Don<t be afraid to experiment. Also use the Ubuntu Wiki-Beryl install (Edgy). Ive had very successful experience with beryl.
and
Level 1
Level 1
 
Posts: 1
Joined: Wed Mar 21, 2007 6:28 pm

Re: Reply to Nighto

Postby grimdestripador on Fri Mar 23, 2007 12:12 am

If you are afraid, use http://www.getautomatix.com follow the normal repo instructions for apt. then
Code: Select all
sudo apt-get install automatix2bleeder
User avatar
grimdestripador
Level 6
Level 6
 
Posts: 1069
Joined: Fri Feb 16, 2007 2:26 am

Beryl configures but won't run

Postby rmdir_r_windows on Fri Apr 06, 2007 2:13 am

Greetings forum. New newbie here. Tried various distros (Suse, Fedora, Dream, eLive, Mandriva, Knoppix, Ubuntu, and SAM). Mint by far has been the most well rounded and working solutions for me.

I followed the forum instructions. Beryl installs with no errors but when I run Beryl Manager my X session jumps out for about 3 or 4 secs (restarting) and then I'm back at my login screen. After logging in, Beryl is not running.

I piped the output of the beryl-manager command and this is what I got:

**************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed
Checking for non power of two texture support : passed
Checking maximum texture size : passed (2048x2048)

Reloading options

----

Any ideas? I'm running a desktop pc with the Verto Nvidia FX5200 card.

Thanks!

~T
"root@root:# rmdir -r windows && run Mint Linux"
Linux Lovers of the World...Unite!
rmdir_r_windows
Level 1
Level 1
 
Posts: 1
Joined: Fri Apr 06, 2007 2:03 am

Postby Dabbill on Mon Apr 09, 2007 10:45 pm

I followed your how to. It seems to go fine with no errors, but when i type beryl-manager the windows i currently have open go white, and computer locks up. Only thing i can do is unplug my comp or hit the reset button. I have GeFroce 8800GTX. Any ideas?

Thanks
Dabbill
Level 1
Level 1
 
Posts: 14
Joined: Mon Apr 09, 2007 10:42 pm

Postby Zone on Tue Apr 10, 2007 12:41 am

Hello,
I had the install go perfect, I have it starting after log-in is done.

I did use this and have had no issues with it. He listed it in the "how to"
(only add the next one if you want unsupported experimental packages)
Code: Select all
deb http://3v1n0.tuxfamily.org edgy beryl-svn


I don't know if you have seen the additions on page two, that solved the problems for me.

I fixed this by adding the following two lines to the "Screen" section of /etc/X11/xorg.conf:

Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"


append the following to your /etc/X11/xorg.conf in the “Deviceâ€￾ section:

Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "backingstore" "True"
Option "TripleBuffer" "True"


I hope this helps, good luck :)
User avatar
Zone
Level 2
Level 2
 
Posts: 76
Joined: Tue Feb 13, 2007 1:10 pm
Location: Wisconsin, USA

Postby Sanchopinky on Sat May 26, 2007 11:00 pm

When I go to "Select Window Manager" the screen just flickers a few times and then goes back to Metacity. Can anyone help me?

:?:
Sanchopinky
Level 1
Level 1
 
Posts: 22
Joined: Sat May 26, 2007 10:08 pm

Can't get beryl to work

Postby akilan on Sat Sep 22, 2007 8:52 pm

Hello all.

my system. dell vostro 1500 1gb ram/ nvidia 8400m gs /T5470, 1.60untu

i have a dual boot with mint cassandra and vista basic.

i used envy for the nvidia driver - i had to do it twice to get it to work (second time manual option) and i have got wireless working. i also did whatever updates that the system recommended (that was perhaps a mistake)

i am trying to get beryl working.
first i went to this thread: http://www.linuxmint.com/wiki/index.php/Setting_up_Beryl_on_Linux_Mint

the problems i have are :

there is no Administration > Software Sources in my mintmenu.
i went into the synaptic and tried to add the repositories in there.
i got the following error:


W: GPG error: http://ubuntu.beryl-project.org edgy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3FF0DB166A7476EA


i thought perhaps these are instructions for older versions ( the paragraph at the top of the wiki seemed to imply that). so i just went to mint menu and opened beryl settings manager. there are a lot of options that i don't understand. but it opens and i can select things, so i assume it works.

when i actually select the beryl manager ( the red jewel) the icon appears in the panel at the bottom of the screen and then the computer freezes - i can move the mouse around but that is it. i can't open any programs, i can't seem to do anything with beryl - no screens moving around , no cuve, etc. nothing.
the only thing to get out of it is to hold the power down to do a hard shutdown.

any ideas?

thank you in advance for any help.

- akilan[/url]
akilan
Level 1
Level 1
 
Posts: 4
Joined: Sat Sep 22, 2007 3:02 pm

Postby Husse on Sun Sep 23, 2007 2:48 pm

I know I should not recommend you to do something that risks a total freeze, but if you start beryl again as you did when it froze - see if you can restart x with ctrl+alt+backspace
If so I'm pretty sure you don't have the right driver....
Then install the latest envy follow the instructions in
http://www.linuxmint.com/planet/Alberto ... _available
and install the driver again (automatically I think)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

one step closer

Postby akilan on Mon Oct 01, 2007 8:22 pm

what i have done is wipe that partition and installed 3.1 celena. i upgraded envy and installed (auto) nvidia drivers - works!

i can also start beryl but nothing happens. the red jewel icon is present in the panel at the bottom of the screen. i can open programs and work as normal - just nothing happening with beryl.

i read on the wiki - http://www.linuxmint.com/wiki/index.php ... Linux_Mint




A solution for nVidia cards when beryl falsely believes the card is in 32 bit mode.

I got an error stating that my video card was in 32 bit mode (which beryl doesn't support) even though it was actually in 24 bit mode. I fixed this by adding the following two lines to the "Screen" section of /etc/X11/xorg.conf:

Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
















my card is a 8400m gs on a dell vostro notebook. when i look under the control panel on my windows settings - my card does in fact have 32bit color. i don't have a 24 bit option. so it seems that unlike the wiki - my card is really 32 bit, not just the driver thinking it is.

in mint - the only other option i have is 8 bit.

i am afraid to add these lines to the program and screw up my stable system.

any thoughts, anyone?
akilan
Level 1
Level 1
 
Posts: 4
Joined: Sat Sep 22, 2007 3:02 pm

Postby Oryzae on Sun Nov 18, 2007 6:46 am

Hi all!

I must say that Linux Mint is fantastic; excellent user experience. =]

I've been following the wiki, but there are some questions that I want to ask:

When I try to edit xorg.conf, I don't see a "Section "Module"" =/ I'm using the EEE PC, and I'm having no trouble at all with using Daryna on it. Except, I'd like to see if Beryl can make the already amazing GUI even better. Here's my xorg.conf

http://rafb.net/p/LBZEvf22.html

Last time I added modules, and everything else, and X died. I did install Beryl Manager but when I type "Beryl-Manager" it said command not found :(

Any help is appreciated :D
Oryzae
Level 1
Level 1
 
Posts: 4
Joined: Sun Nov 18, 2007 6:35 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 12 guests