Solution to mounting internal floppy drive Linux Mint Nadia:

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Solution to mounting internal floppy drive Linux Mint Nadia:

Postby Zorba on Fri Nov 23, 2012 2:45 pm

If I receive this error msg in Linux Mint 14, codename (Nadia) ''Error mounting system-managed device /dev/fd0: Command-line `mount "/media/floppy0"' exited with non-zero exit status 32: mount: /dev/fd0 is not a valid block device'' it means that the floppy driver is loaded as a module. You can blacklist this module so it doesn't get loaded:

Code: Select all
echo "blacklist floppy" | sudo tee /etc/modprobe.d/blacklist-floppy.conf
sudo rmmod floppy
sudo update-initramfs -u


That's it man!!!
Last edited by Zorba on Tue Mar 12, 2013 9:56 pm, edited 1 time in total.
Image
User avatar
Zorba
Level 8
Level 8
 
Posts: 2309
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Linux Mint is funded by ads and donations.
 

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby simes549 on Sun Jan 20, 2013 9:56 pm

Thanks so much. Since I don't have a floppy drive, this was really driving me nuts with Nadia.
simes549
Level 1
Level 1
 
Posts: 6
Joined: Thu May 05, 2011 5:51 pm

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby jepsr on Thu Mar 07, 2013 5:49 am

Thanks Brahim...this solution worked for me too! Error message had been driving me crazy.
jepsr
Level 1
Level 1
 
Posts: 1
Joined: Thu May 31, 2007 9:42 am

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby Skara Brae on Sun Mar 24, 2013 5:26 pm

[bump], if I may.

My new PC - running "Nadia" since a few weeks - too shows the "Unable to mount floppy disk" after logging in. Following Brahim's tip, I however get the error that the "Module floppy does not exist in /proc/modules".

What now?
Codename "PUMA": Intel Core i5-3450 // Gigabyte GA-H77-D3H // 1 x 4 GB DDR3-RAM // Gigabyte Geforce GT 630 // WD Caviar Blue 500 GB (S-ATA) // Samsung WriteMaster DVD-rw // Aopen QF50C PC case
--
Registered Linux User #495429
Skara Brae
Level 1
Level 1
 
Posts: 48
Joined: Sat Jun 09, 2012 10:45 am

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby Orbmiser on Sun Mar 24, 2013 7:59 pm

Did you try and disable and turn off the floppy in Bios?
and then won't even be listed when devices are polled.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby Skara Brae on Mon Apr 08, 2013 3:45 pm

Another [bump].

The BIOS shows no "disabling" any floppy drive. It does show this external USB floppy drive/CF/SD drive that I have. That is probably not the cause of that error.

My fstab file has a reference to /dev/sde - a floppy drive (Gee, I can't remember such "technical" Linux stuff, I'll have to look into this fstab thing again). I bet (or maybe not) that's the cause.

----
Edit: Well, putting a # in front of the /dev/sde line in my fstab file didn't work; it gave me another error about the floppy drive.
Codename "PUMA": Intel Core i5-3450 // Gigabyte GA-H77-D3H // 1 x 4 GB DDR3-RAM // Gigabyte Geforce GT 630 // WD Caviar Blue 500 GB (S-ATA) // Samsung WriteMaster DVD-rw // Aopen QF50C PC case
--
Registered Linux User #495429
Skara Brae
Level 1
Level 1
 
Posts: 48
Joined: Sat Jun 09, 2012 10:45 am

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby oxman on Wed May 01, 2013 2:12 pm

I want to track this thread. I am unable to mount my floppy drive. I get the message also but do not know how to interpret it. My floppy is enabled in the bios. Any help is appreciated. Linuxmint 14 Mate
ox is grateful http://www.singingfalls.com linux user #199890
User avatar
oxman
Level 1
Level 1
 
Posts: 8
Joined: Fri Apr 26, 2013 10:38 am
Location: Oregon

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby Orbmiser on Wed May 01, 2013 2:48 pm

I am unable to mount my floppy drive


Is that with a formatted floppy inside the drive?
As believe it won't mount unless their is one in drive?

Not positive and just guessing here.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby DrHu on Wed May 01, 2013 3:50 pm

You can make a mount point if the floppy device is not available, from the /etc/fstab file
http://home.ubalt.edu/abento/linux/terminal/mount.html

Code: Select all
mount -t vfat /dev/fd0 /mnt/floppy

--typical mount command from a terminal

Expect most floppies (diskettes) to be FAT formatted, they usually came that way, unless you changed it to use a Linux file format, however FAT is more universal for that device/media
User avatar
DrHu
Level 16
Level 16
 
Posts: 6921
Joined: Wed Jun 17, 2009 8:20 pm

Re: Solution to mounting internal floppy drive Linux Mint Na

Postby i.r.id10t on Mon May 06, 2013 11:32 pm

DrHu wrote:You can make a mount point if the floppy device is not available, from the /etc/fstab file
http://home.ubalt.edu/abento/linux/terminal/mount.html

Code: Select all
mount -t vfat /dev/fd0 /mnt/floppy

--typical mount command from a terminal

Expect most floppies (diskettes) to be FAT formatted, they usually came that way, unless you changed it to use a Linux file format, however FAT is more universal for that device/media


If you use gkrellm or some other "click to mount" you can edit your /etc/fstab file

Code: Select all
/dev/fd0      /mnt/floppy      msdos      noauto,user      0      0     
     


Then for your script or command you don't need to run it with sticky bit or play with permissions
i.r.id10t
Level 1
Level 1
 
Posts: 11
Joined: Mon Jun 25, 2012 9:26 am

Linux Mint is funded by ads and donations.
 

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 7 guests