Get The Sound Working In Skype With Linux Mint 16 64bit

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Zorba on Sat Nov 30, 2013 10:27 pm

To fix the Skype no sound / distorted sound issue in Linux Mint 16, Get skype at http://www.skype.com/en/download-skype/skype-for-computer/ then install pulse audio plugins in 32bit:

Code: Select all
sudo apt-get install libasound2-plugins:i386


If this does not solve your problem proceed with this:


1- run the following command:

Code: Select all
sudo sed -i 's/^Exec=.*/Exec=env PULSE_LATENCY_MSEC=30 skype %U/' /usr/share/applications/skype.desktop



The command above replaces "skype" from the Skype desktop file with "env PULSE_LATENCY_MSEC=30 skype", this being a work-around for getting Skype to work with PulseAudio 4.0.


Image

2- Add skype icon to desktop (You can add icons to desktop by going to the menu, rightclick on skype then click on add to desktop ) , rightclick on it and go to "Properties" then replace
Code: Select all
skype U%


with
Code: Select all
env PULSE_LATENCY_MSEC=30 skype


in the command field.

So it looks like this: Image

Use the same command if you want to add skype to startup applications.

That's it guys :D
Last edited by Zorba on Tue Jan 21, 2014 10:52 pm, edited 2 times in total.
Image Image
User avatar
Zorba
Level 7
Level 7
 
Posts: 1990
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Linux Mint is funded by ads and donations.
 

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Geoff_P on Tue Dec 03, 2013 8:34 am

Does this apply to LM 16 Cinnamon 32 bit as well?
Thanks
Image
Geoff_P
Level 1
Level 1
 
Posts: 20
Joined: Wed Oct 10, 2012 4:42 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Zorba on Tue Dec 03, 2013 9:42 am

Geoff_P wrote:Does this apply to LM 16 Cinnamon 32 bit as well?
Thanks


This bug affects the 64bit only :D
Image Image
User avatar
Zorba
Level 7
Level 7
 
Posts: 1990
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Geoff_P on Tue Dec 03, 2013 2:42 pm

Thanks for the reply. I've got the same issue on 32bit version though.
Sound is either absent or very distorted.
It was fine on LM15.
Any ideas?
Image
Geoff_P
Level 1
Level 1
 
Posts: 20
Joined: Wed Oct 10, 2012 4:42 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby ImpliedConsent on Tue Dec 03, 2013 3:52 pm

Geoff_P wrote:Thanks for the reply. I've got the same issue on 32bit version though. Sound is either absent or very distorted. It was fine on LM15. Any ideas?

Ditto. Never had a 'incoming-ring' on LM14 32bit, but other sounds worked - now nothing on LM16 32bit.
User avatar
ImpliedConsent
Level 1
Level 1
 
Posts: 10
Joined: Tue Dec 18, 2012 11:04 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Zorba on Tue Dec 03, 2013 4:58 pm

ImpliedConsent wrote:
Geoff_P wrote:Thanks for the reply. I've got the same issue on 32bit version though. Sound is either absent or very distorted. It was fine on LM15. Any ideas?

Ditto. Never had a 'incoming-ring' on LM14 32bit, but other sounds worked - now nothing on LM16 32bit.


Did you both try the above solution?
Image Image
User avatar
Zorba
Level 7
Level 7
 
Posts: 1990
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Tioz on Wed Dec 04, 2013 12:27 am

Brahim wrote:
Geoff_P wrote:Does this apply to LM 16 Cinnamon 32 bit as well?
Thanks


This bug affects the 64bit only :D


First time LM user here. Using new V16 on a second machine. Nice alternative to Ubuntu :)
G'day all :) The above command worked fine for me on 32 bit system.

I love these open source forums...they actually work!
Tioz
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 04, 2013 12:18 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Geoff_P on Wed Dec 04, 2013 4:17 am

Brahim wrote:Did you both try the above solution?


Not yet, but I will today and report back later.
Image
Geoff_P
Level 1
Level 1
 
Posts: 20
Joined: Wed Oct 10, 2012 4:42 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Geoff_P on Wed Dec 04, 2013 6:26 am

Geoff_P wrote:
Brahim wrote:Did you both try the above solution?


Not yet, but I will today and report back later.


Update: Yes I've just tried it and it worked!

Thankyou very much for your help.
Image
Geoff_P
Level 1
Level 1
 
Posts: 20
Joined: Wed Oct 10, 2012 4:42 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Noozy on Sun Dec 08, 2013 2:54 pm

Brahim wrote:
ImpliedConsent wrote:
Geoff_P wrote:Thanks for the reply. I've got the same issue on 32bit version though. Sound is either absent or very distorted. It was fine on LM15. Any ideas?

Ditto. Never had a 'incoming-ring' on LM14 32bit, but other sounds worked - now nothing on LM16 32bit.


Did you both try the above solution?


Hi, I've had issues with Skype & LM16 on both 64 and 32 bit platforms.

x64 Details - Lenovo Z570 i7 with 8GB Ram and LM 16 Cinnamon. Instead of installing Skype from the repo I downloaded the multiarch deb from skype.com and it seems to fix the sound issue. This was only a couple of hours ago so I haven't really fully tested it in anger yet.

x32 Details - Lenove G550 with 4GB Ram and LM 16 Mate. I was having the same issue on this machine with Cinnamon so I decided to try Mate as I had no issues with LM15 Mate, but the same sound problems were there in LM16 Mate as there were with Cinnamon. I tried your solution and it seems to have worked. Once again no real comprehensive testing but now I have the Skype sign in "Whoosh" which I didn't have before and the test call seems to be working.
Noozy
Level 1
Level 1
 
Posts: 4
Joined: Sun May 29, 2011 5:41 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby djalf on Tue Dec 10, 2013 6:12 am

I can confirm that it is working on LM 16 x86.
djalf
Level 1
Level 1
 
Posts: 19
Joined: Thu Sep 19, 2013 9:08 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby ImpliedConsent on Sat Dec 14, 2013 5:37 pm

Brahim wrote:
ImpliedConsent wrote:Ditto. Never had a 'incoming-ring' on LM14 32bit, but other sounds worked - now nothing on LM16 32bit.


Did you both try the above solution?


I have no idea why I typed the above. I musta got some bad stuff, 'cuz the sound is working - and has worked (as far as I can remember) since I installed Petra32. Disregard.
User avatar
ImpliedConsent
Level 1
Level 1
 
Posts: 10
Joined: Tue Dec 18, 2012 11:04 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby GamesBond on Mon Dec 16, 2013 2:10 am

Regrettably, after trying the fix i have no sound at all in Skype under LM16 x64 :(

Skype also crashes very frequently
GamesBond
Level 1
Level 1
 
Posts: 2
Joined: Sun Dec 15, 2013 4:22 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Jodelman on Mon Dec 16, 2013 10:42 am

Brahim wrote:To fix the Skype no sound / distorted sound issue in Linux Mint 16, run the following command:


Many thanks. Your fix worked beautifully on my Mint 16 64 bit system. I was getting very frustrated at Skype not working properly.
Jodelman
Level 1
Level 1
 
Posts: 1
Joined: Fri Sep 09, 2011 12:15 pm

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Noozy on Tue Dec 17, 2013 11:47 am

Confirmed that the fix worked with 32bit LM16. Have tested it quite a lot now.

Also, seems to have fixed 64bit version as well, but I haven't tested it as much.
Noozy
Level 1
Level 1
 
Posts: 4
Joined: Sun May 29, 2011 5:41 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Zorba on Tue Jan 21, 2014 10:54 pm

Updated the above tutorial :D :D
Image Image
User avatar
Zorba
Level 7
Level 7
 
Posts: 1990
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby hexabit on Wed Feb 05, 2014 8:22 am

Installing the "libasound2-plugins:i386" fixed sound LAG on my Linux Mate 16 amd64

The lag was like 30 sec after some event occurs.

THX for the help.
User avatar
hexabit
Level 1
Level 1
 
Posts: 15
Joined: Thu Dec 06, 2012 12:13 pm

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby klu9 on Fri Feb 07, 2014 2:46 pm

I already installed Skype via the Software Manager (and currently have the problem of extremely low mic volume). Do I need to uninstall existing Skype before trying this method?

Also the 1st step is "Get skype at http://www.skype.com/en/download-skype/ ... -computer/ " but there are several versions listed there (under "Choose your distribution"), none of which is Linux Mint 16 64. Which version should I get?
klu9
Level 1
Level 1
 
Posts: 1
Joined: Sun Jul 22, 2007 6:19 pm

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby thomas2000 on Mon Feb 10, 2014 12:08 pm

I had the same problem. If you run 64 bit in the package manager you find only skype-i386
I installed skype-bin. problems were solved.
command: sudo apt-get install skype-bin
UNIX user since 1991 - Linux user since 2000
thomas2000
Level 1
Level 1
 
Posts: 4
Joined: Fri Jan 03, 2014 2:13 am

Re: Get The Sound Working In Skype With Linux Mint 16 64bit

Postby Bob_VM on Sun Mar 30, 2014 2:12 am

Tioz wrote:
Brahim wrote:
Geoff_P wrote:Does this apply to LM 16 Cinnamon 32 bit as well?
Thanks


This bug affects the 64bit only :D


First time LM user here. Using new V16 on a second machine. Nice alternative to Ubuntu :)
G'day all :) The above command worked fine for me on 32 bit system.


I applied this to 32-bit but 30 msec was not quite enough, so I did 60 msec and it worked. The Skype phone ringing sounded a bit breaking up but the conversation was fine. I even got the cam going for the first time, but it quit after about 30 seconds.

For me just edit the skype file and put the clause in and that was it. :P
Bob_VM
Level 1
Level 1
 
Posts: 1
Joined: Sun Mar 30, 2014 2:03 am

Linux Mint is funded by ads and donations.
 

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 5 guests