Fix "timeout initializing reports" and speed up boot

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Fix "timeout initializing reports" and speed up boot

Postby powerhouse on Wed Jan 22, 2014 8:16 am

I'm currently running LM16 and noticed that booting from SSD took much too long ~ 30 seconds!

Checking the dmesg log file under /var/log shows a 7 second delay in initializing an USB device :( . Here is the relevant section in dmesg:
Code: Select all
[   10.607141] hid-generic 0003:058F:9410.0007: input,hidraw4: USB HID v1.10 Keyboard [USB Multimedia Keyboard] on usb-0000:00:1d.0-1.3.3/input0
[   10.611668] input: USB Multimedia Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3.3/2-1.3.3:1.1/input/input7
[   10.611987] hid-generic 0003:058F:9410.0008: input,hidraw5: USB HID v1.10 Device [USB Multimedia Keyboard] on usb-0000:00:1d.0-1.3.3/input1
[   17.645726] hid-generic 0003:058F:9410.0002: usb_submit_urb(ctrl) failed: -1
[   17.645749] hid-generic 0003:058F:9410.0002: timeout initializing reports
[   17.645916] input: USB Multimedia Keyboard as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5:1.1/input/input8


Note the following message after the 7 second delay:

[ 17.645749] hid-generic 0003:058F:9410.0002: timeout initializing reports

This issue can be solved by adding the following grub command line option to your existing options in /etc/default/grub and changing the hexadecimal numbers as explained below:
Code: Select all
    GRUB_CMDLINE_LINUX_DEFAULT="usbhid.quirks=0x058F:0x9410:0x20000000"

where 058F is the vendor ID and 9410 the product ID taken from the dmesg line here:
[ 17.645749] hid-generic 0003:058F:9410.0002: timeout initializing reports

Following is an example of a complete grub entry after adding the above option - most likely yours will look different:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="profile elevator=deadline usbhid.quirks=0x058F:0x9410:0x20000000 quiet nomodeset"


When done editing and saving the /etc/default/grub file, issue the following command:
Code: Select all
sudo update-grub


And here the result after reboot:
Code: Select all
[   10.216019] hid-generic 0003:058F:9410.0007: input,hidraw6: USB HID v1.10 Keyboard [USB Multimedia Keyboard] on usb-0000:00:1d.0-1.3.3/input0
[   10.219682] input: USB Multimedia Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3.3/2-1.3.3:1.1/input/input9
[   10.219889] hid-generic 0003:058F:9410.0008: input,hidraw7: USB HID v1.10 Device [USB Multimedia Keyboard] on usb-0000:00:1d.0-1.3.3/input1
[   10.624759] vesafb: mode is 1920x1200x32, linelength=7680, pages=0


Voila, gone are the 7 seconds delay :D .


Note: The "timeout initializing reports" message in dmesg may or may not be preceded with a failure message - the important part is the "timeout..."

Reference: https://bugzilla.redhat.com/show_bug.cgi?id=907221
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 578
Joined: Thu May 03, 2012 3:54 am

Linux Mint is funded by ads and donations.
 

Return to Tutorials / Howtos

Who is online

Users browsing this forum: Dee'Kej and 8 guests