MEGA gnome performance boost

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

MEGA gnome performance boost

Postby hairy_Palms on Tue Mar 20, 2007 3:42 pm

Hi,

For the past while I've been experiencing poor performance in GNOME; for example, opening a gnome terminal can take 5-10 seconds on a system that's been running for a while (and with another gnome terminal already open). Having done some research, I found this thread: http://forums.gentoo.org/viewtopic-t...ighlight-.html

Checking my /etc/hosts, I saw:

Code:

127.0.0.1 localhost
127.0.1.1 inspiron

...so I added my hostname to the first line:

Code:

127.0.0.1 localhost inspiron
127.0.1.1 inspiron

(Replace "inspiron" with your hostname)

you should notice a crazy performance boost


REASONS

Explanation why.

This is a fix for the new system that was started back in edgy where the host name was split off to 127.0.1.1, the problem is that some applications still look for the host name @ 127.0.0.1, so to keep those applications happy and running smoothly you simple need to add the host name where those applications expect it to be.

Hope that helps explain the reason understandably.
User avatar
hairy_Palms
Level 4
Level 4
 
Posts: 297
Joined: Mon Nov 27, 2006 10:46 am

Linux Mint is funded by ads and donations.
 

Postby Husse on Tue Mar 20, 2007 4:13 pm

Thanks!!
The boost is astounding!
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby clem on Tue Mar 20, 2007 6:11 pm

User avatar
clem
Level 15
Level 15
 
Posts: 5541
Joined: Wed Nov 15, 2006 8:34 am

Postby clem on Tue Mar 20, 2007 6:14 pm

Hi,

Please publish a tutorial on this in the Community Portal.

http://www.linuxmint.com/wiki/index.php ... ity_Portal

Clem
User avatar
clem
Level 15
Level 15
 
Posts: 5541
Joined: Wed Nov 15, 2006 8:34 am

Postby hairy_Palms on Tue Mar 20, 2007 10:04 pm

i cant figure out how to add a new page on the wiki.... :(
User avatar
hairy_Palms
Level 4
Level 4
 
Posts: 297
Joined: Mon Nov 27, 2006 10:46 am

Postby Flint on Wed Mar 21, 2007 4:21 am

That worked great :D

Thanks a lot :!:
User avatar
Flint
Level 1
Level 1
 
Posts: 21
Joined: Thu Mar 15, 2007 6:54 am
Location: Bulgaria

Postby gabhla on Wed Mar 21, 2007 4:37 am

Saw this yesterday in the Ubuntu forums and tried it out. While it's beyond me why, it does speed things up.
User avatar
gabhla
Level 1
Level 1
 
Posts: 26
Joined: Sun Feb 25, 2007 6:36 pm

Postby clem on Wed Mar 21, 2007 6:04 am

User avatar
clem
Level 15
Level 15
 
Posts: 5541
Joined: Wed Nov 15, 2006 8:34 am

Postby hairy_Palms on Wed Mar 21, 2007 7:16 am

thhanks husse for the pm and thanks clem for putting up the page :)
User avatar
hairy_Palms
Level 4
Level 4
 
Posts: 297
Joined: Mon Nov 27, 2006 10:46 am

Linux Mint is funded by ads and donations.
 

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 4 guests