How I ICC Profiled My Monitor Under Linux

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

How I ICC Profiled My Monitor Under Linux

Postby johnnyb on Thu Oct 16, 2008 12:11 pm

Get the calibration software from here: http://www.argyllcms.com/

You'll also need some type of calibration hardware - I used a DTP94 type device.

To Profile The Display

1) Set env. variable:
export ARGYLL_IGNORE_XRANDR1_2=yes

2) Profile the display:
dispcal -yl -K -t6500 -f1 -k0 -o samsung.icc

3) Install Profile into X11 atom (this survives reboots):
dispwin -I samsung.icc


Every time you boot

1) Set env. variable:
export ARGYLL_IGNORE_XRANDR1_2=yes

2) Load profile into X11:
dispwin -L


NOTE: You may get strange color casts if you don't do the "export ARGYLL_IGNORE_XRANDR1_2=YES" before running the "dispwin -L"


Other Notes

dispwin -c (clears profile)
dispwin –V samsung.icc (verified profile is loaded)

“dispwin -I” installs your profile in an x11 atom. A file is created called .config/color.jcnf

And the profile itself is copied to .local/share/color/icc/devices/display/

To verify the X11 atom is loaded - comma after -d is needed:
xprop -root | grep ICC | cut -f 1-10 -d,
johnnyb
 

Linux Mint is funded by ads and donations.
 

Re: How I ICC Profiled My Monitor Under Linux

Postby johnnb on Fri Oct 17, 2008 9:36 am

Screen Savers (credit: lt_gustavsen; user from bibblelabs support forum)
If you are using gnome-screensaver it will destroy your calibration if you don't stop it before you load the calibration. I think gnome-screensaver remembers the status of the LUT from the time X11 was started. This script:

#!/bin/bash
#Profile installed once with:
#dispwin -I ~/.color/icc/i1.icc
gnome-screensaver-command --exit
export ARGYLL_IGNORE_XRANDR1_2=yes
dispwin -L
gnome-screensaver

attempts to set up ICC with a screen saver. The cript stops gnome-screensaver, loads the calibration and restarts the gnome-screensaver. It's best to just disable the screen saver.

The quick way to check if you are affected by this:

dispwin -L -V (if OK)
gnome-screensaver-command -a
dispwin -L -V (if still OK you have solved the problem)
johnnb
 


Return to Tutorials / Howtos

Who is online

Users browsing this forum: tino20 and 7 guests