How to make the touchpad turn off automatically when typing

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

How to make the touchpad turn off automatically when typing

Postby Husse on Sun Aug 09, 2009 6:39 am

I've been looking for a solution for this off and on for a long time - and now I found it
There's a handy little CLI tool called syndaemon that does this for you
Code: Select all
syndaemon -d

Shuts off the touchpad when you type and enables it two seconds after the last keystroke
If you add -t you only disable tapping and scrolling, not mouse movement (Just for your info - mostly it's the movement you want to disable)
If you add -i 1 it's enabled after one second
To make syndaemon start automatically add the command to the "Startup Applications" (for Gnome)
Open the menu and type star and you see it
Click the add button and enter syndaemon -d and give it a name (Notouch perhaps?)
In KDE 4 (Gloria) it is Applications > System > System settings > the Advanced tab > Autostart
Click Add program and enter syndaemon -d
To make sure that it works you should enable SHMConfig
In all editions except main and KDE you have to install SHMConfig
For Gnome
Code: Select all
gksudo gedit /etc/hal/fdi/policy/shmconfig.fdi

For KDE
Code: Select all
kdesudo kate /etc/hal/fdi/policy/shmconfig.fdi

This brings up an empty file
Add the following to that file
Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="input.x11_driver" string="synaptics">
      <merge key="input.x11_options.SHMConfig" type="string">True</merge>
    </match>
  </device>
</deviceinfo>

Save, close the file and reboot and you should be done
Note - for versions earlier than Felicia (Mint 6) this is added to xorg.conf
In
Section "InputDevice"
you add
Option "SHMConfig" "true"

Reference
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Re: How to make the touchpad turn off automatically when typing

Postby emorrp1 on Mon Aug 10, 2009 2:38 pm

Thanks, this'll be so useful whenever I can't take my wireless keyboard with me, I always accidentally changed focus because of this.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: How to make the touchpad turn off automatically when typing

Postby RichardH on Mon Aug 10, 2009 4:44 pm

Thanks, Husse!

For Xfce4
substitute mousepad for gedit in Gnome,
all the rest is the same.


This is a great little tool for the AA1.
The little touch pad is very sensitive when typing in unusual positions.
I usually connect a mouse but it's a pain also.

Now I don't scroll the screen by accident while typing.
I feel the need to tell people about this.
This is one of those papercut sort of annoyances.

Well done.
User avatar
RichardH
Level 3
Level 3
 
Posts: 133
Joined: Tue Jun 17, 2008 10:36 am
Location: Venezuela

Re: How to make the touchpad turn off automatically when typing

Postby hack on Sun Aug 16, 2009 1:08 pm

Thank you, this works flawelessly. It's annoying when you are writting and the cursor changes the focus.

Regards
hack
Level 1
Level 1
 
Posts: 14
Joined: Thu Jul 23, 2009 8:55 pm

Re: How to make the touchpad turn off automatically when typing

Postby Copa360 on Sun Aug 16, 2009 1:18 pm

I guess I'm lucky in the fact that my Compaq laptop has a physical switch to turn the touchpad on and off. I hardly ever use it anyway.
Copa360
Level 2
Level 2
 
Posts: 92
Joined: Sun Jul 05, 2009 3:25 am

Re: How to make the touchpad turn off automatically when typing

Postby ameseisch on Mon Aug 17, 2009 11:30 am

nice walk trough for this - thanks!

I wonder if you would know of a way to create a keyboard shortcut that would enable/disable the touchpad. Ideally there would be some sort of indicator (maybe in the gnome panel notification area?) to give you a visual clue that you have the touch pad disabled
ameseisch
Level 1
Level 1
 
Posts: 5
Joined: Mon Jun 30, 2008 2:01 pm

Re: How to make the touchpad turn off automatically when typing

Postby Husse on Mon Aug 17, 2009 6:19 pm

I think you can add a custom keyboard shortcut and use it to execute
syndaemon -d
It may be possible to fix a notification but that's over my head now
You could probably fix something that reads HAL and makes a message
NOTE
This will be obsolete with Ubuntu 9.10 Karmic as there will be no HAL but rather DeviceKit and udev
Have to figure out a new guide then :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How to make the touchpad turn off automatically when typing

Postby Schiphol on Mon Sep 07, 2009 9:46 am

Mmh. I've followed this tutorial, but I'm still getting "Unable to find a synaptics device." when I try to execute syndamon.

Any ideas what may be wrong? I'm using a Philips Freevents with Linux Mint 7.

Thanks
Manolo
Schiphol
Level 1
Level 1
 
Posts: 12
Joined: Tue Jul 14, 2009 4:16 am

Re: How to make the touchpad turn off automatically when typing

Postby Schiphol on Tue Sep 15, 2009 6:09 am

Just thought I'd bump. Thanks
Schiphol
Level 1
Level 1
 
Posts: 12
Joined: Tue Jul 14, 2009 4:16 am

Re: How to make the touchpad turn off automatically when typing

Postby emorrp1 on Tue Sep 15, 2009 7:02 am

Schiphol, run the following command:
Code: Select all
dpkg -l | grep xserver-xorg-input-synaptics

If this command just returns you to the terminal prompt, you don't have the synaptics driver and likely do not have a synaptics touchpad. If the command gives similar to this, then you do have the synaptics driver, which means you're likely to have a synaptics touchpad:
Code: Select all
ii  xserver-xorg-input-synaptics               0.99.3-2ubuntu4                                Synaptics TouchPad driver for X.Org/XFree86
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: How to make the touchpad turn off automatically when typing

Postby Schiphol on Tue Sep 15, 2009 8:32 am

Thanks! The output of

Code: Select all
 dpkg -l | grep xserver-xorg-input-synaptics


is, indeed,
Code: Select all
ii  xserver-xorg-input-synaptics                        1.1.2-1ubuntu1~wgrant1                         Synaptics TouchPad driver for X.Org server


But, nevertheless, the howto will not work in my computer. Any ideas as to what might be going wrong? If you need any further info, please let me know.

Manolo
Schiphol
Level 1
Level 1
 
Posts: 12
Joined: Tue Jul 14, 2009 4:16 am

Re: How to make the touchpad turn off automatically when typing

Postby emorrp1 on Tue Sep 15, 2009 9:17 am

Well, according to that, you're not running a current Mint release, you've enabled the karmic repos, so I guess that's just one of the drawbacks of trying beta software. Either try it directly from current Mint, or try and find the solution yourself, I have no idea what's going on.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: How to make the touchpad turn off automatically when typing

Postby Schiphol on Tue Sep 15, 2009 9:47 am

Thanks again. No, I'm running a current Mint release and have not enabled KK repositories. Is there any way to know from which repository is a particular file version coming?
Anyway, I have forced the jaunty version of xserver-xorg-input-synaptics and the problem remains:

Code: Select all
syndaemon
gives

Code: Select all
Can't access shared memory area. SHMConfig disabled?


While I do have the right /etc/hal/fdi/policy/shmconfig.fdi in place...

Manolo
Schiphol
Level 1
Level 1
 
Posts: 12
Joined: Tue Jul 14, 2009 4:16 am

Re: How to make the touchpad turn off automatically when typing

Postby DrHu on Tue Sep 15, 2009 9:49 am

Schiphol wrote:Thanks again. No, I'm running a current Mint release and have not enabled KK repositories. Is there any way to know from which repository is a particular file version coming?
Anyway, I have forced the jaunty version of xserver-xorg-input-synaptics and the problem remains:

I have forced the jaunty version of xserver-xorg-input-synaptics
And it apparently didn't work..

Linux Mint 7 (Gloria) 32 bit main edition
    dpkg -l | grep xserver-xorg-input-synaptics
    ii xserver-xorg-input-synaptics 0.99.3-2ubuntu4
    Synaptics TouchPad driver for X.Org/XFree86
0.99.3-2ubuntu4
--that is the version that is installed for linux mint 7 from the default repositories.
User avatar
DrHu
Level 17
Level 17
 
Posts: 7098
Joined: Wed Jun 17, 2009 8:20 pm

Re: How to make the touchpad turn off automatically when typing

Postby Schiphol on Tue Sep 15, 2009 9:55 am

I meant, after reading your reply. Now dpkg -l | grep xserver-xorg-input-synaptics shows:

Code: Select all
ii  xserver-xorg-input-synaptics                        0.99.3-2ubuntu4                                Synaptics TouchPad driver for X.Org/XFree86


as expected. I've rebooted and, as I say, the problem remains.

EDIT: Sorry, DrHu, not your reply. I've just noticed :)
Schiphol
Level 1
Level 1
 
Posts: 12
Joined: Tue Jul 14, 2009 4:16 am

Re: How to make the touchpad turn off automatically when typing

Postby samadhi on Sat Oct 10, 2009 3:54 am

Thanks Husse.

This simple command, syndaemon -i -d , put into the Startup Applications control of Mint 7 Gnome works great on my Compaq Presario touchpad. No more jumping insertion point/ cursor. I found the one second delay long enough.

Maybe there is a half-second delay switch?
samadhi
Level 1
Level 1
 
Posts: 20
Joined: Fri Aug 14, 2009 10:04 am
Location: Himalayas

Re: How to make the touchpad turn off automatically when typ

Postby steveperry on Wed Jul 21, 2010 10:47 am

This the amazing thanky you for finding this!
User avatar
steveperry
Level 1
Level 1
 
Posts: 10
Joined: Tue Jul 20, 2010 8:37 pm

Re: How to make the touchpad turn off automatically when typ

Postby aljoriz on Wed Jul 28, 2010 4:41 am

Wherever you are Husse you are a hero. Your legacy of helping people still lives in mint.

FOR LXDE:
Code: Select all
sudo leafpad /etc/xdg/lxsession/Mint/autostart



At the last list line:
add
Code: Select all
synadaemon -d
and save
aljoriz
Level 4
Level 4
 
Posts: 269
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: How to make the touchpad turn off automatically when typ

Postby IMAyNeed on Sun May 29, 2011 1:50 am

I am a newbie, so you may choose to really check what I write, but do not choose "disable touchpad while...." from the mouse menu.
It will just override any other command or package, and activate the touchpad.
9 Gnome 64-bit, 13 KDE 64-bit
ASUS G72 Notebook with Intel C2D P8700 2.53 GHZ 6 GB RAM
NVIDIA GEFORCE GTX 260M CUDA 1 GB
Atheros AR928X Wireless Network Adapter
Clear Modem with wi-fi with 3-6 Mb DL / .5-1 Mb UL
User avatar
IMAyNeed
Level 1
Level 1
 
Posts: 49
Joined: Thu Sep 23, 2010 7:04 pm

Re: How to make the touchpad turn off automatically when typ

Postby musetto on Wed Jan 11, 2012 6:22 pm

Thank you very much! I am always "charged" and this causes me a lot of nuisances when typing due to that damnit keypad. At least, now I can write without losing focus.
musetto
Level 1
Level 1
 
Posts: 1
Joined: Tue Jun 14, 2011 5:46 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 7 guests