HOWTO: Switch compiz-fusion on/off in GNOME easily

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

HOWTO: Switch compiz-fusion on/off in GNOME easily

Postby rich_roast on Wed Sep 16, 2009 10:12 pm

This quick HowTo is for Gnome people (maybe KDE too, please verify) who want to quickly and easily (couple of mouse- clicks) turn compiz-fusion on and off because, like me:

1) They want their work to look like a video game, so have lots of fusion effects on when they're "just" running Firefox, OOo, irc, Rhythmbox and such AND
a) They don't want their video games to feel like work just because they set all their fusion effects to mental (see criterion 1)
OR
b) They also experience bad flickering effects when stuck with their, let's say, ati 9600 card running on radeon driver and the compositing manager is determined to take control of OGL.

In both a) and b) cases they want to switch to metacity to, say, run Google Earth without them having a seizure, or fire up a game of the excellent Frets On Fire, but not at the expense of having to go through several windows to switch off visual effects.

There are a bunch of ways of getting this task done, including going through mintMenu -> preferences -> appearance -> visual effects -> all off; for the terminal crowd there's

Code: Select all
metacity --replace


which seems a lot simpler, but this HowTo is about installing a nice little icon on your panel (I know, there's a bunch of 'em there already, one more couldn't hurt, right?) which, upon right-clicking, gives the user a little direct control over what compiz is up to (or not...)

First we need to get it. You'll need a working Internet connection to access the repositories. If the user prefers using apt-get on the terminal then they'll know what to do from the following, but for those who like to

  • Open mintMenu
  • Click on Package Manager under System
  • Enter password on request
  • Enter "fusion-icon" into search box in Package Manager
  • Click on empty checkbox next to "fusion-icon" on the list, and select "Mark for Installation"
  • Click on "apply" in the toolbar
  • Make a (quick) cup of coffee, or tea, or whatever

And it should be installed. All of those windows can be closed, now. The challenge at this point is actually getting the icon to run.

  • Go into mintMenu -> Preferences -> Startup Applications (if you're looking at your favourites, click on "All Applications" at the top right of your mintMenu before the Preferences stage, of course)
  • Click on "Add"
  • You can write anything you like in the first field, "Name", but something like "Fusion Icon" is sensible in case you need to refer back to it later
  • In "Command" field, simply,
    Code: Select all
    fusion-icon
  • In "Comment" field, you could put something like "I don't believe Rich_Roast's sickening amount of details in his instructions". Seriously, anything you like.

With that all done, all it takes now is a restart of the X-Server; just log out and log back in really will get it done. There's other ways, of course, but this guide recommends that.

So what does it do? Your panel should now be adorned with a little blue box with a white arrow pointing upwards. It doesn't respond to left clicks, only a right click will open its menu. Things should be apparent from here; "Settings Manager" does the same as opening mintMenu -> Preferences -> CompizConfig Settings Manager. "Reload Window Manager" does just that; useful if perhaps something has broken in your compiz or metacity setup. Note that this option, and others below, will probably cause your screen to be redrawn, so depending on the system expect a bit of disk-churning and some, well, redrawing, to occur. Don't panic, but please do post bugs if there are any.

The most useful option is "Select Window Manager". This is what this HowTo is all about - by selecting Metacity all visual effects, and their resource grabbing, AIGLX upsetting ways will vanish. Refer again to the end of the previous paragraph if panicking about all that redrawing and sharpening of knives. When you want your desktop goodies back, clicking "Compiz" does just that. The "Loose Binding" and "Indirect Rendering" options under "Compiz Options" might get you better desktop performance if you're using certain graphics cards; nvidia ones at least some to be affected, but, alas, no improvement for this HowTo writer's ATI - his radeon means the "indirect rendering" checkbox is greyed-out and "loose bindings" make no perceptible difference, for him anyway, using the radeon driver. Finally, the window decorator menu is presumably useful if you have more than one - perhaps you have Emerald installed. This author only has gtk so he can't verify. Posts please.

There's also a quit option. But note that, using this guide, the icon will come back when you restart or log back on to Mint normally. If anyone ever wanted rid of the thing having installed it then they'd want to remove the entry they made in "Startup Applications", and uninstall the package by going through Package Manager again and this time "Mark for Removal".

Well, that's it. The guy who wrote this is doing his nut looking at workarounds, fixes and news for the nightmares and dreams that ATi has caused for Linux users and developers, and if he finds any goodies, he'll be right back here to post something.

ps.

the opposite terminal command of the one given above to replace compiz with metacity is

Code: Select all
compiz --replace
User avatar
rich_roast
Level 6
Level 6
 
Posts: 1136
Joined: Sat Sep 05, 2009 4:37 pm

Linux Mint is funded by ads and donations.
 

Re: HOWTO: Switch compiz-fusion on/off in GNOME easily

Postby smsmith on Fri Sep 18, 2009 11:24 pm

An excellent guide! Thank you much!

I too have one of the ATI cards. I've installed the latest ATI and radeon drivers from Tormod Volden's PPA and they have made things much better (no more screen crackle).
https://launchpad.net/~tormodvolden/+archive/ppa

However, when I log in, the number of desktops (workspaces) is reduced from 4 to 1. The settings are not changed, but the workspaces don't work right. I need to fiddle with the settings each time to make it work right. Any advice?
I like poetry, long walks on the beach and poking dead things with a stick.
User avatar
smsmith
Level 3
Level 3
 
Posts: 157
Joined: Thu Jul 23, 2009 1:30 pm
Location: Illinois

Re: HOWTO: Switch compiz-fusion on/off in GNOME easily

Postby rich_roast on Sat Sep 19, 2009 5:23 pm

smsmith wrote:An excellent guide! Thank you much!


Thank you kindly, glad you liked it.

smsmith wrote:I too have one of the ATI cards. I've installed the latest ATI and radeon drivers from Tormod Volden's PPA and they have made things much better (no more screen crackle).
https://launchpad.net/~tormodvolden/+archive/ppa

However, when I log in, the number of desktops (workspaces) is reduced from 4 to 1. The settings are not changed, but the workspaces don't work right. I need to fiddle with the settings each time to make it work right. Any advice?


I have had something of a bad experience with the drivers being pointed at; they broke Gnome pretty much entirely, getting as far as a (poor-resolution) desktop, but then a white-screen, and then temporary "screen-burning" when trying to shut down (I think that's what to refer to it as, a scary thing on the laptop LCD, kind of resembles what a cinema screen would like if the reel caught fire). I am aware that other users have been less lucky with various radeon drivers, even causing permanent damage to their machines (usually laptops). I tried various things to get them working but failed :(

Alas, I've had my fingers burnt. I'd encourage anyone with a testing setup available to try out the drivers smsmith found, but I wouldn't install them on a work machine, and in any event be a little wary of using testing drivers from PPAs.
User avatar
rich_roast
Level 6
Level 6
 
Posts: 1136
Joined: Sat Sep 05, 2009 4:37 pm


Return to Tutorials

Who is online

Users browsing this forum: Google [Bot] and 5 guests