Problème avec audio

French Forum

Problème avec audio

Postby robert leleu on Fri Jul 04, 2014 4:34 am

ai essayé http://doc.ubuntu-fr.org/son_problemes qui dit en 1.2

Si le même problème survient sur Natty 11.04, la méthode est la suivante:
éditez le fichier /etc/pulse/default.pa et commentez la ligne (ajouter # en début de ligne):
#load-module module-suspend-on-idle

sans succès
robert leleu
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 26, 2013 11:55 am

Linux Mint is funded by ads and donations.
 

Re: PulseAudio - Tune your setting and prevent glitching

Postby robert leleu on Fri Jul 04, 2014 10:04 am

et le phénomène a lieu aussi en session liveCD
robert leleu
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 26, 2013 11:55 am

Re: PulseAudio - Tune your setting and prevent glitching

Postby robert leleu on Fri Jul 04, 2014 3:33 pm

J'ai appliqué à nouveau la recette depuis le début.....(sans succès) mais au passage j'ai dû supposé que les valeurs récpérées par ~/pulseverbose.log avaient changé d'unité car

Code: Select all
leleu@leleu-portable:~ > grep device.buffering -m2 ~/pulseverbose.log
I: [pulseaudio] sink.c:     device.buffering.buffer_size = "14112"
I: [pulseaudio] sink.c:     device.buffering.fragment_size = "1764"
assuming 1411200 bps for stereo
device.buffering.buffer_size = "14112"=>14112/1411200=10 msecs
device.buffering.fragment_size = "1764"=>1764/1411200=1.25msecs

number of fragments=10/1.25=8
fragment size = 1.25

sans doute unités ont varié je mets 125 msecs

et relance  résultat nul
robert leleu
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 26, 2013 11:55 am

Re: PulseAudio - Tune your setting and prevent glitching

Postby robert leleu on Sat Jul 05, 2014 4:31 am

J'ai désinstallé pulseaudio depuis Synaptic.....pas de changement

J'ai aussi essayé https://forum.kde.org/viewtopic.php?f=1 ... 63#p298429 qui promet ALSA as audio server instead of Pulseaudio sans changement

Mais un miracle, curieusement dû à https://forum.kde.org/viewtopic.php?f=1 ... 63#p298559
J'installe bum par synaptic
Bum montre pulseaudio "inactif"
à tout hasard je clique pour activer, et, puisque bum=boot-up manager, je redémarre.
Le son est parfait !
Pourvu que ça dure, comme disait Laetitia Buonaparte.
robert leleu
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 26, 2013 11:55 am

Re: PulseAudio - Tune your setting and prevent glitching

Postby robert leleu on Fri Jul 18, 2014 4:13 pm

le défaut est revenu.....
désinstallé pulseaudio et relancé (sans résultat) Pulsaudio n'est plus vu par bum
remis autospawn = yes
réinstallé pulseaudio et relancé (sans résultat, en outre Pulseaudio reste invisible pour bum)

et de nouveau c'est bon après avoir remis autospawn = no et commencé à chercher «disable pulseaudio»...... il aura eu peur
le mixer est Kmix
robert leleu
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 26, 2013 11:55 am

Re: PulseAudio - Tune your setting and prevent glitching

Postby robert leleu on Sun Jul 20, 2014 5:56 am

Défaut de nouveau présent depuis le 19/7(hier)
pourtant pulseaudio n'est pas responsable puisque
Code: Select all
leleu@leleu-portable:~ > killall pulseaudio
pulseaudio: aucun processus trouvé

pulseaudio est installé (et donc non activé grâce à la ligne autospawn=no dans sa configuration) et le mixer et kmix

et la situation est identique en session MATE (sauf alsamixer au lieu de Kmix)
robert leleu
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 26, 2013 11:55 am

Re: PulseAudio - Tune your setting and prevent glitching

Postby robert leleu on Fri Jul 25, 2014 12:08 pm

Après installation "à neuf" de Mint 17 64bits KDE situation inchangée.

Au passage constaté le défaut en session CDlive......

Puis appliqué diverses recettes Google jusqu'à perdre tout son

Enfin réinstallé Mint17 et tenu compte de la remarque de ma petite-fille qui pirate la machine la nuit....avec des écouteurs et était trés étonnée de mes déboires:

le défaut ne se manifeste que sur la sortie haut-parleur, mais non sur la sortie casque......
robert leleu
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 26, 2013 11:55 am

Re: PulseAudio - Tune your setting and prevent glitching

Postby robert leleu on Tue Jul 29, 2014 10:24 am

Et il semble que sur la sortie haut-parleurs j'ai pu la maîtriser en insérant un bois d'alumette dans la prise femelle de sortie casque.....
conclusion : un faux contact aléatoire dans cette prise ? !
robert leleu
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 26, 2013 11:55 am

Re: Problème avec audio

Postby xenopeek on Tue Aug 12, 2014 2:23 am

Messages ci-dessus déplacés de viewtopic.php?f=42&t=44862. Ecrire messages en français seulement dans ce forum. Utilisez anglais dans les principaux forums.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14726
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Français (French)

Who is online

Users browsing this forum: No registered users and 6 guests