How to enable backlight brightness controls

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

How to enable backlight brightness controls

Postby beefstu on Wed Mar 31, 2010 10:13 am

This tutorial should help you try to fix problems with not being able to change your backlight brightness using the Fn keys on your laptop.

There are a couple of methods that can be used to try to fix this.

1. Passing acpi_backlight=vendor to the kernel at boot

To try this temporarily, on boot at the grub screen, with the Mint option highlighted, press 'e' on your keyboard. If the Grub boot menu does not normally show up on boot, press and hold the 'shift' key whilst booting until it shows. On this screen, navigate to just before it says 'quiet splash' and type
Code: Select all
acpi_backlight=vendor
then press ctrl-x to boot it.

Try the brightness controls again and see if it works:
- If it does then keep reading to make them permanent
- If it doesn't, try method 2 before rebooting, the commands you already put in will be forgotten on next boot

To make it permanent in Mint 8 and after (with Grub2) follow the blue instructions, Mint 7 and before (with Grub legacy) follow the instructions in red. If you have upgraded from Mint 7, it is likely you will still have Grub legacy installed and should therefore follow the red instructions.

Mint 8+

Code: Select all
gksudo gedit /etc/default/grub


find the line which says GRUB_CMDLINE_LINUX=""

and inbetween the ""

write

Code: Select all
acpi_backlight=vendor


save that then back in the terminal

Code: Select all
sudo update-grub


reboot again and see if they still work


Mint 7 and below
Code: Select all
gksudo gedit /boot/grub/menu.lst


Find the kernel line, should be something like
Code: Select all
kernel /boot/vmlinuz-2.6.27-7-generic root=/dev/sda11 ro quiet splash

and add the command as you did when you booted so it should look similar to this
Code: Select all
kernel /boot/vmlinuz-2.6.27-7-generic root=/dev/sda11 ro acpi_backlight=vendor quiet splash


Then reboot and see if it still works



2. change the backlight with xbacklight


First install xbacklight
Code: Select all
sudo apt-get install xbacklight


then in the terminal, run
Code: Select all
xbacklight -10
to turn the backlight down 10% or
Code: Select all
xbacklight +10
to turn up the backlight 10% and note whether these commands work or not. Reboot the laptop and run the xbacklight ±10 commands again and do one of the following:
- If it worked before rebooting but not after, follow the correct instructions in blue or red above and then continue reading down from here.
- If it worked after rebooting but not before, continue reading
- If it worked before and after reboot, continue reading.
- If nothing worked, its probably best to start a thread in the forum in a relevant section

The next step is to create a keyboard shortcut for them.

In the Mint menu, find the Keyboard Shortcuts application and click Add. In the name box, type Backlight Up and in the command box type xbacklight +10 and click Apply. Click the newly created shortcut in the Shortcut column and input the key combination that you want to use. There is a chance that the Fn+Button commands won't work, if so you may have to use Ctrl or Alt +the relevant button. Repeat this for turning down the backlight, but obviously with xbacklight -10 and a different key combination.


I welcome feedback, let me know if you spot a mistake or something is confusing. Also, if anyone has another method that worked for them that you think could be useful for other people, post it here or let me know.
Last edited by Oscar799 on Thu May 13, 2010 9:08 am, edited 3 times in total.
Reason: Amended title to make clear its a How-to guide
Please go through the steps here when posting a question. Once your question has been resolved, edit the original question post and add [Solved] to the subject. Both of these will help others use the forum effectively.
User avatar
beefstu
Level 5
Level 5
 
Posts: 654
Joined: Tue Dec 29, 2009 10:22 am
Location: Southampton, UK

Linux Mint is funded by ads and donations.
 

Re: Methods for enabling backlight brightness controls

Postby Aging Technogeek on Wed Mar 31, 2010 3:42 pm

Nice work beefstu. Very clear and concise. I like the two color system to differentiate between Grub 2 and Legacy Grub.
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4604
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Methods for enabling backlight brightness controls

Postby BrianD on Wed Mar 31, 2010 5:22 pm

agreed.

I would point out, however, that a command-line upgrade from Mint 7 to Mint 8 will produce a Mint 8 installation with legacy grub on it... so, I guess the color would be purple for them? :wink:
need I say more??
BrianD
Level 4
Level 4
 
Posts: 306
Joined: Fri Feb 12, 2010 12:22 am
Location: Tallahassee, Florida, USA

Re: Methods for enabling backlight brightness controls

Postby beefstu on Thu Apr 01, 2010 11:13 am

I did wonder this but have never upgraded myself, is it just a command-line upgrade or graphical too which would leave you with grub legacy in mint 8?
Please go through the steps here when posting a question. Once your question has been resolved, edit the original question post and add [Solved] to the subject. Both of these will help others use the forum effectively.
User avatar
beefstu
Level 5
Level 5
 
Posts: 654
Joined: Tue Dec 29, 2009 10:22 am
Location: Southampton, UK

Re: Methods for enabling backlight brightness controls

Postby BrianD on Thu Apr 01, 2010 1:03 pm

I don't know.. I've only done it once, and it was via the CLI. :wink:

interestingly, the /boot sector contained a bunch of extra grub2 stuff after the upgrade, but the functioning bootloader was still legacy grub. perhaps that was not a feature, but a bug in the upgrade process. :shrug: I manually converted the /boot sector over to grub2 for the sake of consistency.
need I say more??
BrianD
Level 4
Level 4
 
Posts: 306
Joined: Fri Feb 12, 2010 12:22 am
Location: Tallahassee, Florida, USA

Re: Methods for enabling backlight brightness controls

Postby zien on Thu Apr 29, 2010 4:25 pm

method 1 & 2 not working for me..

when im doing method 2.. after install xbacklight..
i type xbacklight -10/+10.
the result is "no outputs have backlight property"
what happen?
im a newbie. first time using linux mint.
zien
Level 1
Level 1
 
Posts: 3
Joined: Thu Apr 29, 2010 2:49 pm

Re: How to enable backlight brightness controls

Postby dritzominous on Fri Dec 31, 2010 4:41 pm

Same problem here. It's a bummer too, because this problem keeps my display at 100% brightness all of the time. My battery gets crap time when I'm off the plug because of it.

More help would be appreciated. I've tried everything I could find on the subject, and still nada.
User avatar
dritzominous
Level 3
Level 3
 
Posts: 160
Joined: Sat Nov 14, 2009 12:49 am

Re: How to enable backlight brightness controls

Postby Piloot on Sun Jan 09, 2011 1:47 pm

Hello.
Laptop is HP Compaq nx6325.
In Mint 7 thous red instructions worked. Did not try step 2.
At Mint 8 and Mint 10 thous blue instructions dont work. Step 2 dont work.

I added small brightness changeing applet to panel. Right click on panel. Then comes menu, chouse Add to panel... And there is this applet, actually I dont know its name in English, because I use Mint with Estonia language, but I think its name is Brightness changeing or something similar.

It does the job for me. Applet is clitchi and hard to control, but I found out that mouse wheel is the best way to control it.

This applet is not working when you have completed red or blue instructions. You have to undo this.

Applet should work now. It does not save settings, so after reboot brightness is default again.
User avatar
Piloot
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 09, 2011 1:04 pm

Re: How to enable backlight brightness controls

Postby drinkmorecoffee on Sat Feb 05, 2011 4:36 pm

Thanks for the detailed how-to!

Dell Inspiron N7010, Integrated Intel Graphics, Mint 10. I had already added the "acpi_backlight=vendor" line from another tutorial, with no effect. Installed xbacklight (said it was already up to date), and the associated +10 and -10 commands had no effect.

But you did mention one thing that got me thinking. You said that there's a chance the Fn keys just flat out won't work. My hard-wired backlight keys are F3 and F4, and while the system does seem to notice them being pressed, it refuses to adjust the backlight in response. So I went into CompizConfig and changed the "Opacity, Brightness and Saturation Settings" to map Alt+Up and Alt+Dn to "Incrase Brightness" and "Decrease Brightness" respectively.

Previously I had tried this same key mapping with F3 and F4, and my success was sporadic at best. With the Alt+Up and Alt+Dn mappings it seems to work consistently. My only issue now is that it only affects the current window - it's not system-wide. That is, each new window that opens launches itself at full brightness, and must be toned down manually. It's a minor annoyance to be sure, but it's worth noting.

Thanks for taking the time to write this!
drinkmorecoffee
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 05, 2011 4:19 pm

Re: How to enable backlight brightness controls

Postby evut on Fri Feb 25, 2011 12:03 pm

Hi, thanks everyone for writing this.
I have just spent 2 days trying to find something that would work on a Samsung RF710 laptop with Mint 10. I got the laptop to register the Fn+up/down, display the control and move the slider but it didn't actually do anything.

Then I read about the Compiz Config solution in the last post (wish I had read the whole thread properly and started with that...) and it works - I can use the Fn +up/down which is great but it changes brightness only on one window at a time like drinkmorecoffee says. Another issue is that I have to go into CompizConfig every time I log in and untick ant then tick again to enable the setting.
Any ideas how the CompizConfig settings could be changed to affect overall brightness and stay active after reboot?
evut
Level 1
Level 1
 
Posts: 35
Joined: Fri Mar 05, 2010 3:22 pm

Re: How to enable backlight brightness controls

Postby Supial on Sun Jun 02, 2013 5:14 am

Thanks a lot for those very clear instructions beefstu. The xbacklight method wordek with me.

Just wanted to mention that I had to find the right value to increase or decrease the brightness. If I type "xbacklight -get" (tells you the actual value set), then xbacklight -10 and again get, the difference is not 10%. The steps were of 14.285714. The reason seems to be there is 8 levels in total from 0 to 100 (100 diveded by 7 gives you that value). No big deal except that if I type xbacklight +10, nothing happens and I have to type xbacklight +15 to increase one level. Strangly, -10 worked but not +10. Don't have a clue why ?

I searched for solutions before and I think there is some kind of confusion for some people. The first thing is to know if Linux is able to change the brightness in any way. If not, I guess it would be a problem with the driver, acpi,... For me it was OK as I could actually change the brightness through the settings panel but my problem is that I could only do it while connected to power because the slider for brightness doesn't appear in the battery section (strange decision from ubuntu developper...). So I tried to change it with the fn keys and realized those keys weren't working. If you can't change the brightness at all, I think there is no way trying to make the fn keys work. Reason why beefstu said you'd better start a new thread in that case.
Linux Mint 14 Mate 32bits
Compaq nc6220 notebook
Supial
Level 1
Level 1
 
Posts: 2
Joined: Tue Mar 26, 2013 6:22 am
Location: Belgium

Re: How to enable backlight brightness controls

Postby MagicMint on Sat Jul 06, 2013 7:04 pm

As no boot parameter had worked for me, I had to use a software only method instead. This alternative needs a script however, see tutorial: WHATTO Do When the Backlight (Brightness) Keys Don’t Work.
Minze, mint, menthe, menta, mento…

Avatar by PhotoZel at CrystalXP.net
User avatar
MagicMint
Level 1
Level 1
 
Posts: 16
Joined: Fri May 31, 2013 1:29 pm

Re: How to enable backlight brightness controls

Postby chauchakching on Wed Jan 15, 2014 12:12 pm

it works immediately after xbacklight is installed, problem solved.
thanks so much
chauchakching
Level 1
Level 1
 
Posts: 1
Joined: Wed Jan 15, 2014 12:07 pm

Linux Mint is funded by ads and donations.
 

Return to Tutorials

Who is online

Users browsing this forum: smsmith and 3 guests