[SOLVED]Shutdown Sounds Linux Mint

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

[SOLVED]Shutdown Sounds Linux Mint

Postby fromk2i on Fri Jul 16, 2010 6:29 pm

Please post your "How To Enable Shutdown Sound" here. I have my own login sound and start up sound working fine but the sound card is turned off before shutdown sounds are played and I would like this enabled. I have searched the forum and could not find this topic covered clearly. I am using a desktop with Linux Mint 9 Isadora- Gnome. All my sounds work except for shutdown. I have placed the sound file properly but the system turns off the soundcard before it can play apparently. Please post things about "no sound", "start up sounds", "poor sound quality" in another thread. This is one topic only, i.e. "Shut Down Sound".
I used Kubuntu in the past and that would always play that horrible Kubuntu music at shutdown unless you turned it off, but Mint is not playing the sounds when it shuts down.

This is really important to some! Please keep it clear for noobs as well. Thanks!
Last edited by fromk2i on Sat Jul 17, 2010 7:55 pm, edited 2 times in total.
fromk2i
Level 1
Level 1
 
Posts: 5
Joined: Sat Jun 12, 2010 3:42 pm

Linux Mint is funded by ads and donations.
 

Re: Shutdown Sounds

Postby fromk2i on Sat Jul 17, 2010 10:35 am

excerpt from: https://bugs.launchpad.net/ubuntu/+sour ... +bug/61530
Scott James Remnant wrote on 2006-10-04: #20

Sorry, but that's absolutely fruity loopy!

The entire point of shutting down the machine is that the user doesn't want it anymore -- spending several seconds playing them nice music instead of getting on with the job is going to seriously piss off most people.

Especially when they realise that it's ONLY playing the shutdown sound!
-------------------------------------------------------------------------------------------------------------------------
Well IMHO this person is wrong! I understand that I am turning the machine off. If it takes 10 seconds to turn off or 15 seconds to turn off that is OK. If you are worried about "FAST" then focus on start up speed. I need a computer to start up quickly, not shutdown quickly. I would like my shutdown sound to play even if it takes 45 minutes to shutdown. It is my computer and that is what I want. There has to be a way to allow the sound card to play the file in it's entirety before the term signal. If you would like to hear the duration of the sound or have the sound you can download it here: http://www.ziddu.com/download/10755268/ ... g.zip.html Thanks!
fromk2i
Level 1
Level 1
 
Posts: 5
Joined: Sat Jun 12, 2010 3:42 pm

Re: Shutdown Sounds

Postby remoulder on Sat Jul 17, 2010 12:22 pm

fromk2i wrote:Please post your "How To Enable Shutdown Sound" here

This is a tutorial forum, not a request one. Please post problems or requests in one of the other forums.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Shutdown Sounds

Postby fromk2i on Sat Jul 17, 2010 1:12 pm

Figures, I requested a How To ! Instead after scouring a forum filled with choppy posts that include several topics at once, your offer is a worthless comment as a reply. You could have posted the How To under the specific name of "Shut down Sounds". Which is a seperate issue from all others. I figured if I posted anything I would just get a reply that it is in the wrong category. Even though it isn't. The post was made for a How To. It was posted for a reason!
fromk2i
Level 1
Level 1
 
Posts: 5
Joined: Sat Jun 12, 2010 3:42 pm

Re: Shutdown Sounds

Postby atovinov on Sat Jul 17, 2010 2:22 pm

Correct me if I am wrong, but the shutdown sounds have been unavailable since PulseAudio was introduced (I think it was Mint 6 or Mint 7 - might even have been Mint 5). I have seen numerous posts over the years in regards to the shutdown sounds with the general consensus being "PulseAudio cuts the sound system off before the shutdown sound has time to play." A few releases back, PulseAudio could be removed and ALSA used, but I do not think that is an easy option anymore.

Not meaning to be disrespectful in any way, but if the only tiny niggle you have with Mint is the shutdown sound, I would consider that something to disregard in looking at the overall picture. I equate the shutdown sound issue to a small scratch on the bumper of my car. Sure, I know it is a minor cosmetic issue, yet it does not detract from my car's overall functionality. Most people would never notice that scratch anyway, just as many of us have gotten accustomed to not hearing the shutdown sounds in GNOME after all these years.
atovinov
Level 1
Level 1
 
Posts: 33
Joined: Fri Jan 22, 2010 2:29 pm

Re: Shutdown Sounds

Postby fromk2i on Sat Jul 17, 2010 2:53 pm

Thanks for your reply. At least we covered the actual topic. So, a shutdown sound is out of the question?? OK!
That however is not the only issue, my floppy drive doesn't work, my USB pinter support has stopped working since I updated last, my printer now says "not connected" but does run on Ubuntu Karmic and Puppy Linux.
So at least anyone with a question about "Shut Down Sound" can get their answer and that is " you can't have one".
Which is a different topic from "Start Up Sound", "No Sound" and all the other "SOLVED" topics on this forum. Thanks for your participation.
fromk2i
Level 1
Level 1
 
Posts: 5
Joined: Sat Jun 12, 2010 3:42 pm

Re: [SOLVED]Shutdown Sounds Linux Mint

Postby @aloss on Mon May 07, 2012 4:36 pm

I can only say that I fully sympathise with you!
- I've been trying to get an answer to this problem myself, for almost a year now, and can only surmise that nobody out there seems to know how to solve/fix this. :(
@aloss
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 05, 2011 8:43 pm

Re: [SOLVED]Shutdown Sounds Linux Mint

Postby Jawz on Mon May 07, 2012 11:07 pm

I remember using LinuxMint 8, it had alsa and worked like a bomb.

sometimes my laptop use to have issues, so someone told me:

There is an intermittent race condition in the alsa-utils module on shutdown. I commented out lines 372-375 in /etc/init.d/alsa-utils which fixed the problem. The easiest way to do this

Code: Select all
sudo gedit /etc/init.d/alsa-utils
CTRL + I ('I' as in Ireland)
372 [enter]


make sure to leave a note someplace for yourself in case you muckety-muck things

#case "$TARGET_CARD" in # appended by pompom@linux-mint: commented out lines 372-375
# ""|all) TARGET_CARD=all ; log_action_begin_msg "Shutting down ALSA" ;;
# *) log_action_begin_msg "Shutting down ALSA card ${TARGET_CARD}" ;;
#esac

Peace.
Jawz
Level 1
Level 1
 
Posts: 28
Joined: Sat Jan 16, 2010 8:50 pm

Re: [SOLVED]Shutdown Sounds Linux Mint

Postby proxima_centauri on Tue May 08, 2012 7:27 am

Please don't bump threads that have been dormant for years. Start a new topic if you have a question please.
* Topic Locked
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3969
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Linux Mint is funded by ads and donations.
 

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 7 guests