HowTo: Using Gigolo to Mount Remote Samba Shares

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this

Re: HowTo: Using Gigolo to Mount Remote Samba Shares

Postby altair4 on Tue Jul 24, 2012 9:21 am

Never seen a "Software caused connection abort" error before. Not even sure if the "software" it's referring to is local to the Mint box or coming from the OS2 server you are using. Did a quick search of the error message and they all go back to 2008 and some claim it was fixed many years ago. Sorry, I don't have a clue.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6876
Joined: Tue Feb 03, 2009 10:27 am

Linux Mint is funded by ads and donations.
 

Re: HowTo: Using Gigolo to Mount Remote Samba Shares

Postby dhdurgee on Tue Jul 24, 2012 9:55 am

My suspicion is it is on the mint end, possibly due to some unanticipated behavior on the OS/2 server, that results in the crash. In part I suspect this as I can still access and use the gvfs mounted share from the desktop without problems. Of course this prevents me from using FCL or MC as I usually do to move files, compare directories, create archives, etc. conveniently. I can use the share from a cifs mount with FCL and MC, but I get errors after I copy files onto the share that I don't see with gvfs mounts. I don't know what the differences are between gvfs windows share mounts and cifs mounts, but there is a difference in behavior. Perhaps I can tweak the cifs mounts if I knew what gvfs is doing, but then again perhaps I will wind up with cifs crashes if I try.

Dave
dhdurgee
Level 4
Level 4
 
Posts: 243
Joined: Thu Jul 02, 2009 7:56 pm

Re: HowTo: Using Gigolo to Mount Remote Samba Shares

Postby dhdurgee on Wed Jul 25, 2012 11:03 am

I decided to do a bit more testing to see if there were a pattern to the crashes of the gvfs-fuse-daemon and I am puzzled by what I see. Some of the sub-directories cause the crash, but not all of them. Specifically attempting to enter the VM, books, My_Pictures or os2-apps result in the crash. The manuals and My_Music directories appear to be functioning normally, including the sub-directories of My_Music. The strangest one is the temp directory, which can be entered but where two of each file and sub-directory are displayed! These doubled entries do not appear when browsing this directory with Nautilus but do appear in FCL, MC or a terminal window. These doubled entries are present only in the temp directory, not the sub-directories of the temp directory. Wierd!

As I noted yesterday, I can still work with the share even after the gvfs-fuse-daemon crashes using Nautilus via the Gigolo folder. Does this imply that Nautilus mounts the folder somewhere else that I could access from FCL or MC? That would be helpful.

Dave
dhdurgee
Level 4
Level 4
 
Posts: 243
Joined: Thu Jul 02, 2009 7:56 pm

Re: HowTo: Using Gigolo to Mount Remote Samba Shares

Postby jpete on Wed Apr 29, 2015 8:27 pm

altair4 wrote:
STEP2: Initial configuration

Launch gigolo then go to Edit > Preferences
G-General.png


I tried to follow these steps but at this point, instead of the gears icon next to "xterm", I have a red circle with a line through it.

That seems like an issue. And when I try to enter my login information for my NAS, it doesn't accept it.

I'm not sure if those two things have anything to do with each other but I'd like to be able to resolve this issue so any suggestions would be appreciated.

I'm using Mint 17.1 BTW
Jeff
jpete
Level 3
Level 3
 
Posts: 195
Joined: Tue Nov 04, 2008 12:10 am

Re: HowTo: Using Gigolo to Mount Remote Samba Shares

Postby altair4 on Thu Apr 30, 2015 6:24 am

I tried to follow these steps but at this point, instead of the gears icon next to "xterm", I have a red circle with a line through it.

That's normal if you are not using XFCE. You shouldn't change anything on that tab anyway except maybe the auto connect interval.
That seems like an issue. And when I try to enter my login information for my NAS, it doesn't accept it.

If the NAS doesn't accept your credentials it's not an issue with gigolo it's an issue with the NAS.

I'm guessing you can't connect through Nemo either with those credentials.

I would start a new topic and try to access the NAS through Nemo first and explain the problem. Posting the output of this command would help in the diagnosis:
Code: Select all
testparm -s

Note: I'm assuming you are using Cinnamon and that you are trying to connect via Samba since you didn't provide that information here.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6876
Joined: Tue Feb 03, 2009 10:27 am

Re: HowTo: Using Gigolo to Mount Remote Samba Shares

Postby jpete on Thu Apr 30, 2015 5:17 pm

I am not trying to connect through Samba as I thought Gigolo was going to allow me to connect. I'll give that a shot and if I have no luck, I'll do as you suggest and start a new thread with the particulars.

Thanks.
Jeff
jpete
Level 3
Level 3
 
Posts: 195
Joined: Tue Nov 04, 2008 12:10 am

Previous

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 6 guests