Can't get linux mint (or ubuntu for that matter) to install

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Can't get linux mint (or ubuntu for that matter) to install

Postby kazyn on Sun Apr 29, 2012 10:35 pm

So.....I want to install Mint. I throw it on a USB flash drive using unetbootin, boot to it, select install. It gets to this and stops completely:

Image

I think maybe it's unetbootin not working correctly, so I go find a DVD and burn it. Pop it in, same thing.

Now I'm thinking ok, screw it... I have ubuntu, I'll throw that on there for now till I can figure out what's up. It does literally the SAME thing...so I don't know what to do. It just sits there, blinking away.

Any ideas?

Core2Quad Q6600, 8GB DDR2 800mhz, Asus P5Q SE, nvidia GTX 550ti.
kazyn
Level 1
Level 1
 
Posts: 4
Joined: Sun Apr 29, 2012 10:26 pm

Linux Mint is funded by ads and donations.
 

Re: Can't get linux mint (or ubuntu for that matter) to inst

Postby xandora on Mon Apr 30, 2012 1:51 am

Just a thought, have you tried a different keyboard? If it looks like it's getting stuck on loading the keyboard, that could be the issue.

Sent from my phone. Excuse the formatting nasties.
xandora
Level 1
Level 1
 
Posts: 11
Joined: Wed Apr 25, 2012 4:49 am

Re: Can't get linux mint (or ubuntu for that matter) to inst

Postby kazyn on Mon Apr 30, 2012 10:06 am

No, I only get this far:

Image


If I plug in the keyboard after I get to this point, it immediately recognizes it and outputs this:

Image
kazyn
Level 1
Level 1
 
Posts: 4
Joined: Sun Apr 29, 2012 10:26 pm

Re: Can't get linux mint (or ubuntu for that matter) to inst

Postby kazyn on Mon Apr 30, 2012 10:41 am

A wonderful person over on r/linuxquestions found this:

https://bugs.launchpad.net/ubuntu/+sour ... bug/969121

It basically says my video card is what's causing the bug. The suggestion is here:

This is a kernel bug <https://bugzilla.kernel.org/show_bug.cgi?id=42876> which says that all 3.2 and 3.3 kernels will crash as soon as the nouveau kernel module is loaded. I don't know if other NVIDIA cards of the NVC0 generation are affected as well.

The good news, not noted in the upstream bug: the issue is resolved in 3.4rc2 at the latest. Verified on Fedora 16.

Ubuntu 12.04 is already in the kernel freeze phase prior to the release, so the OOTB experience will likely remain broken for all users with a GTX 550 Ti. The workaround is to prevent nouveau from loading and to use vesa instead.


So.....how does one force versa over nouveau?
kazyn
Level 1
Level 1
 
Posts: 4
Joined: Sun Apr 29, 2012 10:26 pm

Re: Can't get linux mint (or ubuntu for that matter) to inst

Postby xandora on Mon Apr 30, 2012 3:09 pm

You can try adding nomodeset as a boot condition before you start loading Linux mint. However, it may only be a temporary fix.

Sent from my phone. Excuse the formatting nasties.
xandora
Level 1
Level 1
 
Posts: 11
Joined: Wed Apr 25, 2012 4:49 am

Re: Can't get linux mint (or ubuntu for that matter) to inst

Postby buzzingrobot on Mon Apr 30, 2012 7:10 pm

Kazyn, Fedora's list of common bugs in their current beta includes this as a bug for the GTX 580, but it's the same kernel bug that produces the crash when it tries to load the open source (nouveau) Nvidia driver. Here's what they say:

It has been reported that a bug in the nouveau video driver causes systems with an NVIDIA GeForce GTX 580 video adapter to hang as soon as the X graphical environment starts up. This issue also affects installation, so as soon as X is started, installation hangs.

This issue can be worked around by disabling hardware acceleration. To do this, pass the kernel parameter nouveau.noaccel=1. You can append kernel parameters at boot time - of a live image, DVD or network install image, or an installed system - by hitting the Tab key when the system reaches the bootloader menu, and typing in the desired additional parameter.

You can make the workaround 'permanent' on an installed system either by editing it into the /boot/grub2/grub.cfg file, or by creating a file named /etc/modprobe.d/noaccel.conf containing a single line reading:

options nouveau noaccel=1



Of course, turning off acceleration permanently is not what we want to do. Fedora has patched their kernels and I hope I pick it up when I update the beta. I don't know if Ubuntu/Mint have updated their kernels, but it's worth asking.


I'm expecting a 550TI to arrive tomorrow and plan to use the Fedora beta on it, so I've been concerned about this, too.
buzzingrobot
Level 1
Level 1
 
Posts: 27
Joined: Tue Jan 17, 2012 9:14 pm

Re: Can't get linux mint (or ubuntu for that matter) to inst

Postby kazyn on Mon Apr 30, 2012 9:08 pm

I ended up pulling my 550ti out and throwing my old 9800GTX in there.....booted up first time.

Oh well..maybe it's a sign to get a new one and quit accepting these hand-me-downs :roll:
kazyn
Level 1
Level 1
 
Posts: 4
Joined: Sun Apr 29, 2012 10:26 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Google [Bot], lostfarmer, webtarget and 13 guests