Live DVD boots to gray screen with cursor

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Live DVD boots to gray screen with cursor

Postby dallmon on Sat May 19, 2012 1:38 am

Hi,

Every time I boot from the Live CD or DVD for Linux Mint 12 or 13rc (both x86_64) I get the Live CD menu, select "Start Linux Mint", and it immediately gives a light gray screen with a white blinking cusor. The disk light continues to go for a minute or so, then stops. I can CTL-ALT-DEL, wait a while, then hit ENTER, and the system shuts down. That tells me something is happening. I have tried it from the Live CD/DVD (4 downloads), have copied the ISO to a spare drive, and have also made a bootable USB stick. All behave exactly the same.

The hardware is relatively new: i7-2600 16GB RAM, 2 1TB disks, 1 500GB disk (the target). I have installed Windows 7, Ubuntu 11.04, 11.10, 12.04, Debian Squeeze without any problems in the last few days. I decided after the Ubuntu 12.04 upgrade that their efforts to drive away Gnome users had finally paid off, and went looking for something else, but I have an nVidia dual head arrangement that requires the nVidia proprietary drivers. Ubuntu is really good with that process.

If anyone has encountered such a problem, I would be interested in any input. No hurry, I have about 100,000 other distributions to try still. :shock:

Thanks!
dallmon
Level 1
Level 1
 
Posts: 5
Joined: Sat May 19, 2012 1:14 am

Linux Mint is funded by ads and donations.
 

Re: Live DVD boots to gray screen with cursor

Postby DataMan on Sat May 19, 2012 8:42 am

Have you performed the md5 checksum on the iso (both download and burned media verification)?

-DataMan
Linux'd since 2005 Linux ID 422356 Ubuntu ID 15015
User avatar
DataMan
Level 6
Level 6
 
Posts: 1226
Joined: Thu Dec 04, 2008 6:47 am
Location: Carmel, Indiana USA at /var/www

Re: Live DVD boots to gray screen with cursor

Postby dallmon on Sat May 19, 2012 9:38 am

Thanks for the reply, DataMan.

I just checked the DVD images of both 12 and 13rc against the md5's and they agree. I checked the DVDs, and they verify. I have not checked the hard drive or the USB stick, but since they behave identically, I' m going to assume they are the same. I only checked the most recent downloads. The earlier ones were burnt to DVD, tried, and thrown out - I assumed the ISOs or the burns were bad.

Just a guess here, I believe the system is actually booting, but is not letting me see it. If I boot using the compatible mode option, the boot sequence goes along on the screen then stops dead, even though the drive light continues to flash for another 30 seconds or so. The display "freezes" after the enumeration of the SATA ports. Not always in exactly the same spot, though.

Thanks.
dallmon
Level 1
Level 1
 
Posts: 5
Joined: Sat May 19, 2012 1:14 am

Re: Live DVD boots to gray screen with cursor

Postby dallmon on Sat May 19, 2012 2:59 pm

UPDATE: I tried Ubuntu 12.04 and it did the same thing, only with a black screen insead of a gray one. This was unexpected, so I downloaded the desktop CD rather than the alternate CD, and it worked fine. It is the Live CD thing causing the problem - not the particular distro and version.

This begs the question...Is there a way to make the installer work from the DVD without having booted from it?
dallmon
Level 1
Level 1
 
Posts: 5
Joined: Sat May 19, 2012 1:14 am

Re: Live DVD boots to gray screen with cursor

Postby dallmon on Sat May 19, 2012 5:37 pm

Yet another update: SOLVED!

I had to hit tab at the start linux mint option and add after the "--":
"noacpi noapic nomodeset"

That gets it to boot, but the video is hosed on reboot after install. I copied the default xorg.conf in and got the video going.
dallmon
Level 1
Level 1
 
Posts: 5
Joined: Sat May 19, 2012 1:14 am

Re: Live DVD boots to gray screen with cursor

Postby josteinaj on Sun May 20, 2012 8:07 am

Thanks! That got me past the gray screen as well - I had the exact same problem. (I've got an HP EliteBook 8560w with the DVD replaced with a 500GB disk).
josteinaj
Level 1
Level 1
 
Posts: 2
Joined: Sun May 20, 2012 8:00 am

Re: Live DVD boots to gray screen with cursor

Postby josteinaj on Sun May 20, 2012 10:08 am

dallmon wrote:(...) I copied the default xorg.conf in and got the video going.

So I've installed and now the video isn't working; there's just a bunch of blue and green horizontal stripes across the screen. I booted into the Live CD (from USB) to gain access to the new Linux Mint filesystem, and copied /etc/X11/xorg.conf.failsafe to /etc/X11/xorg.conf (assuming that's what you did) but it didn't help.

Any ideas?
josteinaj
Level 1
Level 1
 
Posts: 2
Joined: Sun May 20, 2012 8:00 am

Re: Live DVD boots to gray screen with cursor

Postby dallmon on Thu May 24, 2012 2:00 am

I ran into that as well. At one point, the install put in a default nvidia driver (I have an nvidia card). The driver didn't work right. My xorg.conf looked something like this after I copied the default config file:

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

When I finished messing with the installation, it looked like this:

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

I did not put that in, but I installed an nVidia driver (not from the Control Center). Out of sheer desperation I changed it back to "vesa" and rebooted. Video worked but had some wacky aspect ratio. I went to Control Center->Additional Drivers and installed the recommended driver and all is well. The xorg.conf now has this in it:

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTS 450"
EndSection

I have no idea why the install didn't work, or why that fixed it.
dallmon
Level 1
Level 1
 
Posts: 5
Joined: Sat May 19, 2012 1:14 am

Re: Live DVD boots to gray screen with cursor

Postby Francis Marion on Sat May 26, 2012 2:35 am

I am having the same problem.

I have installed 32 bit LM13 on a laptop and 64 bit LM13 on a desktop without any issues but get this gray screen with the flash boot on a 3rd computer. I installed by using compatability mode with the flash boot and now get the horizontal lines described by josteina that indicates a bad video sync. Copying xorg.conf.failsafe doesn't help because the text is identical in both.

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection


All 3 computers have nvidia cards with the 3rd having the newest video card.
Francis Marion
Level 1
Level 1
 
Posts: 3
Joined: Sat May 26, 2012 2:18 am

Re: Live DVD boots to gray screen with cursor

Postby alexakarpov on Thu Nov 15, 2012 9:58 pm

exactly the same problem here. I also managed to start the installation, with just a nomodeset flag. It then seems to finish installation fine, but when I proceed to reboot, nothing boots at all. I don't get anything, not even a grey screen this time, no cursor, nothing... Don't know if this post will get bumped or not, but if anyone can offer any suggestions, it would be much appreciated.
alexakarpov
Level 1
Level 1
 
Posts: 1
Joined: Thu Nov 15, 2012 9:44 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 8 guests