startx fails

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

startx fails

Postby locutus on Sat Mar 15, 2008 2:42 pm

Daryna 4.0 KDE edition.

I just get Mint configured the way I want and...I can't boot in anymore (I'm typing from Mepis, which I had planned on deleting, but now...?).

I get about a third of the way in and it goes to a command prompt. The usual workarounds, <ctrl>+<alt>+F7, <ctrl>+<alt>+F8, <ctrl>+<alt>+F1 don't do anything except lead to a completely blank screen. <ctrl>+<alt>+Del gets past that and it seems to continue booting fine until I get the graphical login screen, then every time I enter my password it loops back to the login screen again. <Alt>+E to restart X results in the same thing. Changing the session type to gnome or failsafe does nothing.

Mepis has a utility that checks partition integrity; it passed on both /root and /home partitions.

Is there a way past this that I'm missing, or does the Mint Live CD have any utilities to fix this? If I re-install can this be avoided in any way? Or if I delete and re-install gnome-version can I add KDE from the repositories?

In short, what are my options here?
Thanks in advance.
User avatar
locutus
Level 4
Level 4
 
Posts: 406
Joined: Mon Dec 04, 2006 4:54 pm
Location: Ontario, Canada

Linux Mint is funded by ads and donations.
 

Re: startx fails

Postby grimdestripador on Sat Mar 15, 2008 3:34 pm

I have this exact problem. it seems that KDM isn't running properly. I can't install LM KDE because of it either. Please offer a workaround.

When booting off the DVD...
It happends about midway though loading (according to the process bar), then flashes the window black, returns to the terminal, and blinks on it own blank line. If i press return, then the normal mint@mint prompt appears. Hmm.
User avatar
grimdestripador
Level 6
Level 6
 
Posts: 1069
Joined: Fri Feb 16, 2007 2:26 am

Re: startx fails

Postby locutus on Sat Mar 15, 2008 4:04 pm

Is there any config file I can edit from within Mepis?
User avatar
locutus
Level 4
Level 4
 
Posts: 406
Joined: Mon Dec 04, 2006 4:54 pm
Location: Ontario, Canada

Re: startx fails

Postby grimdestripador on Mon Mar 17, 2008 7:44 pm

Problem Found: (compared to previous post)
I just went and installed with ubuntu alternative and found that...

My recent upgrade to a nVidia 8800 does not seem to be supported by
1) nvidia-glx-new
2) nvidia install through envy
3) nvidia install as by restricted modules

The community edition KDE does not seem to boot due to valid video drivers.
Question. Is there a way to enable the visa driver, since the live cd auto detect does not seem to behave when KDM does not "status [ok]", ie (ctrl-alt-bkspace does not respond). Alt-F1 and the like respond, but the modifications of
Code: Select all
sudo dpkg-reconfigure xserver-xorg -phigh
don't seem to take effect in Alt-F7, since I can't get it to ctrl-alt-bkspace.
User avatar
grimdestripador
Level 6
Level 6
 
Posts: 1069
Joined: Fri Feb 16, 2007 2:26 am

Re: startx fails

Postby locutus on Mon Mar 17, 2008 7:56 pm

All I can think of is, in some distros I have changed a few desktop settings before installation, and those changes held after installation is finished. I haven't tried this with Mint so I don't know for sure if this would work.

But you could try.... Edit the xorg.conf file (in /etc/X11 directory) and select vesa driver there, then proceed with installation.

Can you install and then boot into Recovery-mode? You might be able to edit the same file from there and see if it works. Those are my only two possible fixes. Sorry I couldn't give a definitive answer.
User avatar
locutus
Level 4
Level 4
 
Posts: 406
Joined: Mon Dec 04, 2006 4:54 pm
Location: Ontario, Canada

Re: startx fails

Postby grimdestripador on Mon Mar 17, 2008 11:49 pm

So its just plain incompatability with the nvidia gforce 8800.

in short the solution to boot from live cd goes like

First, remove nvidia-glx, nvidia-glx-new, remove envy installed.
Code: Select all
[b]<ctrl-alt-F1>
sudo /etc/init.d/kdm stop
sudo dpkg-reconfigure xserver-xorg -phigh
wget -c http://us.download.nvidia.com/XFree86/Linux-x86/169.12/NVIDIA-Linux-x86-169.12-pkg1.run
sudo sh NVIDIA-Linux-x86-169.12-pkg1.run
sudo /etc/init.d/kdm start
exit
<ctrl-alt-F7>[/b]

[You might need to navigate to the right directory since wget will be in your user folder.]

The bright side is that that these urls lead me to fix this problem.
Ubuntu Feisty and an Nvidia 8800 GTS
http://jd.wuputah.com/articles/2007/08/ ... a-8800-gts

Help installing Edgy with nVidia 8800 GTS - Ubuntu Forums
http://ubuntuforums.org/showthread.php?t=376483

Linux Display Driver - x86
http://www.nvidia.com/object/linux_disp ... 69.12.html
User avatar
grimdestripador
Level 6
Level 6
 
Posts: 1069
Joined: Fri Feb 16, 2007 2:26 am

Re: startx fails

Postby MagnusB on Sat Mar 22, 2008 4:11 am

If you got this working with vesa, how come failsafe didn't work? IIRC that force vesa (VGA=something), and sets an extremely conservative resolution. And isn't failsafe X included in KDE CE? Shouldn't that catch these things?
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: startx fails

Postby grimdestripador on Thu Apr 03, 2008 6:57 pm

failsafe set keeps setting it to nv not vesa.
User avatar
grimdestripador
Level 6
Level 6
 
Posts: 1069
Joined: Fri Feb 16, 2007 2:26 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: sefner, taikara, WoodLark and 15 guests