[SOLVED]Can't log into Gnome mint 13

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

[SOLVED]Can't log into Gnome mint 13

Postby Carl Andersen on Fri Jun 22, 2012 4:48 am

I have installed Linux Mint 13 MATE 32 bit. It worked fine one day, but then suddenly I got this message
"Can't log into Gnome"

My xessions-errors
/etc/mdm/Xsession: Beginning session setup...
localuser:carl being added to access control list
Setting IM through im-switch for locale=da_DK.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
Failed to connect to theI haven't installed kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service


What do I do, I do in order to log into Gnome again? I haven't installed VirtuelBox.

I also have Linux Mint 11 on the same machine, and here there is the same in My xessions-errors But here are there no problems logging in?

My xessions-errors in Mint 11
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=da_DK.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
_IceTransmkdir: ERROR: euid != 0,directory /tmp/.ICE-unix will not be created.
GNOME_KEYRING_CONTROL=/tmp/keyring-ApOyFn
SSH_AUTH_SOCK=/tmp/keyring-ApOyFn/ssh
GNOME_KEYRING_PID=1200
GNOME_KEYRING_CONTROL=/tmp/keyring-ApOyFn
SSH_AUTH_SOCK=/tmp/keyring-ApOyFn/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-ApOyFn
SSH_AUTH_SOCK=/tmp/keyring-ApOyFn/ssh
Backend : gconf
Integration : true
Profile : unity
Adding plugins
Initializing core options...done

And so wider
Last edited by Carl Andersen on Sat Jun 23, 2012 7:21 am, edited 2 times in total.
Carl Andersen
Level 1
Level 1
 
Posts: 8
Joined: Fri Jun 22, 2012 3:31 am

Linux Mint is funded by ads and donations.
 

Re: Can't log into Gnome mint 13

Postby oobetimer on Fri Jun 22, 2012 12:03 pm

Is there any room left on your /home partition? Terminal command df -h tells. You get to the command line by pressing Ctrl Alt F2 and back Ctrl Alt F7 or Ctrl Alt F8.
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Can't log into Gnome mint 13

Postby Carl Andersen on Fri Jun 22, 2012 2:19 pm

Code: Select all
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda7        84G  3,8G   76G   5% /
udev            936M   12K  936M   1% /dev
tmpfs           378M  996K  377M   1% /run
none            5,0M     0  5,0M   0% /run/lock
none            943M   76K  943M   1% /run/shm
Carl Andersen
Level 1
Level 1
 
Posts: 8
Joined: Fri Jun 22, 2012 3:31 am

Re:[SOLVED] Can't log into Gnome mint 13

Postby Carl Andersen on Sat Jun 23, 2012 7:18 am

I made a reinstall, and now everything seems fine.
Carl Andersen
Level 1
Level 1
 
Posts: 8
Joined: Fri Jun 22, 2012 3:31 am

Re: [SOLVED]Can't log into Gnome mint 13

Postby manoelsslima on Thu Jul 05, 2012 1:27 am

Please, anybody has another way to solve the problem? Reinstall is not a good idea for me...

Thanks in advance
manoelsslima
Level 1
Level 1
 
Posts: 1
Joined: Thu Jul 05, 2012 1:24 am

Re: [SOLVED]Can't log into Gnome mint 13

Postby samjam on Thu Jul 12, 2012 4:46 am

I solved it by purging all packages that had "virtualbox" in the name AND by explicitly selecting MATE as my session instead of "last session"

I don't know why that kast step was needed as I didn't have any other sessions enabled anyway.

I also reversed some changes I ahd recently made in vmware and removed the extended keyboard support
samjam
Level 1
Level 1
 
Posts: 16
Joined: Wed Nov 09, 2011 5:41 am

Re: [SOLVED]Can't log into Gnome mint 13

Postby oobetimer on Thu Jul 12, 2012 7:56 am

samjam wrote:selecting MATE as my session instead of "last session"

Some reason Mint offers ubuntu-session by default, and many computers simply do not work with ubuntu-session. I think that MATE-session should be default, so that many tears and anger would be avoided .. :lol:
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: [SOLVED]Can't log into Gnome mint 13

Postby drrob on Thu Oct 18, 2012 7:28 am

I just had to explicitly select MATE as my session instead of "last session" and it worked.

Thanks for this.
drrob
Level 1
Level 1
 
Posts: 1
Joined: Thu Oct 18, 2012 7:24 am

Re: [SOLVED]Can't log into Gnome mint 13

Postby seier on Mon Jan 27, 2014 4:59 am

samjam wrote:I solved it by purging all packages that had "virtualbox" in the name AND by explicitly selecting MATE as my session instead of "last session"


Yay that worked for me too.

Thanks,
Christian Blackburn
seier
Level 1
Level 1
 
Posts: 6
Joined: Wed Oct 10, 2012 2:12 am

Re: [SOLVED]Can't log into Gnome mint 13

Postby otacon14112 on Thu Apr 17, 2014 8:48 pm

For those of you who can't log into "GNOME" (Mate) in Linux Mint, I would like to share "a" solution to this seemingly-ambiguous problem. I've read so many topics on the 'net about this same issue. I've scanned so many lines of ~/.xsession-errors, that I have learned that there are many possible causes for this problem. I read solutions that worked for other people, such as removing .ICEauthority and .Xauthority, but that didn't work for me, because .Xauthority didn't exist in my home directory because the desktop manager kept crashing whenever I tried to log in, which is why I'm posting this solution, and I couldn't change sessions, because I didn't use a real login window as a login window. I used a wallpaper. I could click on the hostname and time/date, which would bring up the dialog box to shutdown/restart the computer, etc., but there was nothing to click on to change sessions. That single simple thing caused this whole problem for me lol.

When I'm showing commands here, I used tty1 (Ctrl+Alt+F1) to log in.

My own .xsession-errors file contained
Code: Select all
/etc/mdm/Xsession: Beginning session setup...
localuser:shredder being added to access control list
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service

I cannot figure out what happened, or what I did last night to have caused this problem, but here is how I fixed it for my scenario.

First of all, I typed:
Code: Select all
sudo apt-get purge virtualbox virtualbox-dkms virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 virtualbox-qt

You can see if you have other VirtualBox packages or not, by hitting tab twice. I then went into my regular user's home directory and deleted (here is where I forget what it was actually named) the VirtualBox directory by typing:
Code: Select all
rm -r Virtualbox
rm -r .Virtualbox
The case for v or b may be different, because I don't remember. In hindsight, I should have typed everything I did into a textfile, so I could paste it here in order to help others, but I was too concerned about just getting my computer back up and running again because I had to log into my company's website to check my work schedule, and I didn't remember what my password is because I have it saved. Fortunately, however, I remember virtually everything else I did that made actual changes.

I restarted, and by purging all of the VirtualBox software (and maybe or maybe not removing the said directories from my home directory actually making a difference - who knows?), I no longer got any lines about not being able to connect to VirtualBox, however, I still had:
Code: Select all
/etc/mdm/Xsession: Beginning session setup...
localuser:shredder being added to access control list
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
in my ~/.xsession-errors file.

I tried other marginal stuff that changed nothing, so I won't even waste time typing about it. However, I did type this:
Code: Select all
sudo apt-get purge mdm
That removed the (Mate) GNOME Desktop Manager.

After I executed that command, it said there were two other packages remaining that were no longer needed, and now I can't remember what they were, but it doesn't matter. What I did at that point was this:
Code: Select all
sudo apt-get autoremove mdm
and it got rid of the other two packages. I then restarted the computer.

Now, when my computer booted back up, I was greeted with the bash shell login. I logged in, then reinstalled mdm:
Code: Select all
sudo apt-get install mdm
I then restarted the computer.

When it booted back up, I was greeted with the default Linux Mint 13 MATE login window. I logged in, still not confident that everything was OK, because I had so many other crashes after I logged in. Sure enough, I was not finished yet, because I received the familiar text:
Code: Select all
/etc/mdm/Xsession: Beginning session setup...
localuser:shredder being added to access control list
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.

When I was taken back to the login screen I chose MATE as my desktop manager. It worked! I had my computer back to normal, except for my missing X-Files-style LinuX login window, but that's marginal. I then logged out, and chose the last session and when a dialog box asked me what I wanted to do, I clicked the button to make it my default desktop manager.

I contemplated making a new topic because this one is marked as "SOLVED", but there's no need for redundancy, so I'm posting this here.

I hope this helps at least one person, because that means it was worth my time to post this.
otacon14112
Level 1
Level 1
 
Posts: 3
Joined: Sun Apr 21, 2013 11:43 pm

Re: [SOLVED]Can't log into Gnome mint 13

Postby theUnderhillAccount on Sat Aug 02, 2014 6:56 pm

@ otacon14112

Thanks...it helped. I'm using the KDE desktop, and, after installing nemo, I had this same problem on reboot. Instead of trying everything you listed, I just used the last portion of your solution and removed and re-installed mdm...worked like a charm--simple and easy. Thanks.
theUnderhillAccount
Level 1
Level 1
 
Posts: 1
Joined: Sat Aug 02, 2014 6:50 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 15 guests