SOLVED - Linux Mint 13 UEFI boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

SOLVED - Linux Mint 13 UEFI boot

Postby powerhouse on Sat Jul 14, 2012 2:57 pm

I've installed Linux Mint 13 Maya 64 bit via USB stick (in UEFI mode!!!), but when rebooting I get the following message:

Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key

Here is what I did:

1. Boot USB stick from boot menu in UEFI mode.
2. Install lvm2 and grub-efi (the latter uninstalls grub-pc and some other gfx... packet
3. Using gparted, I wiped my SSD and created a gpt partition table on the SSD (/dev/sda)
4. Using gparted, I created and formatted /dev/sda1 as EFI system partition flagged "boot", size 100MB, mounted as /boot/efi; /dev/sda2 as ext2, size 500MB, mounted as /boot; the rest of the SSD was assigned to /dev/sda3, unformatted, marked "LVM"
5. pvcreate /dev/sda3 to create a physical LVM volume using /dev/sda3
6. vgcreate to create vol1 on /dev/sda3
7. lvcreate to create the following Linux partitions in vol1: / (root) formatted to ext4; /home formatted to ext4
8. I ran the Linux Mint installer and assigned and formatted the following partitions: /dev/mapper/vol1-root using ext4 mounted at /; /dev/sda2 using ext2 mounted at /boot; /dev/mapper/vol1-home using ext4 mounted at /home; and selected as boot device /dev/sda
9. After the installer finished successfully, I went into a terminal shell to mount the installed system and chroot to /mnt (after mounting dev), then mounted /proc etc. as described in the "Installing LVM and encryption on LMDE" (or so) thread here in the forum
10. I installed lvm2 and then grub-efi
11. Ran grub-update and grub-install
12. Rebooted

I checked the grub.cfg file and the /boot/efi/EFI/linuxmint directory and all looks OK. The grub.cfg contains a modprobe lvm at the beginning (but not in the subsections - is this OK?). I also checked the /etc/fstab file to see that all the partitions are properly listed.

In the past I managed to install Linux Mint directly on disk, i.e. not using LVM. At other times I tried to install Linux on LVM (except /boot and /boot/efi) and got a grub prompt ( I then had hardware problems - my memory was faulty).

I also checked the BIOS setup to make sure that EFI boot was enabled/preferred. When booting, I selected the "linuxmint:...." option which seems to be the UEFI option.

I know this is not the conventional way of installing Linux Mint, but I was hoping to make it work. All files seem to be in place and I can boot the USB stick and access the partitions on the SSD. I'm sure it's my mistake, can someone point me into the right direction?

P.S.: For those who've followed my other posts on UEFI boot, bleeding edge hardware issues, or preferred Linux Mint distribution, I've finally solved the memory issue by replacing my memory. It has been tested successfully under Windows 7 using Prime95, Aida64, as well as using the memtest86+ v4.2 bootable USB stick and a hardware-based RST memory and stress test system. So I believe I'm finally in the possession of a functional PC hardware.

EDIT: I've solved the issue. Instructions on how to install Linux Mint 13 on LVM volumes and booting it using UEFI (EFI) can be found further down here: http://forums.linuxmint.com/viewtopic.php?f=46&t=107620#p608123.
Last edited by powerhouse on Tue Apr 02, 2013 5:48 am, edited 2 times in total.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 13 UEFI boot - not detecting grub - please he

Postby powerhouse on Sun Jul 15, 2012 5:45 am

Here the output of gdisk /dev/sda:

Code: Select all
Command (? for help): p
Disk /dev/sda: 234441648 sectors, 111.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): C202F681-9D00-4362-BCD2-E45D486B7004
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 234441614
Partitions will be aligned on 2048-sector boundaries
Total free space is 2925 sectors (1.4 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          206847   100.0 MiB   EF00 
   2          206848         1230847   500.0 MiB   0700 
   3         1230848       234440703   111.2 GiB   8E00 

Command (? for help): i
Partition number (1-3): 1
Partition GUID code: C12A7328-F81F-11D2-BA4B-00A0C93EC93B (EFI System)
Partition unique GUID: FF76D986-B50B-4D6B-A3C3-9B97372582A9
First sector: 2048 (at 1024.0 KiB)
Last sector: 206847 (at 101.0 MiB)
Partition size: 204800 sectors (100.0 MiB)
Attribute flags: 0000000000000000
Partition name: ''

Command (? for help): i
Partition number (1-3): 2
Partition GUID code: EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 (Microsoft basic data)
Partition unique GUID: 4331F60A-48E4-4530-8071-8A1237BD0545
First sector: 206848 (at 101.0 MiB)
Last sector: 1230847 (at 601.0 MiB)
Partition size: 1024000 sectors (500.0 MiB)
Attribute flags: 0000000000000000
Partition name: ''

Command (? for help): i
Partition number (1-3): 3
Partition GUID code: E6D6D379-F507-44C2-A23C-238F2A3DF928 (Linux LVM)
Partition unique GUID: 0049FE4F-BC9E-42C1-BB04-CBD0E7EA5EBE
First sector: 1230848 (at 601.0 MiB)
Last sector: 234440703 (at 111.8 GiB)
Partition size: 233209856 sectors (111.2 GiB)
Attribute flags: 0000000000000000
Partition name: ''


Partition 2 (/dev/sda2) should be a Linux ext2 partition, but it says here "Microsoft basic data" or code 0700 ?

I need to check / change that.

EDIT: Changed the code to "8300" using gdisk - makes no difference.

EDIT2:

Here the output of efibootmgr -v (from a life USB stick):

Code: Select all
mint ~ # efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0000,0003,0002
Boot0000* linuxmint   HD(1,800,32000,ff76d986-b50b-4d6b-a3c3-9b97372582a9)File(\EFI\linuxmint\grubx64.efi)
Boot0002* Hard Drive    BIOS(2,0,00)AMGOAMNO........o.S.a.n.D.i.s.k. .S.D.S.S.D.X.1.2.0.G.G.2.5....................A...........................>..Gd-.;.A..MQ..L.2.1.5.0.1.4.0.4.0.0.8.4. . . . . . . . ......AMBOAMNO........o.W.D.C. .W.D.2.0.E.A.R.X.-.0.0.P.A.S.B.0....................A...........................>..Gd-.;.A..MQ..L. . . . .W. .-.D.M.W.Z.A.7.A.5.6.4.2.5.9......AMBOAMNO........s.S.3.1.B.0.7.1.2.U.S.B. .D.I.S.K. .1.1.0.0....................A.............................@..Gd-.;.A..MQ..L.S.3.1.B.0.7.1.2.U.S.B. .D.I.S.K. .1.1.0.0......AMBO
Boot0003* UEFI: S31B0712USB DISK 1100   ACPI(a0341d0,0)PCI(1c,2)PCI(0,0)USB(4,0)HD(1,3e,1ef802,00083562)AMBO


For some reason, linuxmint is not listed as UEFI, though it contains the \EFI\linuxmint\grubx64.efi bootloader and is an "EFI system" marked disk.
Boot0002 is the SSD (/dev/sda) - this isn't bootable as I don't have an MBR.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint 13 UEFI boot - not detecting grub - please he

Postby srs5694 on Sun Jul 15, 2012 12:18 pm

Your NVRAM entries look OK -- or at least, the Boot0000 entry looks OK, and that's the one that matters. My suspicion is that there's something flaky about your EFI implementation that's causing it to fail. A lot of manufacturers have released very buggy EFIs that have only been tested with Windows, and it could be that yours isn't working the way it should. Alternatively, there could be some subtle error in the setup that I've missed.

I recommend you try to work around this by renaming EFI/linuxmint/ on the ESP to EFI/boot/ and rename the grubx64.efi file it contains to bootx64.efi. This will rename everything to the default boot name, which means that it should launch without an entry in the NVRAM. The drawback is that if you upgrade GRUB, the upgrade won't "take." Alternatively, you could install rEFInd as EFI/boot/bootx64.efi, as described on its Web page. Once it's running, rEFInd doesn't refer to the NVRAM variables; instead, it scans common locations for boot loaders, so it should detect your GRUB configuration.

Oh, and don't worry about the 0700 value for /dev/sda2. This is the partition type code for a Windows partition, which the GNU Parted people improperly use for Linux partitions. This is an unimportant detail on a Linux-only installation. Changing it to 8300 with gdisk will keep Windows from interpreting the partition as an uninitialized partition, but the Linux kernel and most Linux programs don't care about this. Note that gdisk presents partition type codes as stored in the GPT, which are distinct from the filesystems actually contained in partitions.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Linux Mint 13 UEFI boot - not detecting grub - please he

Postby powerhouse on Sun Jul 15, 2012 12:37 pm

I installed rEFInd and edited the refind.conf file to load the /boot/efi/EFI/linuxmint/grubx64.efi loader. I get the same message on boot indicating that there is no bootable media.

I'm at the end of my wits with UEFI.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint 13 UEFI boot - not detecting grub - please he

Postby powerhouse on Sun Jul 15, 2012 12:52 pm

Hello Rod,

Thanks for your reply, which I haven't seen earlier and in the meantime posted on your thread as well as here.

I'm not on my PC now but I think I tried your suggestion re renaming to /boot/efi/EFI/boot/bootx64.efi. I need to check when I get back.

I also tried it with rEFInd but get the same result.

I changed the refind.conf file to have an entry pointing to the linuxmint/grubx64.efi file.

If I remember correctly rEFInd is able to scan the available boot loaders. How do I enable that? Or is it automatic?

In any case, with rEFInd installed I got the same message.

If I remember correctly you have the same motherboard (Asus Sabertooth X79). I'm running Bios version 1203 (the latest one). Since I managed to boot into UEFI using the older bios 1104 I was wondering if this could be the culprit?
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint 13 UEFI boot - not detecting grub - please he

Postby powerhouse on Sun Jul 15, 2012 1:53 pm

Update:

I booted my PC into BIOS - all UEFI boot loaders are marked as "UEFI" in the Asus EZ mode menu. So somehow the motherboard BIOS recognizes the loaders but when booting I get the

Code: Select all
Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key


message.

Now I'm really confused.

I was hoping that at least rEFInd would load. But it doesn't - same message as for all loaders.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint 13 UEFI boot - not detecting grub - please he

Postby powerhouse on Mon Jul 16, 2012 8:55 am

Ok, I took a Fedora 17 beta DVD that I had prepared 2-3 months ago and gave it a try. The DVD was formatted to boot in UEFI mode.

Anyway, Fedora installed and boots from SSD, I even installed it using LVM for / and /home.

There are numerous other problems/bugs with Fedora (I didn't get the "firstboot" screen and can't get it back :x ).

This just proofs that UEFI boot works, so does LVM - unfortunately under Fedora.

Any ideas why LM doesn't work?
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint 13 UEFI boot - not detecting grub - please he

Postby powerhouse on Thu Jul 19, 2012 8:25 am

The following describes the installation of LM13 Maya 64 bit with LVM to boot via UEFI.

Caution - this procedure destroys all data on your target drive (/dev/sda in this example) !!!

Note: I've tried several different approaches that ultimately failed and didn't boot. Then I found this http://www.matrix44.net/blog/?p=1155 blog which describes the UEFI installation for Linux Mint 13 and Ubuntu 12.04. Unfortunately I didn't take notes during the successful install.

These instructions cover 2 different issues:

1. UEFI boot;
2. Installing Linux Mint on LVM volumes.

If you only want to boot your PC using UEFI (EFI), then use another how-to, for example the one linked above, or http://forums.linuxmint.com/viewtopic.php?f=42&t=121912 or http://forums.linuxmint.com/viewtopic.php?f=46&t=97221.



Prerequisites: You need an UEFI-bootable live USB stick with LM13 64 bit installed on it. I prepared this some time ago with unetbootin (I believe), but you can find instructions on the Internet. The stick should contain an /efi directory.

When booting the USB stick, press F8 (on Asus MB) to enter the BIOS boot menu and select the "UEFI: ...USB..." option (the one pointing to the UEFI USB stick - it will identify your USB stick). The USB stick will appear twice in the menu - once with UEFI prefix, the other time without.

Here is what I did:

    1. Boot LM13 from USB stick using the UEFI option in the BIOS boot menu
    2. Open a terminal window and install gdisk and lvm2 packages:
    Code: Select all
    sudo -i

    Code: Select all
    apt-get install gdisk lvm2

    3. Check your devices using
    Code: Select all
    fdisk -l

    and make sure to choose the correct drive in the next step!
    4. This step wipes your disk clean !!! So backup everything you need. Let's assume you install to /dev/sda:
    Code: Select all
    gdisk /dev/sda

    Now we create a GPT partition table:
      Command (? for help): o
      This option deletes all partitions and creates a new protective MBR.
      Proceed? (Y/N): y
    For use with an SSD, we set the partition alignment to 4096:
      Command (? for help): x

      Expert command (? for help): l
      Enter the sector alignment value (1-65536, default = 2048): 4096
    And return to the gdisk main menu:
      Expert command (? for help): m

    Create a 256 MB partition on /dev/sda1 for /boot/efi:
      Command (? for help): n
      Partition number (1-128, default 1):
      First sector (34-7856094, default = 34) or {+-}size{KMGTP}:
      Last sector (34-7856094, default = 7856094) or {+-}size{KMGTP}: 256M
      Current type is 'Linux filesystem'
      Hex code or GUID (L to show codes, Enter = 8300): ef00
      Changed type of partition to 'EFI System'

    Create a /boot partition on /dev/sda2 (1024 MB is more than enough):
      Command (? for help): n
      Partition number (2-128, default 2):
      First sector (524289-7856094, default = 524289) or {+-}size{KMGTP}:
      Information: Moved requested sector from 524289 to 524290 in
      order to align on 2-sector boundaries.
      Use 'l' on the experts' menu to adjust alignment
      Last sector (524290-7856094, default = 7856094) or {+-}size{KMGTP}: +1G
      Current type is 'Linux filesystem'
      Hex code or GUID (L to show codes, Enter = 8300):
      Changed type of partition to 'Linux filesystem'

    The following step is specifically for setting up / (root) and /home in a "logical volume" using LVM. If you want to use regular / and /home partitions, set them up like in the previous step (code: 8300 for Linux).
    The following command prepares the rest of the disk to be used with LVM:
      Command (? for help): n
      Partition number (3-128, default 3):
      First sector (524289-7856094, default = 729090) or {+-}size{KMGTP}:
      Last sector (729090-7856094, default = 7856094) or {+-}size{KMGTP}:
      Current type is 'Linux filesystem'
      Hex code or GUID (L to show codes, Enter = 8300): 8e00
      Changed type of partition to 'Linux LVM'

    Now we write the changes to disk:
      Command (? for help): w

      Final checks complete. About to write GPT data. THIS WILL OVERWRITE EXISTING
      PARTITIONS!!

      Do you want to proceed? (Y/N): y
      OK; writing new GUID partition table (GPT).
      Warning: The kernel is still using the old partition table.
      The new table will be used at the next reboot.
      The operation has completed successfully.

    We create a physical volume on /dev/sda3:
    Code: Select all
    pvcreate /dev/sda3


    Now we create a volume group named "lm13" on /dev/sda3:
    Code: Select all
    vgcreate lm13 /dev/sda3


    a logical volume called "root", size 15 GB, in volume group "lm13":
    Code: Select all
    lvcreate -L 15G -n root lm13


    a logical volume called "swap", size 5 GB, in volume group "lm13" - NOTE: you can also install the swap partition on a different drive (if you don't like having it on an SSD, for example):
    Code: Select all
    lvcreate -L 5G -n swap lm13


    and a logical volume called "home", size 35 GB, in volume group "lm13":
    Code: Select all
    lvcreate -L 35G -n home lm13


    We need to format the LVs else the installer won't recognize them. First check that the "virtual partitions" (LVs) have been created:
    Code: Select all
    ls /dev/mapper

    The output should look something like:
      control lm13-home lm13-root lm13-swap

    Let's create the file systems for the newly created logical volumes:
    Code: Select all
    mkfs -t ext4 /dev/mapper/lm13-root

    Code: Select all
    mkfs -t ext4 /dev/mapper/lm13-home

    Code: Select all
    mkswap /dev/mapper/lm13-swap


    Continued on next post...

Last edited by powerhouse on Tue Apr 02, 2013 6:01 am, edited 7 times in total.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint 13 UEFI boot - not detecting grub - please he

Postby powerhouse on Thu Jul 19, 2012 8:34 am

Caution: This procedure needs to be verified - see previous post !!!

Continued from previous post:

    5. Make sure you have a working Internet connection!

    Now run the Linux Mint 13 installer.

    In the partitioner, select "something else" - DON'T use the preselected option!

    Image

    You will then get something like this:
    Image

    Press "Change" to edit the /dev/mapper/lm13-home partition:
    Image

    Do the same for the /dev/mapper/lm13-root partition and assign it to /.

    Now edit the /dev/sda1 partition and select "EFI boot partition":
    Image

    And change the /dev/sda2 as follows:
    Image

    After you assigned all partitions you should get something like this:
    Image

    Make sure that "Device for bootloader installation:" at the bottom reads "/dev/sda" !

    Check that everything is OK and press "Install Now".

    6. After the installer finishes, DON'T reboot !!!

    Go back to the terminal and enter:
    Code: Select all
    mount /dev/mapper/lm13-root /mnt

    Code: Select all
    mount /dev/mapper/lm13-home /mnt/home

    Code: Select all
    mount /dev/sda2 /mnt/boot

    Code: Select all
    mount -t vfat /dev/sda1 /mnt/boot/efi


    7. Mount the /dev file system to /mnt/dev and chroot to the installed system:
    Code: Select all
    mount --bind /dev /mnt/dev

    Code: Select all
    chroot /mnt

    Root is now the / on your new system. We must mount the special file systems:
    Code: Select all
    mount -t sysfs none /sys

    Code: Select all
    mount -t proc none /proc

    Code: Select all
    mount -t devpts none /dev/pts


    8. Now we update the packages and install lvm2 onto the installed system (our previous lvm2 install didn't update the initram file since the USB disk is read only):
    Code: Select all
    apt-get update

    Code: Select all
    apt-get install lvm2

    Enter "y" when asked "Do you want to continue?"

    9. Let's check the UEFI boot entries we have:
    Code: Select all
    efibootmgr -v

    Note: efibootmgr is automatically installed with grub-efi during the system installation.
    This is the critical part with regard to UEFI boot. Different motherboards / systems may require different procedures here. Any feedback on this part is most welcome!

    The output should look something like this:
      BootCurrent: 0002
      Timeout: 1 seconds
      BootOrder: 0000,0001,0002
      Boot0000* CD/DVD Drive BIOS(3,0,00)AMGOAMNO........o.H.L.-.D.T.-.S.T. .D.V.D.R.A.M. .G.H.2.2.N.S.7.0....................A...........................>..Gd-.;.A..MQ..L.2.K.B.E.J.7.4.A.5.5. .9. . . . . . . . ......AMBO
      Boot0001* Hard Drive BIOS(2,0,00)AMGOAMNO........o.S.a.n.D.i.s.k. .S.D.S.S.D.X.1.2.0.G.G.2.5....................A...........................>..Gd-.;.A..MQ..L.2.1.5.0.1.4.0.4.0.0.8.4. . . . . . . . ......AMBOAMNO........o.W.D.C. .W.D.2.0.E.A.R.X.-.0.0.P.A.S.B.0....................A...........................>..Gd-.;.A..MQ..L. . . . .W. .-.D.M.W.Z.A.7.A.5.6.4.2.5.9......AMBOAMNO........s.S.3.1.B.0.7.1.2.U.S.B. .D.I.S.K. .1.1.0.0....................A.............................@..Gd-.;.A..MQ..L.S.3.1.B.0.7.1.2.U.S.B. .D.I.S.K. .1.1.0.0......AMBOAMNO........o.W.D.C. .W.D.2.0.E.A.R.X.-.0.0.P.A.S.B.0....................A...........................>..Gd-.;.A..MQ..L. . . . .W. .-.D.M.W.Z.A.9.A.4.0.5.9.2.8......AMBO
      Boot0002* UEFI: S31B0712USB DISK 1100 ACPI(a0341d0,0)PCI(1c,2)PCI(0,0)USB(4,0)HD(1,3e,1ef802,00083562)AMBO

    Now we update the UEFI boot list:
    Code: Select all
    efibootmgr --create --label 'Linux MINT 13' --loader \\EFI\\linuxmint\\grubx64.efi


    The output is something like this:
      BootCurrent: 0002
      Timeout: 1 seconds
      BootOrder: 0003,0000,0001,0002
      Boot0000* CD/DVD Drive
      Boot0001* Hard Drive
      Boot0002* UEFI: S31B0712USB DISK 1100
      Boot0003* Linux MINT 13

    10. Let's check the partitions and file systems:
    Code: Select all
    blkid

    The output should look similar to that:
      /dev/loop0: TYPE="squashfs"
      /dev/sda1: UUID="915E-D6FC" TYPE="vfat"
      /dev/sda2: UUID="bef3dfcf-eda3-4f36-bca5-3b3da8d11b84" TYPE="ext2"
      /dev/sda3: UUID="olwatC-fcdl-atIX-m4a7-suCY-uoXo-bjhfJd" TYPE="LVM2_member"
      /dev/sdc1: LABEL="LM13" UUID="D4B7-1DAB" TYPE="vfat"
      /dev/mapper/lm13-home: UUID="079228e8-a467-4cfc-9bb1-66586a5c7f39" TYPE="ext4"
      /dev/mapper/lm13-root: UUID="862e50e7-6683-4da9-b7ed-c4dc77b3ebad" TYPE="ext4"
      /dev/mapper/lm13-swap: UUID="045c015c-75a9-4561-b747-1db9f6a9d1b5" TYPE="swap"
      /dev/dm-5: UUID="045c015c-75a9-4561-b747-1db9f6a9d1b5" TYPE="swap"

    Edit the /etc/fstab file with you favorite editor, for example:
    Code: Select all
    pluma /etc/fstab

    The file should look like this:
      # /etc/fstab: static file system information.
      #
      # Use 'blkid' to print the universally unique identifier for a
      # device; this may be used with UUID= as a more robust way to name devices
      # that works even if disks are added and removed. See fstab(5).
      #
      # <file system> <mount point> <type> <options> <dump> <pass>
      proc /proc proc nodev,noexec,nosuid 0 0
      /dev/mapper/lm13-root / ext4 errors=remount-ro 0 1
      # /boot was on /dev/sda2 during installation
      UUID=f7281e5f-9e67-4492-bf55-cd9b014af5f0 /boot ext2 defaults 0 2
      # /boot/efi was on /dev/sda1 during installation
      UUID=9417-4215 /boot/efi vfat defaults 0 1
      /dev/mapper/lm13-home /home ext4 defaults 0 2
      /dev/mapper/lm13-swap none swap sw 0 0

    Compare the fstab file with the output of blkid and pay attention to the /dev/sda1 UUID. Mine was different from the blkid output so I replaced the UUID=... with /dev/sda1:
    Code: Select all
    /dev/sda1  /boot/efi       vfat    defaults        0       1


    Make changes if necessary and save.

    11. Now we umount the installed system and exit chroot:
    Code: Select all
    umount /dev/pts

    Code: Select all
    umount /proc

    Code: Select all
    umount /sys

    exit chroot:
    Code: Select all
    exit   # exits chroot

    Code: Select all
    umount /mnt/dev

    Code: Select all
    umount /mnt/home

    Code: Select all
    umount /mnt/boot/efi

    Code: Select all
    umount /mnt/boot

    Code: Select all
    umount /mnt

    Code: Select all
    sync   # write all changes to disk (just to be safe)


    12. Now comes the moment of truth - reboot the system.

If you have used these instructions, please report the results, and/or any modifications to the above steps.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: SOLVED - Linux Mint 13 UEFI boot

Postby williamdemeo on Sat Sep 15, 2012 10:51 pm

Thanks for all the info. I tried this procedure on my newly built machine, but it failed at the command pvcreate /dev/sda3.
williamdemeo
Level 1
Level 1
 
Posts: 1
Joined: Sat Sep 15, 2012 10:37 pm

Re: SOLVED - Linux Mint 13 UEFI boot

Postby powerhouse on Sun Sep 16, 2012 3:13 am

williamdemeo wrote:Thanks for all the info. I tried this procedure on my newly built machine, but it failed at the command pvcreate /dev/sda3.


Check that your /dev/sda3 partition is flagged "LVM" under gparted. Or use gdisk.

This should solve the problem.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: SOLVED - Linux Mint 13 UEFI boot

Postby rnaodm on Thu Oct 04, 2012 10:55 pm

Hello just wondering why its so difficult to install linux on computers with uefi Bios? Is there no fix that can be added to the kernel itself, so those of us with new PC's with uefi can install linux? I really love Mint, And was extremely disappointed that after I build my new rig, I could no longer use it.
rnaodm
Level 1
Level 1
 
Posts: 2
Joined: Tue Nov 30, 2010 5:35 pm

Re: SOLVED - Linux Mint 13 UEFI boot

Postby srs5694 on Fri Oct 05, 2012 1:10 pm

rnaodm wrote:Hello just wondering why its so difficult to install linux on computers with uefi Bios? Is there no fix that can be added to the kernel itself, so those of us with new PC's with uefi can install linux? I really love Mint, And was extremely disappointed that after I build my new rig, I could no longer use it.


The problem isn't with the kernel, and it's not fundamentally with any other specific software component (although IMO GRUB 2's EFI support is lousy); the problem is primarily that distribution developers haven't been sufficiently forward-looking over the past couple of years. The result is poor integration between elements and poor support for EFI in the distributions' installation routines. Installing Linux on EFI-based computers can be done, and it's not really that hard if you understand what's going on; but the installers don't make this easy. A secondary problem is that today's EFI implementations are buggy, insufficiently standardized in terms of user interface, and contain legacy BIOS booting support that actually creates more problems than it solves. This leads to a lot of system-specific problems, such as boot loaders that fail on one system but that work on another and boot disks that boot in EFI mode on one system and in BIOS mode on another. This in turn creates issues such as Linux installing in BIOS mode on a system that already boots Windows in EFI mode.

FWIW, IMHO the best distribution right now for EFI installations is Fedora. Fedora does the best job of integrating everything and it's got the fewest glitches. (Still too many, but the fewest.) The current version (17) also uses post-3.3.0 kernels, which gives you more boot loader options. Ubuntu and Mint lag well behind on this score, in part because of their insistence on using the lame GRUB 2 and in part because (as of Ubuntu 12.04 and everything based on it) they still use 3.2.x kernels. (Presumably this will change with Ubuntu 12.10, but I haven't checked the betas.) OpenSUSE is currently in-between and has been improving rapidly. Debian's in bad shape because they've been very slow to add explicit EFI support. It's actually not too bad if you know how to do a BIOS installation and switch over to EFI mode, though.

Give it some time and things will improve. For the moment, though, UEFI users will just have to deal with the fact that they're using a "bleeding edge" component, at least as far as Linux is concerned. FWIW, I've got a Web page on EFI boot loaders for Linux, which covers the available boot loaders and how to deal with them. (I've got to add gummiboot, though.) Understanding the boot loaders will help you immensely, although navigating an installer with poor EFI support requires distribution-specific knowledge on top of that.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: SOLVED - Linux Mint 13 UEFI boot

Postby sluc23 on Mon Oct 08, 2012 9:11 am

great tutorial powerhouse!!!!
It worked like a charm. I didn't know about the existence of this new EFI thing, until I bought a new brand Packard Bell IMEDIA SI47777SP, and tried to install Linux Mint. You can imaging my panic face after the first reboot and the "Operating system not found" message :shock:

Thank you very much for the detailed explanation!!
sluc23
Level 1
Level 1
 
Posts: 1
Joined: Mon Oct 08, 2012 9:03 am

Re: SOLVED - Linux Mint 13 UEFI boot

Postby Skara Brae on Tue Oct 09, 2012 4:11 pm

Well, my old and loyal Athlon64-based computer, whose specs are in my signature, died last week... I got myself a new, Core i5-based machine that is running WinVista. It means I lost my "Maya" install, as well as Xubuntu (and XP Home).

I believe I have the same problem as many, because of that UEFI nonsense. When starting the live-CD, I get a light grey screen with a white blinking cursor and nothing else (when I tried my Xubuntu live disk, first I got a black screen with several weird, coloured lines and then a black screen and a white, blinking cursor).

If I am understanding it correctly, I will lose my existing Vista installation, when trying to install Mint back (or Xubuntu)?
Codename "PUMA": Intel Core i5-3450 // Gigabyte GA-H77-D3H // 1 x 4 GB DDR3-RAM // Gigabyte Geforce GT 630 // WD Caviar Blue 500 GB (S-ATA) // Samsung WriteMaster DVD-rw // Aopen QF50C PC case
--
Registered Linux User #495429
Skara Brae
Level 1
Level 1
 
Posts: 48
Joined: Sat Jun 09, 2012 10:45 am

Re: SOLVED - Linux Mint 13 UEFI boot

Postby srs5694 on Tue Oct 09, 2012 7:53 pm

Skara Brae wrote:I believe I have the same problem as many, because of that UEFI nonsense. When starting the live-CD, I get a light grey screen with a white blinking cursor and nothing else (when I tried my Xubuntu live disk, first I got a black screen with several weird, coloured lines and then a black screen and a white, blinking cursor).


That sounds more like a video driver issue than a firmware/boot issue to me, although it could be that the boot loader isn't handling the video hardware properly. How long does it take you to get to a stable (albeit unusable) screen? The longer the time, the more likely it's an X11 video driver issue.

If I am understanding it correctly, I will lose my existing Vista installation, when trying to install Mint back (or Xubuntu)?


No, Linux can coexist with Windows on a UEFI-based system just as easily as it can on a BIOS-based system. The details are different, though. Of course, on either system, you must be sure to properly resize your Windows partition(s), and there's always the possibility that you'll get this wrong or that a bug in the installer will get it wrong for you.

FWIW, if the computer really is running Vista "out of the box," it seems unlikely that it would be based on UEFI. Vista is pretty old technology by OS standards, and at the time it was current, almost every motherboard used BIOS. Something new enough to use UEFI would probably ship with Windows 7, not Vista. (OTOH, maybe the manufacturer specifically wanted Vista even on newer hardware for some reason.) You can learn which boot mode you're using in Windows by doing the following:

  1. Launch an administrative Command Prompt by right-clicking the Command Prompt item and selecting Run As Administrator from the menu.
  2. In the Command Prompt window, type bcdedit.
  3. Examine the output for a line that begins "path" under the "Windows Boot Loader" section. If this line refers to winload.exe, you've booted in BIOS mode; if it refers to winload.efi, you've booted in UEFI mode.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: SOLVED - Linux Mint 13 UEFI boot

Postby AlbertP on Wed Oct 10, 2012 4:17 am

Windows Vista 64-bit versions with SP1 preinstalled support booting from UEFI. But I agree that it is rare to do so.

Probably your Vista disk is not GPT formatted, so it'll use BIOS boot. Which may cause problems with an SSD that is booting with UEFI.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6515
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: SOLVED - Linux Mint 13 UEFI boot

Postby powerhouse on Sun Oct 14, 2012 3:03 am

rnaodm wrote:Hello just wondering why its so difficult to install linux on computers with uefi Bios? Is there no fix that can be added to the kernel itself, so those of us with new PC's with uefi can install linux? I really love Mint, And was extremely disappointed that after I build my new rig, I could no longer use it.


Have been away for a while.

Many/most systems with UEFI BIOS will be able to boot in legacy (BIOS) mode. Just make sure it's selected in the BIOS menu. HOWEVER, if you want to run Linux alongside a preinstalled Windows 7 etc. OS, chances are that Win7 is already using UEFI boot, in which case you need to install an UEFI boot loader for the Linux OS.

The Windows installation should have the /boot/efi (or \boot\efi or \boot\EFI) folder on the disk (C:).

If, for some reason, you can't get an UEFI bootable Linux partition, you may be able to use rEFInd (see http://www.rodsbooks.com/efi-bootloaders/) and chainload Linux with grub2. rEFInd then points to the grub2 boot loader to start Linux.

If you don't have a preinstalled Windows or don't mind reinstalling it, you could as well wipe the disk and format it to MBR (BIOS) for legacy boot, as long as the BIOS supports this mode. It's a lot easier.

Grub2 version 2.x is supposedly bringing some improvements on UEFI boot.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: SOLVED - Linux Mint 13 UEFI boot

Postby powerhouse on Sun Oct 14, 2012 3:06 am

sluc23 wrote:great tutorial powerhouse!!!!
It worked like a charm. I didn't know about the existence of this new EFI thing, until I bought a new brand Packard Bell IMEDIA SI47777SP, and tried to install Linux Mint. You can imaging my panic face after the first reboot and the "Operating system not found" message :shock:

Thank you very much for the detailed explanation!!


I'm glad it worked! Yeah, I've been there ("OS not found")...
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: SOLVED - Linux Mint 13 UEFI boot

Postby AlbertP on Sun Oct 14, 2012 7:04 am

rnaodm wrote:Hello just wondering why its so difficult to install linux on computers with uefi Bios? Is there no fix that can be added to the kernel itself, so those of us with new PC's with uefi can install linux? I really love Mint, And was extremely disappointed that after I build my new rig, I could no longer use it.

In short, the problem is that every computer manufacturer does UEFI differently. Many implementations have trouble dual-booting, or booting systems that aren't called Windows or aren't from Microsoft. Not everybody is keeping to the UEFI specifications; Sony Vaio for example have some of their computers hardcoded to boot straight into Windows and ignore normal UEFI bootloaders.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6515
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Linux Mint is funded by ads and donations.
 
Next

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 10 guests