HAL boot error

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

HAL boot error

Postby lone_rocker on Thu Apr 17, 2008 8:45 pm

I'm having a very strange problem.
The story... I was going to shut off the laptop, and before that I tried to unmount the external USB hard drive, as usual. A dialog box appeared with an error, but with no text, just an icon of error. Didn't give it much importance, and turned the laptop off in the normal way.
When I started it again, it got stuck when booting, at this part:

(starting some stuff ) [OK]
Starting Hardware abstraction layer hald .....

After a while it continued, but when I logged in, the USB devices wouldn't mount, and there was no network devices. So, I guess it has something to do with HAL.
At the grub, if th recovery mode is selected, it makes a normal boot, but after the logging in a graphic mode, it's the same thing with the hardware: there's no USB and no network.
Searching on Google I read that (in the cases I found) the problem was related with visudo, or with sudo permissions; in other it happened after building the kernel or doing an update. I have done none of these things. The only sudo thing I did before this problem was to install wine and dosbox (I removed those, just in case, but I'm sure it's not related). Therefor, I just can't understand what caused the problem, and less how to solve it.

....it all was going just so fine..... it's a shame.
lone_rocker
Level 1
Level 1
 
Posts: 5
Joined: Sun Mar 16, 2008 4:05 pm

Linux Mint is funded by ads and donations.
 

Re: HAL boot error

Postby atlef on Fri Apr 18, 2008 2:28 am

This is happening to me to. Need to run: sudo hald --daemon=no, then removable drives and media in startmenu just to get my stick to show. This happened after the last update.
Not sure if there are easier ways to do this, as I have not had the time to investigate further then posting confirming a bug found on launchpad.
I will look more into this during the weekend. Or maybe someone else knows how to fix this.

atlef.
User avatar
atlef
Level 4
Level 4
 
Posts: 306
Joined: Sun Nov 18, 2007 8:20 am
Location: Stavanger NORWAY


Return to Installation & Boot

Who is online

Users browsing this forum: BoDill, lostfarmer, ragez0r and 24 guests