Unable to get a splash screen in Cinnamon

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Unable to get a splash screen in Cinnamon

Postby dclement on Tue Oct 23, 2012 8:21 am

Hello,

My daughter's brand new laptop proudly runs LM13 Cinnamon, but I'd like her to get a nice splash screen instead of that "frightening" dark...

I know the suggested workaround (sudo update-alternatives --config default.plymouth), I even ran sudo update-initramfs -u thereafter, but no luck.

Yet I could check (with hwinfo) that the native screen resolution (1366x768) is fully supported in principle.

Thanks a lot for any help - best regards,

Daniel
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Linux Mint is funded by ads and donations.
 

Re: Unable to get a splash screen in Cinnamon

Postby bigj231 on Tue Oct 23, 2012 10:14 am

What graphics chip does she have installed? Run lspci and look for a line that says something like:
Code: Select all
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
I know that I had problems when trying to run it on an AMD/ATI chipset. I had it working for about a week before the screen died.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Unable to get a splash screen in Cinnamon

Postby dclement on Tue Oct 23, 2012 11:41 am

Thanks for replying so quickly. I should have been more specific about the hardware: the laptop is a Dell Latitude E6330 with Intel HD4000 graphics.

The output of lspci is exactly the same as in your post.

bigj231 wrote:I had it working for about a week before the screen died.

Well the first par is encouraging... I hope the last part has noting to do with it!
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Unable to get a splash screen in Cinnamon

Postby Alpha-Geek on Tue Oct 23, 2012 11:19 pm

You could install "Grub Customizer" http://grub-customizer.en.uptodown.com/ubuntu Use it to display any .png as a background image during boot.
Image
User avatar
Alpha-Geek
Level 4
Level 4
 
Posts: 311
Joined: Sun Aug 19, 2007 12:29 am
Location: Wisconsin, USA

Re: Unable to get a splash screen in Cinnamon

Postby dclement on Wed Oct 24, 2012 5:32 am

Hmm... that looks nice, but from the home page:
Requirements:
Repository: ppa:danielrichter2007/grub-customizer
Architecture: i386
I wonder if it would install on an AMD64 setup. I'll try, though, and report ASAP.

Another thought, just FWIW: could there be a slight problem with just the Mint theme for Plymouth?
I got Plymouth working on my own system (LMDE XFCE), but with the "Solar" theme. I think I remember the Mint theme wouldn't work. But this was some time ago.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Unable to get a splash screen in Cinnamon

Postby dclement on Wed Oct 24, 2012 11:51 am

Well the page I was looking at was not very up to date.

I managed to find an AMD64 version. I wish I hadn't! The result was terrible, the system refusing to boot...

Fortunately everything useful was backed up! It seems to me that Grub-customizer is a very dangerous program; I'm saying goodbye to it.

So I'm back to my original problem...
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Unable to get a splash screen in Cinnamon

Postby eMcE on Sun Nov 04, 2012 6:35 am

Grub customizer is ok, but only if framebuffer and vesafb modes are working fine with your gfx-card.
Most of the problems with plymouth are, because framebuffer implementation (support), and hence vesafb modes, are "nonstandard" (are screwed) in gfx-hardware.
Miłość i prawda rządzą :] a hipokrytom chooy w tylny exit :]
Image
User avatar
eMcE
Level 3
Level 3
 
Posts: 109
Joined: Tue Oct 30, 2012 9:53 am
Location: Czołg.. Gdzieś na pustyni..

Re: Unable to get a splash screen in Cinnamon

Postby dclement on Mon Nov 05, 2012 11:00 am

Well I think this card is among those that have problems with framebuffer / vesafb.

Maybe I should try something else? E.g., what about usplash? I know nothing about it, but I've come across it, I think, while searching for splash themes.

Is there a better chance that it would run find with Intel HD4000 graphics?
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Unable to get a splash screen in Cinnamon

Postby eMcE on Mon Nov 05, 2012 5:46 pm

Ok, a bit different..

Solar theme or any complex theme = problems, beceause uvesafb don't use acceleration and have some limitations.
From documentation:
uvesafb is a _generic_ driver which supports a wide variety of video cards, but which is ultimately limited by the Video BIOS interface. The most important limitations are:
- Lack of any type of acceleration.
- A strict and limited set of supported video modes. Often the native or most optimal resolution/refresh rate for your setup will not work with uvesafb, simply because the Video BIOS doesn’t support the video mode you want to use. This can be especially painful with widescreen panels, where native video modes don’t have the 4:3 aspect ratio, which is what most BIOS-es are limited to.
- Adjusting the refresh rate is only possible with a VBE 3.0 compliant Video BIOS. Note that many nVidia Video BIOS-es claim to be VBE 3.0 compliant, while they simply ignore any refresh rate settings.

Also, uvesafb replaces vesafb in Mint/Ubuntu, in case you are wondering.

Symptoms:
Plymouth splash screen…
- is in low res mode.
- has corrupted graphic
- is decent but can’t switch to virtual terminal or VT is horribly in low res mode
- is decent but the splash screen only appears for a brief 1-2 second (you are missing the dots moving :P ), before that you only see a black/blank screen

Environment
Use Synaptic or ‘apt-cache policy ‘ or common-sense to find out.
- GRUB >= 1.98
- Plymouth >= 0.8.2-2
- ATI cards with FGLRX >= 8.723.1-0ubuntu3
- NVIDIA cards with nvidia-glx-1*
- A clean without other tweaks to plymouth & grub, please revert them before proceeding.
Really, it will not work if you insisted on apply other tweaks. ! IMPORTANT !
- Common-sense and google searching skill
- A bit of risk taking spirit and confidence


Ok.. Now the fix - try it for yourself - but at own risk
--
* uvesafb required v86d package to be installed.
Hwinfo package is required for the next step as well.
Code: Select all
sudo apt-get install v86d hwinfo


* Find out the supported resolution by using hwinfo.
Code: Select all
sudo hwinfo --framebuffer


Sample output:
Code: Select all
02: None 00.0: 11001 VESA Framebuffer
[Created at bios.464]
...
Hardware Class: framebuffer
Model: "(C) 1988-2005, ATI Technologies Inc. M92"
Vendor: "(C) 1988-2005, ATI Technologies Inc. "
Device: "M92"
SubVendor: "ATI ATOMBIOS"
...
Mode 0x0321: 640x480 (+2560), 24 bits
Mode 0x0322: 800x600 (+3200), 24 bits
Mode 0x0323: 1024x768 (+4096), 24 bits
Mode 0x03ee: 1366x768 (+1408), 8 bits
Mode 0x03ef: 1366x768 (+2752), 16 bits
Mode 0x03f0: 1366x768 (+5504), 24 bits
Config Status: cfg=new, avail=yes, need=no, active=unknown


* Edit: /etc/default/grub to make sure we boot with uvesafb framebuffer.
For the mode_option parameter change to your native screen resolution you see from running the above comment (if not just set to 1024×768-24 which is safest.
Netbook user - please exercise some common-sense here) Non relevant lines are omitted for clarity.

Code: Select all
...
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1366x768-24,mtrr=3,scroll=ywrap"
...
GRUB_GFXMODE=1366x768


* Edit /etc/initramfs-tools/modules to include uvesafb by adding the following line.
Code: Select all
uvesafb mode_option=1366x768-24 mtrr=3 scroll=ywrap


* Force the use of framebuffer:
Code: Select all
echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash


* Update and we are done :)

Code: Select all
sudo update-grub2
sudo update-initramfs -u


* Now reboot and enjoy the high resolution sensation :) (my first reboot hangs, but 2nd time onward it works flawlessly).
If it works correctly, you should be able to have moving dots with the splash screen; lesser time of blank screen and much more time with splash screen.

* And contrary to popular belief, your laptop should resume and suspend normal with uvesafb! :)
* Thing you probably will see in dmesg if succeed:

Code: Select all
[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-here_version-generic-pae
root=UUID=your_uuid_number ro quiet splash nomodeset
video=uvesafb:mode_option=1366x768-24,mtrr=3,scroll=ywrap
[ 6.684235] uvesafb: (C) 1988-2005, ATI Technologies Inc. , M92, 01.00, OEM: ATI ATOMBIOS, VBE v3.0
[ 6.783693] uvesafb: protected mode interface info at c000:a2d4
[ 6.783695] uvesafb: pmi: set display start = c00ca376, set palette = c00ca434
[ 6.783727] uvesafb: VBIOS/hardware supports DDC2 transfers
[ 6.845060] uvesafb: monitor limits: vf = 61 Hz, hf = 48 kHz, clk = 69 MHz
[ 6.845110] uvesafb: scrolling: ywrap using protected mode interface, yres_virtual=1536
[ 6.847159] uvesafb: framebuffer at 0xc0000000, mapped to 0xf8380000, using 8256k, total 16384k
[ 6.854259] uvesafb: mode switch failed (eax=0x34f, err=0). Trying again with default timings.


Other Alternative
* No splash screen but high resolution virutal terminal using EFI framebuffer.
Edit /etc/default/grub, remove ‘splash’ option and replace the two entries below with your native resolution.
Seriously, this is way better than setting the payload to keep and in 00_header.
GRUB_GFXPAYLOAD_LINUX is only available from grub 1.98.

Code: Select all
...
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
...
GRUB_GFXMODE=1366x768
GRUB_GFXPAYLOAD_LINUX=1366x768
...


*Or use "Zorin Splash Screen Manager":
http://www.webupd8.org/2010/10/install- ... es-in.html

Thats all ;)
Source:
http://git.kernel.org/?p=linux/kernel/g ... vesafb.txt
Miłość i prawda rządzą :] a hipokrytom chooy w tylny exit :]
Image
User avatar
eMcE
Level 3
Level 3
 
Posts: 109
Joined: Tue Oct 30, 2012 9:53 am
Location: Czołg.. Gdzieś na pustyni..

Re: Unable to get a splash screen in Cinnamon

Postby dclement on Tue Nov 06, 2012 5:08 am

Thank you, eMcE, for your detailed reply. I knew the v86d - framebuffer - ... path --indeed I used it successfully on my own laptop (which is a bit different: Nvidia graphics / LMDE). However...
eMcE wrote:Solar theme or any complex theme = problems
Strangely, Solar theme worked in my case while none of the Mint themes did.

Now back to my daughter's PC:
- ATI cards with FGLRX >= 8.723.1-0ubuntu3
- NVIDIA cards with nvidia-glx-1*
So I thought this fix would not work on her Intel HD4000 system. Well I tried it all the same, with no luck. But yet I still have to try a non-Mint theme.

*Or use "Zorin Splash Screen Manager":
http://www.webupd8.org/2010/10/install- ... es-in.html
This is interesting, it does not look to be Nvidia- or ATI-specific. I'll give it a try and report.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Unable to get a splash screen in Cinnamon

Postby eMcE on Tue Nov 06, 2012 5:42 am

Changing plymouth theme is like playing roulette.
One works, the other does not.
Just try. Maybe something hopefully works on this HD4000. :)

On one of my computers I have somethink like this:
Image

And nothing helps.
Fortunately I see this mess only a few seconds :lol:
This is machine with old Nvidia FX5200 card.
3D works great, but bootscreen.. eeehh.. :P
Miłość i prawda rządzą :] a hipokrytom chooy w tylny exit :]
Image
User avatar
eMcE
Level 3
Level 3
 
Posts: 109
Joined: Tue Oct 30, 2012 9:53 am
Location: Czołg.. Gdzieś na pustyni..

Re: Unable to get a splash screen in Cinnamon

Postby dclement on Wed Nov 07, 2012 12:06 pm

Some progresses here:

1) Zorin splash manager is really convenient for selecting and changing theme. Ended up with mint-logo theme (that good old legacy theme with the dots). Alas it only flashes for a fraction of a second just before the GDM window.

2) After that I tried to install v86d, edit /etc/default/grub, /etc/initramfs-tools/modules etc. (like I did on my main laptop with the Nvidia card). Not only did it improve nothing, but it had a weird side effect: the Cinnamon interface was sort of locked to the classic way (toolbars above and below like early Ubuntu), whatever settings I chose. The only way to recover was to cancel all the previous steps.

Now, back to my mint-logo flash, I'm looking for a way perhaps less radical or Nvidia- or ATI-specific to force it to appear earlier in the boot process.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Unable to get a splash screen in Cinnamon

Postby eMcE on Wed Nov 07, 2012 1:53 pm

Ad.1.
Zorin is ok, when all other fix don't work.
A few seconds is not a problem if You don't restart your computer often :mrgreen:

Ad.2.
Stay with Zorin.
If "v86d_fix" don't work for You - this means (most likley) that your gfx-card is from this "happy_incompatible_group" ;)

Ps. And use only one fix at one time.
Miłość i prawda rządzą :] a hipokrytom chooy w tylny exit :]
Image
User avatar
eMcE
Level 3
Level 3
 
Posts: 109
Joined: Tue Oct 30, 2012 9:53 am
Location: Czołg.. Gdzieś na pustyni..

Re: Unable to get a splash screen in Cinnamon

Postby dclement on Thu Nov 08, 2012 4:42 am

Still, I managed to improve.

Following comment #2 in bug 540801, I added "FRAMEBUFFER=y" to /etc/initramfs-tools/conf.d/splash.

Now the Mint logo pops up much earlier (though not instantly) in the boot sequence, making the boot process more "reassuring" for a newbie.

This worked without v86d installed.

No Mint logo upon shutdown though, but the shutdown is very quick.

Still a couple of things to try, but I doubt I can get a much better result.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Unable to get a splash screen in Cinnamon

Postby eMcE on Thu Nov 08, 2012 5:15 pm

That is reason, why I gave it a rest ;)
It is not worth the trouble.
Miłość i prawda rządzą :] a hipokrytom chooy w tylny exit :]
Image
User avatar
eMcE
Level 3
Level 3
 
Posts: 109
Joined: Tue Oct 30, 2012 9:53 am
Location: Czołg.. Gdzieś na pustyni..

Re: Unable to get a splash screen in Cinnamon

Postby everready on Thu Nov 08, 2012 7:19 pm

In earlier mint you had two themes in the repository name "Plymouth Theme Mint Logo" and "Plymouth Theme Mint Text" when they were installed together you had your splash but alas i was working on a way to import that part of the repository into Mint 13 Maya when i got weak and reverted to an earlier version Mint 9 Isadora all for the sake of a splash screen.. So you have to ask yourself this question, Is It Worth It, Well Is It.. :lol:

Thanks..
everready
User avatar
everready
Level 3
Level 3
 
Posts: 133
Joined: Fri Jan 27, 2012 6:37 am
Location: In His Service

Re: Unable to get a splash screen in Cinnamon

Postby eMcE on Fri Nov 09, 2012 9:45 am

Maybe devs will improve/fix this in Mint 14 ;)
Miłość i prawda rządzą :] a hipokrytom chooy w tylny exit :]
Image
User avatar
eMcE
Level 3
Level 3
 
Posts: 109
Joined: Tue Oct 30, 2012 9:53 am
Location: Czołg.. Gdzieś na pustyni..

Re: Unable to get a splash screen in Cinnamon

Postby bigj231 on Wed Nov 14, 2012 6:08 pm

Those themes were installed on my system by default. I just had to switch to using them. I'm currently using a modified mint-logo theme. I just replaced 2 pictures and made it grey.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 14 guests