Num Lock on startup <SOLVED>

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Num Lock on startup <SOLVED>

Postby gimme4 on Thu Nov 01, 2012 5:55 am

Hi everyone, I'm not sure this post is in the right place but I'm sure that it will be moved if it isn't.
I am running mint 13 mate with compiz, My problem is that when i boot my laptop up the num lock light comes on ( enabled in bios ), but as soon as mint gets hold of the system the light goes off, My login password is all numbers and it is so much easier to use the number pad, is there any way to get the num lock to be enabled so that I can enter my password easily, please remember that I am a NOOB so step by step instructions would be appreciated.

Many Thanks..
Last edited by gimme4 on Fri Nov 02, 2012 4:14 am, edited 1 time in total.
gimme4
Level 1
Level 1
 
Posts: 27
Joined: Thu Feb 21, 2008 12:49 pm

Linux Mint is funded by ads and donations.
 

Re: Num Lock on startup

Postby remoulder on Thu Nov 01, 2012 10:52 am

In a terminal
Code: Select all
apt install numlockx
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Num Lock on startup

Postby killer de bug on Thu Nov 01, 2012 10:53 am

That's a well known problem !

First you need to install "numlockx" using synaptic.

Then open a terminal & type :

Code: Select all
gksudo gedit /etc/mdm/Init/Default


after typing your password, a file will be opened in Gedit. Add these lines at the beginning of the file.

Code: Select all
if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi


Edit : add these lines after the commented lines at the beginning of the file (the ones starting with #)
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1807
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: Num Lock on startup <SOLVED>

Postby gimme4 on Fri Nov 02, 2012 4:13 am

Thank you very much guys, that worked a treat, the only problem was that Gedit was not my default editor for some reason, I had to install Gedit but after that all worked well, I have marked the post as solved, again many, many thanks..
gimme4
Level 1
Level 1
 
Posts: 27
Joined: Thu Feb 21, 2008 12:49 pm

Re: Num Lock on startup <SOLVED>

Postby killer de bug on Fri Nov 02, 2012 9:00 am

Outchhhhh ! My mistake ! I didn't realize that you were using MATE. Sorry for that.

You could have replaced gedit by pluma in the command line and that would have work like a charm. Sorry for that. You can uninstall gedit now :wink:

Code: Select all
sudo apt-get remove gedit
sudo apt-get autoremove



The last command will remove all the gnome stuff that you don't need and that could have been installed with gedit. :wink:
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1807
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: Num Lock on startup <SOLVED>

Postby rosenhof on Thu Jan 10, 2013 4:06 pm

Hi

I had the same problem as gimme4 and it seems that this is a common issue.
I have fixed this issue on Fedora17 in the past but didn't make any notes of it so I goggled to this tread

I'm just installed LinuxMint 13 Maya / Cinnamon 64-bit with updates for the back ported issues and things are starting to look nice but then I have the num lock issue before logging in.
- Added numlockx with Synaptic
- Edited the Default as killer de bug suggests, no problem

On reboot the Num Lock key lit up and I can enter the login credentials containing numbers without the need to enable Num Lock every time
BUT immediate when I have logged in it is turned off

I'd like to keep it always on since it's a keyboard with separate numerical keypad.
Any ideas?
rosenhof
Level 1
Level 1
 
Posts: 15
Joined: Thu Jan 10, 2013 3:33 am

Re: Num Lock on startup <SOLVED>

Postby rosenhof on Fri Jan 11, 2013 4:12 am

Hi

The strange behaviour that turned off Num Lock immediate after login occurred once, the first time after I applied this (on reboot) but later on during the night it worked perfect so I guess that it was some hiccup the first time and it's not an issue any more.

Thanks for the tips!
rosenhof
Level 1
Level 1
 
Posts: 15
Joined: Thu Jan 10, 2013 3:33 am

Re: Num Lock on startup <SOLVED>

Postby Webtest on Mon Jan 14, 2013 10:53 pm

This post helped me ... I was successful in getting numlockx installed in Mint 8 but I couldn't do it through the Synaptic package manager because all of the repositories are long since dead ...

I won't go into the gory details of how I found everything, but here was the solution:

From: http://archive.ubuntu.com/ubuntu/ubuntu/ubuntu/pool/main/n/numlockx/
I downloaded: numlockx_1.1-10build1_i386.deb to my USB thumb drive at /media/artwork/linux/general
"artwork" is the label of my Thumbdrive, and /linux/general is the path to my working folder.

From a Terminal session:
mint@mint ~ $ sudo -i
mint ~ # dpkg -i /media/artwork/linux/general/numlockx_1.1-10_i386.deb

This installed numlockx thus enabling the on, off, and toggle options for the numlockx command!

Blessings in abundance, all the best, & ENJOY!
Art in Carlisle, PA USA
BOAT - a hole in the water that you pour money into
LINUX - a hole in your life that you pour TIME into

HP dx2400 Core 2 Duo 4 GB - Mint 10 Gnome, Mint 13 Mate, Mint 15 Mate <on LOCKED Kanguru USB drives>
Webtest
Level 3
Level 3
 
Posts: 179
Joined: Sun Feb 21, 2010 4:45 pm
Location: Carlisle, Pennsylvania, USA

Re: Num Lock on startup

Postby Jordi Sayol on Fri Mar 29, 2013 7:51 am

killer de bug wrote:...
Code: Select all
if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi

...


Is there a reason to use the "exec" command on script?

This command exits the script immediately after run "/usr/bin/numlockx on". So, if "/usr/bin/numlockx" exist, nothing else will be executed.
Jordi Sayol
Level 1
Level 1
 
Posts: 3
Joined: Fri Mar 29, 2013 7:25 am

Re: Num Lock on startup <SOLVED>

Postby stilloving on Sat Jun 29, 2013 8:27 am

This method enable numlock during login and after login, so you have the numlock always ON in your LINUX MINT and LMDE

1) FIRST, install numlockx : sudo apt-get install numlockx

2) SECOND, go to menu and type startup application and opent it.

3) Click on +add

4) On "Name" put NUMLOCK ON

5) On "Command" put /usr/bin/numlockx on

6) Click on "+add" and "close" .


7) Go to /etc/mdm/Init/ and edit Default

8) Add before exit 0 these lines:

if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi


Just restart your computer and next time you turn on it you have Numlock On always.


Stilloving from Argentina, Buenos Aires
stilloving
Level 1
Level 1
 
Posts: 5
Joined: Sat Jun 29, 2013 7:52 am

Re: Num Lock on startup <SOLVED>

Postby Blackout STi on Thu Jul 31, 2014 2:14 am

stilloving wrote:This method enable numlock during login and after login, so you have the numlock always ON in your LINUX MINT and LMDE

1) FIRST, install numlockx : sudo apt-get install numlockx

2) SECOND, go to menu and type startup application and opent it.

3) Click on +add

4) On "Name" put NUMLOCK ON

5) On "Command" put /usr/bin/numlockx on

6) Click on "+add" and "close" .


7) Go to /etc/mdm/Init/ and edit Default

8) Add before exit 0 these lines:

if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi


Just restart your computer and next time you turn on it you have Numlock On always.


Stilloving from Argentina, Buenos Aires


This worked for me. Thanks!
ASUS F1A75V-EVO / AMD A8-3870 / ASUS Radeon HD 7870 GHz Edition V2 / 12GB RAM
128GB Samsung SSD 840 PRO / 1TB HDD
Linux Mint 17 / Virtualbox (Windows 7 Pro)
User avatar
Blackout STi
Level 1
Level 1
 
Posts: 21
Joined: Tue Jul 22, 2014 12:53 am
Location: Happy Valley, OR

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Daniella and 21 guests