LiveCD's Xorg "no usable configuration" error with EeePC

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

LiveCD's Xorg "no usable configuration" error with EeePC

Postby theLo on Sat Dec 01, 2012 8:15 pm

Hi everybody,

I'm an Asus eeepc X101CH owner, on it I used linux mint 13 with XFCE without problems, but mint 14 with MATE causes troubles with Xorg.
Even thought with the liveCD I had no problems at all, after the installation Xorg fails booting. It's the not-so-uncommon error "Screen(s) found, but none have a usable configuration".

So I tried to fix it googling around. Tried updating. Tried sudo X -configure, copy and startx. Tried sudo apt-get remove and then install. Tried to make a Xvesa xorg.conf configuration using the xvesa settings that was working with Parted Magic. No success.
By the way, I noticed that even Parted Magic cannot launch Xorg, but i had to use the pure vesa settings.

My installation method was through usb: first I've just prepared myself the usb pen; then I thought it was my fault and I tried with Unetbootin and ImageWriter each time installing from zero. Still no success.

***EDIT1: the command "X -configure" says that the number of the created screens does not match the number of detected devices. Checked "/usr/X11/xorg.conf.d/10-evdev.." and found no monitor settings. Is this relevant?

***EDIT2: downloaded the new iso avalaible called "14.1" and tried installing through USB: Xorg didnt start even in the live cd session. Changed title.

Code: Select all
[    22.652]
X.Org X Server 1.13.0
Release Date: 2012-09-05
[    22.653] X Protocol Version 11, Revision 0
[    22.653] Build Operating System: Linux 3.2.0-26-generic i686 Ubuntu
[    22.653] Current Operating System: Linux thelo-X101CH 3.5.0-19-generic #30-Ubuntu SMP Tue Nov 13 17:49:53 UTC 2012 i686
[    22.653] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.5.0-19-generic root=UUID=8106621c-b4cc-4938-a87e-83d56c00f437 ro quiet splash vt.handoff=7
[    22.653] Build Date: 08 October 2012  03:34:08PM
[    22.653] xorg-server 2:1.13.0-0ubuntu6 (For technical support please see http://www.ubuntu.com/support)
[    22.653] Current version of pixman: 0.26.0
[    22.653]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    22.653] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    22.653] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec  2 06:54:09 2012
[    22.654] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    22.655] (==) No Layout section.  Using the first Screen section.
[    22.655] (==) No screen section available. Using defaults.
[    22.655] (**) |-->Screen "Default Screen Section" (0)
[    22.655] (**) |   |-->Monitor "<default monitor>"
[    22.655] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    22.655] (==) Automatically adding devices
[    22.655] (==) Automatically enabling devices
[    22.655] (==) Automatically adding GPU devices
[    22.655] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    22.655]    Entry deleted from font path.
[    22.655] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    22.655]    Entry deleted from font path.
[    22.655] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    22.656]    Entry deleted from font path.
[    22.656] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    22.656]    Entry deleted from font path.
[    22.656] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    22.656]    Entry deleted from font path.
[    22.656] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    22.656]    Entry deleted from font path.
[    22.656] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   built-ins
[    22.656] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    22.656] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    22.656] (II) Loader magic: 0xb7753640
[    22.656] (II) Module ABI versions:
[    22.656]    X.Org ANSI C Emulation: 0.4
[    22.656]    X.Org Video Driver: 13.0
[    22.656]    X.Org XInput driver : 18.0
[    22.656]    X.Org Server Extension : 7.0
[    22.657] (II) config/udev: Adding drm device (/dev/dri/card0)
[    22.664] (--) PCI:*(0:0:2:0) 8086:0be1:1043:84a9 rev 9, Mem @ 0xdfc00000/1048576, I/O @ 0x0000f0e0/8
[    22.665] (II) Open ACPI successful (/var/run/acpid.socket)
[    22.665] Initializing built-in extension Generic Event Extension
[    22.665] Initializing built-in extension SHAPE
[    22.665] Initializing built-in extension MIT-SHM
[    22.665] Initializing built-in extension XInputExtension
[    22.665] Initializing built-in extension XTEST
[    22.665] Initializing built-in extension BIG-REQUESTS
[    22.665] Initializing built-in extension SYNC
[    22.665] Initializing built-in extension XKEYBOARD
[    22.665] Initializing built-in extension XC-MISC
[    22.665] Initializing built-in extension SECURITY
[    22.665] Initializing built-in extension XINERAMA
[    22.665] Initializing built-in extension XFIXES
[    22.665] Initializing built-in extension RENDER
[    22.665] Initializing built-in extension RANDR
[    22.665] Initializing built-in extension COMPOSITE
[    22.665] Initializing built-in extension DAMAGE
[    22.665] Initializing built-in extension MIT-SCREEN-SAVER
[    22.665] Initializing built-in extension DOUBLE-BUFFER
[    22.666] Initializing built-in extension RECORD
[    22.666] Initializing built-in extension DPMS
[    22.666] Initializing built-in extension X-Resource
[    22.666] Initializing built-in extension XVideo
[    22.666] Initializing built-in extension XVideo-MotionCompensation
[    22.666] Initializing built-in extension XFree86-VidModeExtension
[    22.666] Initializing built-in extension XFree86-DGA
[    22.666] Initializing built-in extension XFree86-DRI
[    22.666] Initializing built-in extension DRI2
[    22.666] (II) LoadModule: "glx"
[    22.667] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    22.667] (II) Module glx: vendor="X.Org Foundation"
[    22.667]    compiled for 1.13.0, module version = 1.0.0
[    22.667]    ABI class: X.Org Server Extension, version 7.0
[    22.667] (==) AIGLX enabled
[    22.668] Loading extension GLX
[    22.668] (==) Matched intel as autoconfigured driver 0
[    22.668] (==) Matched intel as autoconfigured driver 1
[    22.668] (==) Matched vesa as autoconfigured driver 2
[    22.668] (==) Matched modesetting as autoconfigured driver 3
[    22.668] (==) Matched fbdev as autoconfigured driver 4
[    22.668] (==) Assigned the driver to the xf86ConfigLayout
[    22.668] (II) LoadModule: "intel"
[    22.672] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    22.673] (II) Module intel: vendor="X.Org Foundation"
[    22.673]    compiled for 1.13.0, module version = 2.20.9
[    22.673]    Module class: X.Org Video Driver
[    22.673]    ABI class: X.Org Video Driver, version 13.0
[    22.673] (II) LoadModule: "vesa"
[    22.674] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    22.674] (II) Module vesa: vendor="X.Org Foundation"
[    22.674]    compiled for 1.12.99.902, module version = 2.3.2
[    22.674]    Module class: X.Org Video Driver
[    22.674]    ABI class: X.Org Video Driver, version 13.0
[    22.674] (II) LoadModule: "modesetting"
[    22.674] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    22.675] (II) Module modesetting: vendor="X.Org Foundation"
[    22.675]    compiled for 1.13.0, module version = 0.5.0
[    22.675]    Module class: X.Org Video Driver
[    22.675]    ABI class: X.Org Video Driver, version 13.0
[    22.675] (II) LoadModule: "fbdev"
[    22.675] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    22.675] (II) Module fbdev: vendor="X.Org Foundation"
[    22.675]    compiled for 1.12.99.902, module version = 0.4.3
[    22.675]    Module class: X.Org Video Driver
[    22.675]    ABI class: X.Org Video Driver, version 13.0
[    22.676] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
   Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
   Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
   Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
   Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
   Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
   Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
   Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
   Haswell Server (GT2+), Haswell SDV Desktop (GT1),
   Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
   Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
   Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
   Haswell SDV Server (GT2), Haswell SDV Server (GT2+),
   Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
   Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
   Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
   Haswell ULT Server (GT1), Haswell ULT Server (GT2),
   Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
   Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
   Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
   Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
   Haswell CRW Server (GT2), Haswell CRW Server (GT2+),
   ValleyView PO board
[    22.678] (II) VESA: driver for VESA chipsets: vesa
[    22.678] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    22.678] (II) FBDEV: driver for framebuffer: fbdev
[    22.678] (++) using VT number 7

[    22.686] (II) intel(0): using device path '/dev/dri/card0'
[    22.686] (WW) Falling back to old probe method for vesa
[    22.686] (WW) Falling back to old probe method for modesetting
[    22.686] (WW) Falling back to old probe method for fbdev
[    22.686] (II) Loading sub module "fbdevhw"
[    22.686] (II) LoadModule: "fbdevhw"
[    22.687] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    22.687] (II) Module fbdevhw: vendor="X.Org Foundation"
[    22.687]    compiled for 1.13.0, module version = 0.0.2
[    22.687]    ABI class: X.Org Video Driver, version 13.0
[    22.688] (EE) intel(0): [drm] Failed to detect GEM.  Kernel 2.6.28 required.
[    22.688] (EE) intel(0): Failed to become DRM master.
[    22.688] (II) UnloadModule: "intel"
[    22.688] (EE) Screen(s) found, but none have a usable configuration.
[    22.688]
Fatal server error:
[    22.688] no screens found
[    22.688] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    22.688] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    22.688] (EE)
[    22.704] Server terminated with error (1). Closing log file.
theLo
Level 1
Level 1
 
Posts: 8
Joined: Sat Dec 01, 2012 7:43 pm
Location: Milan, Italia

Linux Mint is funded by ads and donations.
 

Re: LiveCD's Xorg "no usable configuration" error with EeePC

Postby mank_in on Sun Dec 02, 2012 7:46 am

this is a known bug. ubuntu 12.10 (LM14 parent) refuse to boot with intel GMA 3600 system.
LM 14 ISO has a bug to force intel graphic use software rendering ( gallium llvmpipe ) , but installed LM14 use mesa DRI renderer. If you can force to use software rendering from boot menu , maybe your system will boot normally.
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: LiveCD's Xorg "no usable configuration" error with EeePC

Postby theLo on Mon Dec 03, 2012 1:32 am

Thanks for the answer. I tried using i915.modeset=0 and it makes xorg failing and avoiding me to reach the command line. I'm not sure how to do it. May you help me?

I noticed that Xorg fails also in puppy precise. Maybe I shall try to install again Xorg. Or use Xvesa, if it is possible.
Anyway, the LM iso "14" (not the 14.1) had NO problem launching Xorg in the live environment; the "no usable configurations" problem appeared only after the installation. On the contrary, using the iso 14.1 the problem appears since the beginning, since booting the livecd.
theLo
Level 1
Level 1
 
Posts: 8
Joined: Sat Dec 01, 2012 7:43 pm
Location: Milan, Italia

Re: LiveCD's Xorg "no usable configuration" error with EeePC

Postby mank_in on Mon Dec 03, 2012 7:14 am

I didn't know if recovery mode works, try boot to recovery mode. If GUI not launch , try :
Code: Select all
startx


try add ppa:xorg-edgers/ppa
I read in ubuntu forum , someone success boot to 12.10

I think you better stick with LM13 for your netbook until solution come.
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 19 guests