Dual Monitors - MDM on the wrong display

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Dual Monitors - MDM on the wrong display

Postby bowens44 on Sat Dec 01, 2012 8:45 pm

I finally have dual monitors work almost perfectly on LM 13. The only Issue that I have left is that the log in screen is on the wrong monitor.
I have googled this extensively but haven't found a solution that works fro me.

I created an xorg.conf with nvidia-settings and this resolved all of the other issues I was having.# nvidia-settings: X configuration file generated by nvidia-settings
Code: Select all
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 310.14  (buildd@komainu)  Tue Oct 16 22:20:47 UTC 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc PA248"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 560 Ti"
EndSection

Section "Screen"

# Removed Option "nvidiaXineramaInfoOrder" "DFP-0"
# Removed Option "metamodes" "DFP-2: nvidia-auto-select +0+0, DFP-0: nvidia-auto-select +1920+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "DFP-0: nvidia-auto-select +1920+0, DFP-2: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection



Has anyone else experiencing this found a working solution?

Thanks
bowens44
Level 1
Level 1
 
Posts: 17
Joined: Sat Nov 05, 2011 4:19 pm

Linux Mint is funded by ads and donations.
 

Re: Dual Monitors - MDM on the wrong display

Postby bowens44 on Sun Dec 02, 2012 8:40 pm

I have uninstalled MDM and installed GDM.

With GDM I can get the login screen on the correct screen by installing xwit and then adding xwit -root -warp 1940 500 to /etc/gdm/init/default.

I would prefer to use MDM but the login on the wrong screen is a big problem. Is there something similar I can do in MDM to force the login to my primary monitor?

I tried adding the command to the default script in /etc/mdm/init/ but it didn't change anything.
bowens44
Level 1
Level 1
 
Posts: 17
Joined: Sat Nov 05, 2011 4:19 pm


Return to Installation & Boot

Who is online

Users browsing this forum: baldrick.777 and 10 guests