grub2 will not boot cds (Win8-Mint14.1)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

grub2 will not boot cds (Win8-Mint14.1)

Postby X-san on Sun Dec 02, 2012 2:33 pm

So I got ticked off at Windows 8 and decided to test out moving to Mint.

I have a Sony laptop with UEFI H2O BIOS. Currently it duel boots Windows 8 Pro x64 and Linux Mint 14.1 x64 with grub2 bootloader.
I did some crazy things (NVIDIA drivers, randomly installing MATE desktop, etc.) and now Mint is pretty effed up, but it still starts (in 680x420).

Anyway, I attempted to boot the live CD to make a fresh install and grub refused to boot from the disk reporting "no such device exists %UID%' (there was the actual UID of the drive). After trying the Windows 8 CD and an Ubuntu Live CD I'm pretty sure this is a software problem. To verify that it was not an EFI issue I booted into Legacy mode and received the same issues.

Now I'm no expert but this seems to me like a driver issue... but what should I do? The OSs boot just fine so I could just let it be; however, if something bad happens and I can't boot a CD I'll be in a pinch.
User avatar
X-san
Level 1
Level 1
 
Posts: 2
Joined: Sun Dec 02, 2012 1:58 pm
Location: Rolla, Missouri; USA

Linux Mint is funded by ads and donations.
 

Re: grub2 will not boot cds (Win8-Mint14.1)

Postby X-san on Mon Dec 03, 2012 2:56 pm

I did alot of things and now it works... no clue what fixed it.
User avatar
X-san
Level 1
Level 1
 
Posts: 2
Joined: Sun Dec 02, 2012 1:58 pm
Location: Rolla, Missouri; USA


Return to Installation & Boot

Who is online

Users browsing this forum: claggan, Google Adsense [Bot] and 21 guests