<Solved> Mint 14 Installation problems: Dell XPS 15Z

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

<Solved> Mint 14 Installation problems: Dell XPS 15Z

Postby cpenticuff on Wed Jan 16, 2013 2:26 am

After having some issues with installing Ubuntu on my Dell XPS 15Z laptop, I decided to give Mint a try on the advice of a friend. Though I have a pretty extensive knowledge of computers in general, I am pretty much a noob when it comes to Linux, so please bear with me. FYI, the installation issues I am having with Mint are basically the same as I was having with Ubuntu.

I did, at one time, have Ubuntu running on this computer through WUBI, so I am aware of a few of the hoops that must be jumped through to make it work, unfortunately I am having little luck with a "true" install. When booting from the Mint Live DVD, I must choose compatibility mode or the boot freezes. All is then well and I am able to begin the install. The install progresses as would be expected until the "configuring hardware" stage. At this point, the install appears to just stop. The system does not freeze. I am able to navigate the menus, run applications, move the installation window around, minimize, maximize, and all that other jazz as well. The progress bar simply halts. I left the installation running for ~3 hours with no change, so I feel fairly confident that the install has truly "stopped" as opposed to simply being very slow. I eventually killed the installation process and shut down the computer as I felt there was nothing else that I could do. On the reboot, chkdsk found quite a few errors but was able to fix them all. There was no grub menu, and after chkdsk finished it's magic, Windows booted up fine. I then deleted the partition through Windows and made the preparations for a second attempt.

Attempt #2
Things progressed exactly the same as before. I am unfamiliar with what happens behind the scenes with the Mint installation, so I was hoping that perhaps all system files were installed before the installation halted and that it would be possible to get into the OS and "clean things up." Since there was no Grub menu, I assume it was not installed. I used the instructions found here to get Grub up and running. https://help.ubuntu.com/community/Boot-Repair

I now get a Grub menu with Mint as an option. If I choose the "regular" Mint boot option, I immediately get a black screen with a solid, i.e., not flashing, cursor in the top left corner. At that point the system is frozen. In order to get past this, I use the instructions here https://wiki.ubuntu.com/HardwareSupport/Machines/Laptops/Dell/XPS/15z while selecting the "advanced" Mint boot. What this amounts to, is hitting "e" to get into the extra options and adding "acpi_backlight=vendor dell_laptop.backlight=0" then selecting boot.

I then get the Mint boot animation. It is not frozen, and the dot continues to move along until I get tired of it and use the power button to kill the system. If I hit a key while this animation is going on, I get the following display. https://www.dropbox.com/s/t7k47uv4ydkzkzb/2013-01-16%2001.10.42.jpg

By hitting keys repeatedly, I can see that these few lines repeat indefinitely until I get tired of watching them.

A few things to note:
I am attempting to install the 64 bit version of Mint 14.
The laptop has a few oddities (as can be seen in the link above). There are both dedicated and integrated video cards. I am also unsure of how the hybrid drive plays into this as well...
I am able to connect to my wireless network during the install.

I am curious what my options are now and would love some input from those more knowledgeable than myself regarding this OS. Just let me know what to try or what additional information I can get for you.

Edit: Forgot to mention that I'm installing the "cinnamon rendition" of Mint.

Edit2: Solution
Due to Mint not starting with the "regular" settings, I was starting the Mint LIve DVD under compatibility mode. After adding
Code: Select all
acpi_backlight=vendor dell_laptop.backlight=0
to the boot options of the "regular" mode, I was able to successfully install. I then had to add that same line to the Grub boot options in able to be able to boot Mint.
Level 1
Level 1
Posts: 1
Joined: Wed Jan 16, 2013 1:29 am

Linux Mint is funded by ads and donations.

Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot] and 12 guests