Samsung convoluted dual boot for Windows 8 and Mint 14

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Samsung convoluted dual boot for Windows 8 and Mint 14

Postby tom_byrne on Sun Jan 20, 2013 11:50 am

Hi,

I managed to get Mint 14 running from disk on my NP550P7-S05UK laptop (details below) however the boot procedure is rather convoluted.

I disabled Fast Boot and Secure Boot to install from DVD however after a reboot, instead of the grub loader I get a message to select suitable media and re-boot. (I think all this is "secure-boot-dysfunctionality").

I can boot to Windows 8 by resetting the original BIOS settings however I noticed that with Secure Boot off I can interupt a boot using F4 (recovery).

I then cancel the recovery and select restart and then get the grub loader.

Although this allows me to run Mint from disk it is a tad awkward (sarcastic understatement).

I'd be interested to hear if anyone has experienced this or has suggestions/solutions?

I believe Ubunto have a 64b distro that supports Secure Boot but I would prefer to use Mint if at all possible.

Regards
Tom


System: Host: tom-550P5C-550P7C Kernel: 3.5.0-17-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: System: SAMSUNG product: 550P5C/550P7C version: P03ABI
Mobo: SAMSUNG model: SAMSUNG_NP1234567890 version: SEC_SW__1234567890ABCD
Bios: American Megatrends version: P03ABI.005.120927.dg date: 09/27/2012
CPU: Quad core Intel Core i7-3630QM CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz 3: 1200.00 MHz 4: 1200.00 MHz 5: 1200.00 MHz 6: 1200.00 MHz 7: 1200.00 MHz 8: 1200.00 MHz
Graphics: Card-1: Intel 3rd Gen Core processor Graphics Controller
Card-2: NVIDIA GK107 [GeForce GT 650M]
X.Org: 1.13.0 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1600x900@60.1hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 9.0
Audio: Card: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network: Card-1: Intel Centrino Advanced-N 6235 driver: iwlwifi
IF: wlan0 state: up mac: c4:85:08:f0:72:dd
Card-2: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
IF: eth0 state: up speed: 100 Mbps duplex: full mac: 50:b7:c3:06:79:a4
Drives: HDD Total Size: 1000.2GB (0.4% used) 1: id: /dev/sda model: ST1000LM024_HN size: 1000.2GB
Partition: ID: / size: 451G used: 3.7G (1%) fs: ext4 ID: swap-1 size: 8.47GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 51.0C mobo: 51.0C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 167 Uptime: 12:41 Memory: 781.6/7873.9MB Client: Shell inxi: 1.8.4
tom_byrne
Level 1
Level 1
 
Posts: 3
Joined: Sun Jan 20, 2013 11:12 am

Linux Mint is funded by ads and donations.
 

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby viking777 on Sun Jan 20, 2013 12:54 pm

Imho, the only chance you have with secure boot is to switch it off for approximately the next two years. Then switch it on again and see if anybody has got it to work by then.

I guess the question is can you boot windows and mint with secure boot switched off permanently in your bios?
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5157
Joined: Mon Dec 01, 2008 11:21 am

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby tom_byrne on Sun Jan 20, 2013 6:46 pm

Yes, that would be acceptable and I suppose Windows 8 requires secure boot to be on, so turning off SB in the BIOS effectively turns off W8

When I think of it, I might prefer to do without W8 rather than go through hoops to get to Mint.

However, I'm not confident that I can scratch the disk and do a full install of Mint - should this be possible?
tom_byrne
Level 1
Level 1
 
Posts: 3
Joined: Sun Jan 20, 2013 11:12 am

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby srs5694 on Sun Jan 20, 2013 7:52 pm

tom_byrne wrote:I managed to get Mint 14 running from disk on my NP550P7-S05UK laptop (details below) however the boot procedure is rather convoluted.


Just to clarify: By "...from disk...", I presume you mean that you've installed Mint so that you can dual-boot, albeit via the convoluted method you describe. If not, please elaborate.

I disabled Fast Boot and Secure Boot to install from DVD however after a reboot, instead of the grub loader I get a message to select suitable media and re-boot. (I think all this is "secure-boot-dysfunctionality").


No, if Secure Boot is disabled, then any problems you're having are unrelated to Secure Boot. I'm not 100% positive, but I suspect that disabling Fast Boot on your computer also enables BIOS-mode (aka legacy-mode or CSM) booting and gives it priority over EFI booting, and you don't have a BIOS-mode boot loader installed, hence the error message. In your situation, you should probably turn Secure Boot off but enable Fast Boot.

I can boot to Windows 8 by resetting the original BIOS settings however I noticed that with Secure Boot off I can interupt a boot using F4 (recovery).

I then cancel the recovery and select restart and then get the grub loader.


Again, I'm not 100% positive, but based on the symptoms you've described, I suspect you've got a broken firmware that insists on booting the Windows boot loader even if something else is set as the default. To test this hypothesis, please enter the following command in Linux:

Code: Select all
sudo efibootmgr -v


This will produce information on the configured boot loaders, plus the order in which they're called ("BootOrder"). If there's no entry for Mint's GRUB (referencing grubx64.efi, IIRC), then my hypothesis could be wrong, and you need to use efibootmgr to add such an entry. If there is an entry for GRUB, though, and if it appears at the head of the BootOrder list, then my hypothesis is correct.

If my hypothesis is correct, there are several possible solutions:

  • Run Ubuntu's Boot Repair tool, which performs some brute-force changes that should get GRUB running as the default. Specifically, it moves/renames the Windows boot loader, installs a copy of GRUB in its place, and reconfigures GRUB to launch Windows via the moved copy of the Windows boot loader. This is likely to be the simplest solution, but it could cause confusion or problems down the road.
  • In Mint, move/rename /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi to another name/location. I recommend pushing it down to /boot/EFI/Microsoft/bootmgfw.efi. Then copy /boot/efi/EFI/linuxmint/grubx64.efi to /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi. With this change in place, GRUB should launch as the default boot loader; but you'll need to adjust your Windows entries in grub.cfg to refer to bootmgfw.efi in its new location. It's possible that update-grub will pick it up automatically, but I'm not sure of that. This procedure is similar in effect to the previous one, but the on-disk changes are a little less extreme and it obviously takes more manual tweaking.
  • In Mint, install my rEFInd boot manager by installing the Debian package. Once that's done, try to reboot. If rEFInd comes up immediately, you're done. If it doesn't come up immediately (which is more likely, given the problem), reboot into Mint in whatever way you can and type "sudo mvrefind.sh /boot/efi/EFI/refind /boot/efi/EFI/Microsoft/Boot". This does something conceptually similar to the previous two fixes, but it sets up rEFInd as the default boot manager rather than GRUB. You can then boot Mint via rEFInd, either bypassing GRUB entirely or using GRUB as an intermediary, as you see fit.

viking777 wrote:Imho, the only chance you have with secure boot is to switch it off for approximately the next two years. Then switch it on again and see if anybody has got it to work by then.


Secure Boot is a nuisance, but it's not as bad as that. Some distributions (Ubuntu 12.10, Fedora 18, and a few more obscure ones to date) work with Secure Boot enabled in its default mode already. Any distribution, including Mint, can be made to work with some extra effort. See my page on the topic for more information. Currently the extra effort required is well outside the comfort zone for less technically-inclined users, but as distributions adopt Secure Boot support, and as the tools improve, that will change. If the Mint developers don't have Secure Boot working with their next release, then they've got their heads buried in the sand.

tom_byrne wrote:I suppose Windows 8 requires secure boot to be on, so turning off SB in the BIOS effectively turns off W8


Why do people think this? It isn't true -- or at least, I've seen numerous reports of people switching off Secure Boot and continuing to be able to boot Windows 8. (I don't have a computer that shipped with Windows 8 with which to test.) Thus, if there is such a requirement, it must apply to only some installations.
srs5694
Level 6
Level 6
 
Posts: 1084
Joined: Mon Feb 27, 2012 1:42 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby tom_byrne on Mon Jan 21, 2013 6:08 pm

..yes, I should have been clearer, I wanted to install Mint on hard disk to create a dual boot Mint and W8 system.

I confirmed your view that W8 can boot with Secure Boot off - I presume I might have made another BIOS setup change (e.g reverting to CMS ) when I originally tried to boot with Secure Boot off.

I tried enabling Fast Boot as you suggested but to no avail. I found that efibootmgr was not present so I loaded it. When I ran efibootmgr -v it complained that it could not get access to some folders.

I noticed that there was no /boot/EFI folder so perhaps what was wrong with the loader was that it was not there?

So I then took your advice and installed Ubuntu's Boot Repair. I think this installed a signed loader. It also advised that the location of the boot loader was too far from the start of the disk.

Now, when I boot with Secure Boot off I get the grub2 menu and can successfully boot to Mint or W8.

However, with Secure Boot on I now get a warning that an invalid signature has been detected.

Thank you, srs5694, for your excellent help with this.
tom_byrne
Level 1
Level 1
 
Posts: 3
Joined: Sun Jan 20, 2013 11:12 am

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby srs5694 on Mon Jan 21, 2013 11:59 pm

tom_byrne wrote:I tried enabling Fast Boot as you suggested but to no avail. I found that efibootmgr was not present so I loaded it. When I ran efibootmgr -v it complained that it could not get access to some folders.


That indicates that either the efivars kernel module wasn't loaded or you were booted in BIOS mode. Typing "sudo modprobe efivars" can fix the former problem, but if it's the latter, you'd need to adjust your boot configuration to boot in EFI mode. Given other things you've posted, I suspect that if you were booting in BIOS mode before, you're not doing so now, so either efibootmgr will now work or it will work after loading the efivars module.

I noticed that there was no /boot/EFI folder so perhaps what was wrong with the loader was that it was not there?


The directory is normally called /boot/efi, not /boot/EFI. (Linux filesystems are case-sensitive, so this distinction is important.) If /boot/efi was not present, that's another clue that the original installation was done in BIOS mode. In an EFI-mode installation, /boot/efi should be present and should function as a mount point for the EFI System Partition (ESP), which is a FAT partition that holds boot loaders and related files.

So I then took your advice and installed Ubuntu's Boot Repair. I think this installed a signed loader. It also advised that the location of the boot loader was too far from the start of the disk.

Now, when I boot with Secure Boot off I get the grub2 menu and can successfully boot to Mint or W8.


This makes me think that you're now booting in EFI mode. If the boot loader it installed is signed, it's signed with Ubuntu's key, which will be useless for booting a Mint kernel.

However, with Secure Boot on I now get a warning that an invalid signature has been detected.


That's because Mint doesn't yet support Secure Boot, which means that Mint's copies of GRUB and the Linux kernel are unsigned and will produce an error message (or just a silent failure) when launched.

If you really want to use Secure Boot, you can do so, but you'll need to jump through some significant extra hoops:

http://www.rodsbooks.com/efi-bootloader ... eboot.html

With any luck this process will get simpler with Mint 15, but I don't really know what the Mint developers are planning on this score. For the moment, it's definitely easier to run with Secure Boot disabled.
srs5694
Level 6
Level 6
 
Posts: 1084
Joined: Mon Feb 27, 2012 1:42 pm

Samsung dual boot Windows 8 and Mint 17, Windows lost

Postby despo on Sat Feb 28, 2015 3:41 pm

After trying to install Linux Mint 17.1 to Samsung notebook (Intel core i5, RAM 64GB, 64bit), I encountered the same problem as Tom. The only way I was able to get the grub loader, was to press F4 for recovery, which would not work anyway, cancel the recovery, and wait a few min until getting the grub loader. However, although selecting Linux Mint OS proceeds alright, when I select Windows OS it gives me a terminal with the message "Reboot and select proper boot device or Insert boot media in selected boot device and press a key." The only way to escape this screen is to shutdown with the power key.

In the partitioning time I made sure I kept all (2) "windows loader" partitions intact, as well as all other very small partitions which were labelled as "unknown". I shrinked the larger partition and formatted about half of it (a 20GB partition for / and the rest for home, as well as an adequate swap partition).

To conclude: no matter whether Fast boot is enabled or disabled, and no matter whether secure boot is enabled or disabled, the only way to get the grub loader is this trick with recovery. Even so, Windows cannot load if selected. Does this mean I have lost Windows?

I know I can simply forget about Windows, and try to reinstall the OS, this probably would let Linux boot and load and run smoothly, but it is a friend's whom I attempted to proselytize to Linux. He is happy with it already, but I would like him to have the option to boot windows if he likes.

Thanks a lot in advance
despo
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 17, 2013 3:30 pm

Re: Samsung dual boot Windows 8 and Mint 17, Windows lost

Postby srs5694 on Sat Feb 28, 2015 5:16 pm

despo wrote:After trying to install Linux Mint 17.1 to Samsung notebook (Intel core i5, RAM 64GB, 64bit), I encountered the same problem as Tom. The only way I was able to get the grub loader, was to press F4 for recovery, which would not work anyway, cancel the recovery, and wait a few min until getting the grub loader.


At this point, the single most important thing to know is: Is the GRUB you're seeing the BIOS-mode or EFI-mode GRUB. My suspicion is the former, but I'm not positive of that....

However, although selecting Linux Mint OS proceeds alright,


Once you're in Linux, look for the /sys/firmware/efi directory. If it's present, you've booted in EFI mode. If it's absent, you've probably booted in BIOS mode.

It's almost always best to install in the same mode as Windows. In the case of a major-brand computer that shipped with Windows 8 or 8.1, that mode is almost certainly EFI mode. If you're booting BIOS-mode GRUB (and thus BIOS-mode Linux), you can install, but you'll need to either manually install an EFI-mode boot loader or jump through extra hoops every time you want to boot.

when I select Windows OS it gives me a terminal with the message "Reboot and select proper boot device or Insert boot media in selected boot device and press a key."


This is the strongest hint that you've booted into BIOS-mode GRUB; with Windows installed in EFI mode, this is the sort of message you'd see if you tried to boot Windows in BIOS mode.

To conclude: no matter whether Fast boot is enabled or disabled, and no matter whether secure boot is enabled or disabled, the only way to get the grub loader is this trick with recovery. Even so, Windows cannot load if selected. Does this mean I have lost Windows?


Your Windows is probably intact, but that's not certain. What happens when you try to boot and do nothing special -- that is, just power it on? Does Windows boot, does GRUB launch, or do you see something else?

Please see my earlier replies in this thread -- in particular, the ones that describe Boot Repair and rEFInd. Chances are one of those approaches will get everything working; however, if you don't already understand it, read up on EFI boot loaders for Linux! Until you understand the difference between BIOS-mode and EFI-mode boot loaders, attempting a repair will be a hit-or-miss process at best, and one where a miss will likely take you tumbling off a cliff.
srs5694
Level 6
Level 6
 
Posts: 1084
Joined: Mon Feb 27, 2012 1:42 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby despo on Sun Mar 22, 2015 4:43 pm

Thank you for the prompt reply. It took me some time to respond, in order to be ready and have read all that you proposed. (And also make a detailed list of the "windows" options that appear in the rEFInd boot loader.)

So I was not booting in EFI mode, as (a) there was no /sys/firmware/efi directory; (b) after I installed efibootmgr, the command efibootmgr
Code: Select all
 $ sudo efibootmgr -r
Couldn't open sysfs or provfs directories for accessing EFI variables
and (c) the command
Code: Select all
 $ sudo modprobe efivars
returned nothing.

As rEFIt was already in the MINT repositiories, I thought I'd install it first to see if there is any change (even though you say it is intended basically for Mac users and its maintenance has stopped). No change.

So I installed rEFInd after adding the rodsmith/refind repository (with commands from http://www.rodsbooks.com/refind/installing.html#ppa). I rebooted and saw that nothing changed, I still could get grub loader only after the recovery process I describe above.
Note that during the installation of rEFInd, I noted the following from the logs:
Code: Select all
EFI was mounted at /boot/efi
(indeed a /boot/efi was created during installation, but it remains empty).

Anyways, with Secure Boot disabled, Boot Mode UEFI, and Fast Boot disabled, I managed to get the rEFInd boot loader. There is the Ubuntu icon, which, if selected boots Linux Mint correctly, and there are four other icons: All of them look like the Windows icon, but with none can I boot to Windows, in particular (those are the comments appearing below the icons in the boot loader):
    1. a blue windows icon: EFI/Microsoft/bootmgw.efi SYSTEM
    Recovery; You PC needs to be repaired. A required device isn't connected or can't be accessed [...]
    2. a colorful windows icon: EFI/Boot/BootX64.EFI SYSTEM
    Recovery; You PC needs to be repaired. A required device isn't connected or can't be accessed [...]
    3. a colorful windows icon: BOOTMGR.EFI SAMSUNG_REC
    Starting BOOTMGR.EFI. Using load options ''. Error: Unsupported while loading BOOTMGR.EFI
    4. a colorful windows icon: EFI/Asclepius/BOOTX64.EFI SAMSUNG_REC
    Recovery. Wait [...this leads to the sequence of screens that attempt recovery (about 10 min) that allowed to boot to Linux before I installed rEFInd...]
Given that I was now able to easily boot to Linux, and since none of the windows icons was able to get me to Windows (and since the /boot/efi directory was empty), I followed your advice to Tom above, and updated grub. This is the response I got in the terminal:
Code: Select all
 $ sudo update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-37-generic
Found initrd image: /boot/initrd.img-3.13.0-37-generic
  No volume groups found
Found Windows Boot Manager on /dev/sda2@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done
If I give the same command again, the response is exactly the same, as if the previous update-grub did not really add "boot menu entry for EFI firmware configuration".

The /boot/efi directory remains empty. According to your previous responses, I suspect that the Windows boot manager has to be moved somewhere in the directory /boot/efi, but I have not idea how to get it from /dev/sda2@/efi/Microsoft/Boot/bootmgfw.efi.

Finally, the command efibootmgr gives the following:
Code: Select all
 $ sudo efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001
Boot0001* Windows Boot Manager  HD(X,XXXXX,XXXXX,XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.X.X.X.X.X.X.X.X.-.X.X.X.X.-.X.X.X.X.-.X.X.X.X.-.X.X.X.X.X.X.X.X.X.X.X.X}................[?]
(X represents any alphanumeric character.)

With the /boot/efi directory still being empty, I have no idea where the EFI and the EFI/Microsoft directories could possibly be located. I would appreciate any idea that could help me figure out how (and if) I can boot to Windows. Thanks in advance.
despo
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 17, 2013 3:30 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby srs5694 on Mon Mar 23, 2015 10:28 pm

Despo,

Try this after booting Mint via rEFInd:

Code: Select all
sudo parted /dev/sda print


Look for the partition with the "boot flag" set and that uses a FAT filesystem. It will probably be /dev/sda1 or /dev/sda2, but it might be something else. Mount that partition at /boot/efi, as in:

Code: Select all
sudo mount /dev/sda1 /boot/efi


(You can make this permanent by creating an entry in /etc/fstab.)

You should then see the EFI boot loader directory tree. There will probably be a file called /boot/efi/EFI/Microsoft/Boot/refind.conf. If so, you should then be able to do this:

Code: Select all
sudo mvrefind.sh /boot/efi/EFI/Microsoft/Boot /boot/efi/EFI/refind


This will move the rEFInd installation from where it went in your BIOS-mode install of it to a more conventional location. The BIOS-mode install caused rEFInd to "hijack" the Windows boot loader, and this command will restore the Windows boot loader and move rEFInd out of the way.

It's conceivable that the Windows boot loader is getting confused when it's called from EFI/Microsoft rather than from EFI/Microsoft/Boot. If so, this command will restore Windows to bootability. OTOH, it could be that something else is interfering with Windows' ability to boot, in which case this procedure won't help.

Also, when you examine your parted output, look for any other FAT partition. Some manufacturers create multiple FAT partitions and arrange their boot loaders in strange ways on them. In fact, given the rEFInd descriptions you posted, it's almost certain that your system has at least two such partitions, one called SYSTEM and the other called SAMSUNG_REC. The former probably holds your regular Windows boot loader and the latter probably holds Samsung's recovery tools, but I can't be 100% positive of that.
srs5694
Level 6
Level 6
 
Posts: 1084
Joined: Mon Feb 27, 2012 1:42 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby despo on Sat Mar 28, 2015 5:45 pm

Again thank you very much for all the advice and ideas. I followed your last message, and the result was this:

After I saw that the boot flag was on sda2, I mounted it to /boot/efi:
Code: Select all
 $ sudo mount /dev/sda2 /boot/efi
Then I run the command
Code: Select all
 $ sudo mvrefind.sh /boot/efi/EFI/Microsoft/Boot /boot/efi/EFI/refind
It seemed to have worked (no "aborting" messages or anything), as the full boot loader directory tree was finally possible to see.

I rebooted, and the rEFInd boot loader appeared with a new icon (number 3 in the following list, which shows all the options there are):
  • 1. a blue windows icon: EFI/Microsoft/bootmgw.efi from SYSTEM
    Recovery; Your PC needs to be repaired. A required device isn't connected or can't be accessed [...]
  • 2. a colorful windows icon: EFI/Boot/BootX64.EFI from SYSTEM
    Recovery; Your PC needs to be repaired. A required device isn't connected or can't be accessed [...]
  • 3. a blue circular arrow EFI/refind/refind_x64.efi from SYSTEM
    Recovery. Wait [...this leads to the sequence of screens that attempt recovery (about 10 min) that allowed to boot to Linux before I installed rEFInd...]
  • 4. the ubuntu icon: boot\vmlinuz-3.13.0-37-generic from 19GB ext4 volume
    loads linux mint
  • 5. a colorful windows icon: BOOTMGR.EFI from SAMSUNG_REC
    Starting BOOTMGR.EFI. Using load options ''. Error: Unsupported while loading BOOTMGR.EFI
  • 6. a colorful windows icon: EFI/Asclepius/BOOTX64.EFI from SAMSUNG_REC
    Recovery. Wait [...this leads to the sequence of screens that attempt recovery (about 10 min) that allowed to boot to Linux before I installed rEFInd...]
So this new option did not help again. But: I had forgotten to mount /boot/efi to sda2 permanently, and so when I booted to Linux again, the directory /boot/efi was empty again. I mounted again
Code: Select all
 $ sudo mount /dev/sda2 /boot/efi
but when I ran mvrefind.sh:
Code: Select all
 $ sudo mvrefind.sh /boot/efi/EFI/Microsoft/Boot /boot/efi/EFI/refind
There doesn't seem to be a rEFInd installation at /boot/efi/EFI/Microsoft/Boot! Aborting!
And then I realised that although the EFI directory tree seemed to be complete, there was no /boot/efi/EFI/Microsoft/Boot/refind.conf.

So now what should I do? Should I anyway mount /dev/sda2 permanently to /boot/efi? Or should I try to run mvrefind.sh first?
By the way, I saw that the UUID of /dev/sda2 is not a 8chars-4chars-4chars-4chars-12chars, as in the other mounted (ext4) partitions. Instead the UUID of /dev/sda2 is 4characters-4characters. I guess that is due to the fact it not an ext4 partition, but will it cause any problem after I insert the corresponding line to /etc/fstab?
Any (more) ideas? Thanks a lot in advance!
despo
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 17, 2013 3:30 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby srs5694 on Sat Mar 28, 2015 8:50 pm

At this point I'd say you've basically got a Windows boot problem, and you're more likely to get help on a Windows forum. Chances are you'll need to use a Windows recovery tool (perhaps one of those you can get into from rEFInd) to restore your Windows boot loader to a usable state. Be aware, though, that doing so may cause the computer to boot straight to Windows, bypassing rEFInd. If this happens, you can use the bcdedit tool in Windows to set rEFInd back to its primary boot program state:

  1. Launch an Command prompt window as Administrator. (In Windows 7, you do this by right-clicking the Command Prompt icon and selecting the option to run as Administrator. I'm not sure about Windows 8, since I break out in hives whenever I use its UI.)
  2. In the Command Prompt window, type "bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi". This will restore rEFInd to its primary-boot-program status.
srs5694
Level 6
Level 6
 
Posts: 1084
Joined: Mon Feb 27, 2012 1:42 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby despo on Sat Mar 28, 2015 10:16 pm

So, since in no way can I boot to Windows (both of the things you proposed require using the command prompt as administrator in Windows), I can do nothing. I will try to mount /dev/sda2 to /boot/efi. If this does not work I think I will give up.
One last thing. Do you think there is any chance to change something, if I modify any bios settings, something different to my current combination that is Secure Boot disabled, Boot Mode UEFI, and Fast Boot disabled?
Thanks a lot!
despo
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 17, 2013 3:30 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby srs5694 on Sun Mar 29, 2015 2:55 pm

despo wrote:So, since in no way can I boot to Windows (both of the things you proposed require using the command prompt as administrator in Windows), I can do nothing.


Please re-read my previous post. You'll need to use a Windows recovery tool (one of those accessible from rEFInd or a downloadable CD-R or USB-based tool) to fix the Windows boot loader. This is a Windows issue and requires Windows expertise. This is a Linux forum, so for help on the Windows recovery you should ask on a Windows forum, where the expertise is.

Once this issue is fixed, you may end up booting straight to Windows. If so, I provided a procedure to get rEFInd working again. Those aren't two separate suggestions; it's a two-step procedure.

I will try to mount /dev/sda2 to /boot/efi.


If you mean you want to edit /etc/fstab to permanently mount /dev/sda2 to /boot/efi, then go right ahead. Doing so won't help you boot anything, but it will make the ESP more easily accessible from Linux.

One last thing. Do you think there is any chance to change something, if I modify any bios settings, something different to my current combination that is Secure Boot disabled, Boot Mode UEFI, and Fast Boot disabled?


It's unlikely that changing firmware settings will help, with one remote possible exception: If you fiddled with disk settings in the past (AHCI mode vs. non-AHCI mode, for instance), then that could be causing your Windows boot problems, and changing it back might help.
srs5694
Level 6
Level 6
 
Posts: 1084
Joined: Mon Feb 27, 2012 1:42 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby despo on Wed Apr 01, 2015 1:39 pm

Hello again,

Well I seem to have recovered Windows. What I did is the following. The original PC had Windows 8.1 on. As Windows are in the last few years shipped with no recovery CD/DVD and I I had not created a recovery USB drive, I found and installed an earlier version of Windows (Windows 8.). As you had predicted, the system was now able to boot only to Windows, not providing any kind of boot selection menu. But I will come to that later.

The thing is that after I saw Windows 8 was booting alright, I reboot and pressed F4 to get to recovery. This allowed me to recover the Windows 8.1. So it seems that what had happened was that at the time of partitioning during the Linux Mint installation, I had done some damage to the Windows partitions, but I had the Windows recovery partitions intact. So during this latest Windows installation the damage was fixed, and the Windows recovery was able to function and recover Windows 8.1.

Note that in the beginning, as well as now, the Windows lie in the beginning of the hard disk, while the two Windows recovery partitions lie in the end of the disk. The partition table was very sparse (in the sense that there were a lot of partitions, of which I tried to get the biggest one - thinking that it would be only data, which I had backed up already; this biggest partition was lying about in the middle of the hard disk; it was this that I formatted to ext4 partitions for Linux), and I guess this is what got me confused.

Anyway now I cannot boot to Linux. I did what you said, like getting into command prompt as administrator and typing
Code: Select all
bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi
but it did not help. I remember very little of DOS commands - does this "{bootmgr}" has to be substituted with something or is it exactly what I had to type?

Finally, as I know that my /home partition is intact, I don't mind to have to re-install Linux Mint, but I want to do this after I read and find information for dual booting on exactly this Samsung model. In any case, I think I managed to proselytize my friend into using Linux, as he now sees that it takes multiple time for Windows to do whatever Linux can do in a few seconds. :-) The only thing he can do better at Windows is play games.

Thanks a lot for everything!
despo
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 17, 2013 3:30 pm

Re: Samsung convoluted dual boot for Windows 8 and Mint 14

Postby srs5694 on Fri Apr 03, 2015 8:48 am

No, "{bootmgr}" should be typed exactly as that. I have two suggestions for recovery:

  • Try running through the complete Windows installation instructions for rEFInd. With any luck this will get things working. You'll either overwrite the existing rEFInd or install a fresh copy. If the latter, be sure to also install the appropriate EFI filesystem driver for your Linux installation.
  • Download the USB flash drive or CD-R version of rEFInd, boot with it, and re-install rEFInd in Mint. This will re-run the "efibootmgr" command and should fix the installation.
srs5694
Level 6
Level 6
 
Posts: 1084
Joined: Mon Feb 27, 2012 1:42 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: JOPETA and 15 guests