Install fails when the webcam is initialized

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Install fails when the webcam is initialized

Postby ioctlvoid on Sun Jan 27, 2013 2:19 pm

When I'm installing Linux Mint 14 (XFCE) on a 64-bit system, the installer fails at the point where it offers the option of taking a picture with the webcam. It seems the installer just completely crashes, I'm guessing there is a segfault in the kernel ring buffer -- I haven't checked.

I tried to install in "compatibility mode" but even this mode enables the webcam in the installer.

How do I disable this part of the installer so that I can install the OS?
ioctlvoid
Level 1
Level 1
 
Posts: 28
Joined: Tue Jan 08, 2013 9:23 am

Linux Mint is funded by ads and donations.
 

Re: Install fails when the webcam is initialized

Postby xenopeek on Sun Jan 27, 2013 3:10 pm

You have to try if you can disable the webcam before starting the installer. You do this with the modprobe -r command. Probably running:
Code: Select all
sudo modprobe -r uvcvideo

will disable the webcam.

Else please post the output of:
Code: Select all
lsmod

so we can help figure out which module is loaded for your webcam, that needs to be removed.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14505
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Install fails when the webcam is initialized

Postby ioctlvoid on Sun Jan 27, 2013 4:14 pm

xenopeek wrote:You have to try if you can disable the webcam before starting the installer. You do this with the modprobe -r command. Probably running:
Code: Select all
sudo modprobe -r uvcvideo

will disable the webcam.

Else please post the output of:
Code: Select all
lsmod

so we can help figure out which module is loaded for your webcam, that needs to be removed.


Thanks, this did the trick.
ioctlvoid
Level 1
Level 1
 
Posts: 28
Joined: Tue Jan 08, 2013 9:23 am


Return to Installation & Boot

Who is online

Users browsing this forum: borgward and 19 guests