Cannot install linux, "X server not correctly configured"??

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Cannot install linux, "X server not correctly configured"??

Postby blackdahlia on Sun Feb 03, 2013 5:04 am

So I been trying to install it. My laptop (Asus, running Win7) has no CD/DVD drive, and therefore I have to run it off a USB CD player, which isn't a problem. However, I burned the file to the disk like I was supposed to, and it said the X server is not correctly configured and it failed to post my graphical interface. I've tried this with a USB too, same result, and it's really really annoying, I've rebooted and rebooted and I've gotten the same message eight times now. I live in Jakarta, Indonesia, and I've been to lots of stores, but I can't find the OS installation disk anywhere. Had to specially buy a larger-space CD, which is called a DVD/RDL, if that is helpful. I have had the same result with USB and CD, it's incredibly irritating, and I really want to get started with this Linux business. I put a similar question up, to no answer. Can somebody please help?
blackdahlia
Level 1
Level 1
 
Posts: 2
Joined: Fri Feb 01, 2013 9:46 am

Linux Mint is funded by ads and donations.
 

Re: Cannot install linux, "X server not correctly configured

Postby kc1di on Sun Feb 03, 2013 6:46 am

Hello blackdahlia and welcome to Mint,

The problem your encountering may be because of your video card. and you may need to set the kernel parameter "nomodeset"
" nomodeset
The newest kernels have moved the video mode setting into the kernel. So all the programming of the hardware specific clock rates and registers on the video card happen in the kernel rather than in the X driver when the X server starts.. This makes it possible to have high resolution nice looking splash (boot) screens and flicker free transitions from boot splash to login screen. Unfortunately, on some cards this doesnt work properly and you end up with a black screen. Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

Note that this option is sometimes needed for nVidia cards when using the default "nouveau" drivers. Installing proprietary nvidia drivers usually makes this option no longer necessary, so it may not be needed to make this option permanent, just for one boot until you installed the nvidia drivers."

That being said here's a thread that will tell you how to do that:
http://forums.linuxmint.com/viewtopic.php?f=59&t=48077&p=277057&hilit=nomodeset#p277057
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1429
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA


Return to Installation & Boot

Who is online

Users browsing this forum: Greenpalmer, PatH57 and 14 guests