Windows doesn't boot after Mint 14 install

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Windows doesn't boot after Mint 14 install

Postby -mathsLin on Mon Feb 11, 2013 7:40 am

I installed Mint 14 and run this and still windows doesn't boot

b@b ~ $ sudo update-grub
[sudo] password for b:
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.5.0-17-generic
Found initrd image: /boot/initrd.img-3.5.0-17-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows NT/2000/XP (loader) on /dev/sda1
Found Microsoft Windows XP Home Edition on /dev/sda2
done
Last edited by -mathsLin on Mon Feb 11, 2013 12:19 pm, edited 1 time in total.
-mathsLin
Level 1
Level 1
 
Posts: 15
Joined: Wed Feb 06, 2013 3:25 pm

Linux Mint is funded by ads and donations.
 

Re: Windows doesn't boot after Mint 14 install

Postby jungle_boy on Mon Feb 11, 2013 11:57 am

You last defragmented windows before installing?. Use windows CD to recover the MBR, defragment and then reinstall Linux Mint.
LM16 Cinnamon (PC); LM14 Cinnamon with AMD Catalyst (notebook)
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1171
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Windows doesn't boot after Mint 14 install

Postby -mathsLin on Mon Feb 11, 2013 12:32 pm

I didn't defragment, I got windows to shrink the partition with Windows management.

Why do I need to reinstall mint? Any ideas why I windows didn't manage to boat after installing Mint?

here's my trace :

Code: Select all
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
 if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="Linux Mint 14 Cinnamon 32-bit, 3.5.0-17-generic (/dev/sda5)"

if [ x"${feature_menuentry_id}" = xy ]; then
   menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
   save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
     save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
   if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
   fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
   search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5  --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5   6a6b19f3-ec46-43b5-90b8-94aefd522856
 else
  search --no-floppy --fs-uuid --set=root 6a6b19f3-ec46-43b5-90b8-94aefd522856
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
   insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
 fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

 ### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
     set gfxpayload="$1"
    if [ "$1" = "keep" ]; then
        set vt_handoff=vt.handoff=7
    else
        set vt_handoff=
    fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
     if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
     fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry  'Linux Mint 14 Cinnamon 32-bit, 3.5.0-17-generic (/dev/sda5)' --class  linuxmint --class gnu-linux --class gnu --class os {
     recordfail
    gfxmode $linux_gfx_mode
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos5'
    if [ x$feature_platform_search_hint = xy ]; then
       search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5  --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5   6a6b19f3-ec46-43b5-90b8-94aefd522856
     else
      search --no-floppy --fs-uuid --set=root 6a6b19f3-ec46-43b5-90b8-94aefd522856
    fi
    linux    /boot/vmlinuz-3.5.0-17-generic root=UUID=6a6b19f3-ec46-43b5-90b8-94aefd522856 ro   quiet splash $vt_handoff
     initrd    /boot/initrd.img-3.5.0-17-generic
}
menuentry  'Linux Mint 14 Cinnamon 32-bit, 3.5.0-17-generic (/dev/sda5) -- recovery  mode' --class linuxmint --class gnu-linux --class gnu --class os {
    recordfail
     insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos5'
    if [ x$feature_platform_search_hint = xy ]; then
       search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5  --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5   6a6b19f3-ec46-43b5-90b8-94aefd522856
     else
      search --no-floppy --fs-uuid --set=root 6a6b19f3-ec46-43b5-90b8-94aefd522856
    fi
    echo    'Loading Linux 3.5.0-17-generic ...'
    linux    /boot/vmlinuz-3.5.0-17-generic root=UUID=6a6b19f3-ec46-43b5-90b8-94aefd522856 ro recovery nomodeset
     echo    'Loading initial ramdisk ...'
    initrd    /boot/initrd.img-3.5.0-17-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###
 
### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
    insmod part_msdos
    insmod ext2
     set root='hd0,msdos5'
    if [ x$feature_platform_search_hint = xy ]; then
       search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5  --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5   6a6b19f3-ec46-43b5-90b8-94aefd522856
     else
      search --no-floppy --fs-uuid --set=root 6a6b19f3-ec46-43b5-90b8-94aefd522856
    fi
    linux16    /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
     insmod part_msdos
    insmod ext2
    set root='hd0,msdos5'
    if [ x$feature_platform_search_hint = xy ]; then
       search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5  --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5   6a6b19f3-ec46-43b5-90b8-94aefd522856
     else
      search --no-floppy --fs-uuid --set=root 6a6b19f3-ec46-43b5-90b8-94aefd522856
    fi
    linux16    /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows NT/2000/XP (loader) (on /dev/sda1)' --class windows  --class os $menuentry_id_option 'osprober-chain-303D-2179' {
    insmod part_msdos
    insmod fat
    set root='hd0,msdos1'
     if [ x$feature_platform_search_hint = xy ]; then
      search  --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1  --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  303D-2179
    else
      search --no-floppy --fs-uuid --set=root 303D-2179
     fi
    drivemap -s (hd0) ${root}
    chainloader +1
}
menuentry 'Microsoft Windows XP Home Edition (on /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-chain-12503A48503A3339' {
     insmod part_msdos
    insmod ntfs
    set root='hd0,msdos2'
    if [ x$feature_platform_search_hint = xy ]; then
       search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2  --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  12503A48503A3339
     else
      search --no-floppy --fs-uuid --set=root 12503A48503A3339
    fi
    drivemap -s (hd0) ${root}
    chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
 ### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
 # the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
   source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
-mathsLin
Level 1
Level 1
 
Posts: 15
Joined: Wed Feb 06, 2013 3:25 pm

Re: Windows doesn't boot after Mint 14 install

Postby -mathsLin on Mon Feb 11, 2013 3:11 pm

Hi, does this help? what should I do? :)

Code: Select all
                Boot Info Script 0.61      [1 April 2012]


============================= Boot Info Summary: ===============================

 => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of
    the same hard drive for core.img. core.img is at this location and looks
    in partition 72 for .
 => No boot loader is installed in the MBR of /dev/sdf.
 => Syslinux MBR (3.61-4.03) is installed in the MBR of /dev/sdg.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows XP: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System: 
    Boot files:        /boot.ini /ntldr /NTDETECT.COM /COMMAND.COM

sda2: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows XP: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows XP
    Boot files:        /BOOT.INI /ntldr /NTDETECT.COM

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System: 
    Boot files:       

sda4: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  Unknown
    Boot sector info:

sda5: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info:
    Operating System:  Linux Mint 14 Nadia
    Boot files:        /boot/grub/grub.cfg /etc/fstab

sda6: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info:

sdf1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows XP: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System: 
    Boot files:       

sdg1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 4.03 2010-10-22 ........>..sr>.........;9...0...~.....~...f...M.f.f....f..0~....>E}.u......
    Boot sector info:  Syslinux looks at sector 4857814 of /dev/sdg1 for its
                       second stage. SYSLINUX is installed in the  directory.
                       No errors found in the Boot Parameter Block.
    Operating System: 
    Boot files:        /boot/grub/grub.cfg /syslinux.cfg
                       /efi/BOOT/grubx64.efi /ldlinux.sys
-mathsLin
Level 1
Level 1
 
Posts: 15
Joined: Wed Feb 06, 2013 3:25 pm

Re: Windows doesn't boot after Mint 14 install

Postby jungle_boy on Mon Feb 11, 2013 8:52 pm

-mathsLin wrote:I didn't defragment, I got windows to shrink the partition with Windows management.

Why do I need to reinstall mint? Any ideas why I windows didn't manage to boat after installing Mint?

GParted (linux) is better to shrink partitions than windows management.


Defraging windows and recovering MBR will lost GRUB; you don't need reinstall linuxmint, recovery GRUB is sufficient, but I don't know how to, I thing that reinstall mint is fast and easy.
Last edited by jungle_boy on Tue Feb 12, 2013 11:26 pm, edited 1 time in total.
LM16 Cinnamon (PC); LM14 Cinnamon with AMD Catalyst (notebook)
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1171
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Windows doesn't boot after Mint 14 install

Postby -mathsLin on Tue Feb 12, 2013 10:56 am

I see, so originally Grub was installed where the windows booter thing was. I will reinstall then. Maybe I should run this first:
http://windows.microsoft.com/is-IS/wind ... for-errors
-mathsLin
Level 1
Level 1
 
Posts: 15
Joined: Wed Feb 06, 2013 3:25 pm

Re: Windows doesn't boot after Mint 14 install

Postby -mathsLin on Tue Feb 12, 2013 5:30 pm

My laptop has 2 drives so I think it will be safer to install linux on the separate drive (I store my docs on here), do you agree?
-mathsLin
Level 1
Level 1
 
Posts: 15
Joined: Wed Feb 06, 2013 3:25 pm

Re: Windows doesn't boot after Mint 14 install

Postby jungle_boy on Tue Feb 12, 2013 11:34 pm

I agree with you.
LM16 Cinnamon (PC); LM14 Cinnamon with AMD Catalyst (notebook)
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1171
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Linny, palimmo and 16 guests